Jump to content
Калькуляторы

SIP телефония Sip через nat

Всем доброго времени суток, есть сип сервер с адресом 192.168.80.22 и микротик к которому его подключили с локальной сетью 192.168.136.0/24 в порт eth1 на котором сделал адрес 192.168.80.100. Включаю маскарад 192.168.80.0/24>192.168.136.0/24 и сип сервер становится доступен для 136.0, настраиваю на клиенте сип акк всё работает звонит и принимает голос идёт всё как надо, настраиваю второго клиента тоже всё ок, но внутри микротика 2 сип акка друг с другом связываются, но голоса не слышно, подскажите как правильно им дозвониться друг до друга.

Share this post


Link to post
Share on other sites

Убрать нат, сделать обычную маршрутизацию. Нахрена нат в двух приватных сетях.

Share this post


Link to post
Share on other sites

Убрать нат, сделать обычную маршрутизацию. Нахрена нат в двух приватных сетях.

с целью внедрять сип в любые сети + сделать интернет доступ в этих сетях

Edited by u2256

Share this post


Link to post
Share on other sites
с целью внедрять сип в любые сети + сделать интернет доступ в этих сетях

Садитесь. Два.

 

Правильный ответ: Надо сделать обычную маршрутизацию.

Ещё более правильный ответ: В начале нужно нарисовать картинку, что к чему и зачем подключено.

 

Дополнительное задание:

с целью внедрять сип в любые сети

Рассказать в подробностя, что имелось в виду.

Share this post


Link to post
Share on other sites
sip.pngsip сервер не выдаёт адреса, они прописываются в ручную, самая простая задача чтобы юзеры выходили в интернет через ISP и звонили беспрепятственно как во вне так и внутри сети через SIP.
Edited by u2256

Share this post


Link to post
Share on other sites

Для того, чтобы все звонили всем ВНУТРИ вашей сети особенных телодвижений предпринимать не нужно. Нужно удостоверится, что:

1. У юзеров default gateway указывает на микротик на адрес, повешенный на eth3.

2. На сип сервере default gateway указывает на микротик на адрес, повешенный на eth2.Как я понял, это 192.168.80.100

3. На микротике нужно УБРАТЬ всякие маскарады и прочее для 192.168.80.0/24 и 192.168.136.0/24

 

После этого внутри звонки пойду куда угодно. А вот чтобы звонки пошли СНАРУЖИ (со стороны isp)

нужен NAT, умеющий корректно натить сип. Как его извлечь на микротике, не подскажу. Не спец по этому изделию.

Share this post


Link to post
Share on other sites

2. На сип сервере default gateway указывает на микротик на адрес, повешенный на eth2.Как я понял, это 192.168.80.100

что если к настройкам sip сервера нет доступа?

 

А вот чтобы звонки пошли СНАРУЖИ (со стороны isp)

нужен NAT, умеющий корректно натить сип. Как его извлечь на микротике, не подскажу. Не спец по этому изделию.

 

Такой задачи нет

Edited by u2256

Share this post


Link to post
Share on other sites

3. На микротике нужно УБРАТЬ всякие маскарады и прочее для 192.168.80.0/24 и 192.168.136.0/24

если я уберу маскарад сип для 136 сети станет недоступен

Share this post


Link to post
Share on other sites
что если к настройкам sip сервера нет доступа?

Тогда никак. СИП сервер должен ЗНАТЬ, где искать своих клиентов.

 

Простой НАТ не проканает, ибо протокол СИП устроен таким образом, что для совершения звонка происходит два "коннекта". Первый - сигнализация. Это http подобный, текстовый протокол в котором Высокие Договаривающиеся Стороны договариваются о том, кто звонит, куда звонит, звонит ли вообще. И, помимо прочего, договариваются о адресах и портах на которые открывается RTP соединение, несущее голос.

 

Умный НАТ должен подглядывать в обмен сторон по сигнальному протоколу, понимать, на какие адреса/порты договорились стороны и заранее пробросить эти порты.

 

Такой задачи нет
звонили беспрепятственно как во вне так и внутри сети через SIP.

или крестик, или трусы.

Share this post


Link to post
Share on other sites
что если к настройкам sip сервера нет доступа?

Тогда никак. СИП сервер должен ЗНАТЬ, где искать своих клиентов.

а если таких сетей несколько?

 

Такой задачи нет
звонили беспрепятственно как во вне так и внутри сети через SIP.

или крестик, или трусы.

я имел ввиду как внутри микротика так и на телефоны за микротиком (простые атс)

Edited by u2256

Share this post


Link to post
Share on other sites

Вот у меня есть безумная идея на eth2 поставить адреса 80.101,80.102,80.103.. и разбросать каждого через свой адрес

Share this post


Link to post
Share on other sites
а если таких сетей несколько?

В точности также. Если на хосте шлюз смотрит в default, то всё, что не находится в его подсети или к чему хост не имеет явного маршрута, уходит на шлюз. Ибо, шлюзу (роутеру) виднее. Это называется Ласт Резорт Гейтвей. Ну, или, если по каким-то соображениям на сервере нельзя трогать default или его там по каким-то соображениям вообще быть не должно, то надо, тем или иным способом, заиметь на нём явные маршруты к нужным хостам/подсетям. Или руками или с помощью того или иного протокола динамической маршрутизации.

 

Вот у меня есть безумная идея на eth2 поставить адреса 80.101,80.102,80.103.. и разбросать каждого через свой адрес
Не ясно, что вы хотите, но, скорее всего не выйдет )))

Share this post


Link to post
Share on other sites
Вот у меня есть безумная идея на eth2 поставить адреса 80.101,80.102,80.103.. и разбросать каждого через свой адрес
Не ясно, что вы хотите, но, скорее всего не выйдет )))

к примеру беру я 2 разных микротика, настраиваю через нат, у первого микротика 80.100 адрес в сипе у второго 101, подключаю 1 клиента к первому микротику 1 клиента ко второму, звоню друг на друга всё ок. можно ли так выполнить на одном микротике?

Share this post


Link to post
Share on other sites
Вот у меня есть безумная идея на eth2 поставить адреса 80.101,80.102,80.103.. и разбросать каждого через свой адрес
Не ясно, что вы хотите, но, скорее всего не выйдет )))

к примеру беру я 2 разных микротика, настраиваю через нат, у первого микротика 80.100 адрес в сипе у второго 101, подключаю 1 клиента к первому микротику 1 клиента ко второму, звоню друг на друга всё ок. можно ли так выполнить на одном микротике?

 

Странные извращения, надеюсь никогда такого не увидеть.

 

Из вики микротика:

 

/ip firewall nat add chain=dstnat dst-address=11.11.11.0/24 \

action=netmap to-addresses=2.2.2.0/24

 

/ip firewall nat add chain=srcnat src-address=2.2.2.0/24 \

action=netmap to-addresses=11.11.11.0/24

Share this post


Link to post
Share on other sites
Вот у меня есть безумная идея на eth2 поставить адреса 80.101,80.102,80.103.. и разбросать каждого через свой адрес
Не ясно, что вы хотите, но, скорее всего не выйдет )))

к примеру беру я 2 разных микротика, настраиваю через нат, у первого микротика 80.100 адрес в сипе у второго 101, подключаю 1 клиента к первому микротику 1 клиента ко второму, звоню друг на друга всё ок. можно ли так выполнить на одном микротике?

 

Странные извращения, надеюсь никогда такого не увидеть.

 

Из вики микротика:

 

/ip firewall nat add chain=dstnat dst-address=11.11.11.0/24 \

action=netmap to-addresses=2.2.2.0/24

 

/ip firewall nat add chain=srcnat src-address=2.2.2.0/24 \

action=netmap to-addresses=11.11.11.0/24

я предупреждал что идея безумная)) что мне тут подставить? от кого кому проброс? и разве можно пробросить сразу на всю подсеть?

Edited by u2256

Share this post


Link to post
Share on other sites

А какой-нить сип прокси в сети с сип сервером не поможет ?

Share this post


Link to post
Share on other sites

А какой-нить сип прокси в сети с сип сервером не поможет ?

поможет всё, что заставит клиентов пользоваться и инетом с одного интерфейса и сипом с другого

вопрос как?

Edited by u2256

Share this post


Link to post
Share on other sites

Что за мания делать костыли, должна быть обычная маршрутизация

Share this post


Link to post
Share on other sites

Интересно, почему нет настроек до сип сервера? (Если ответ просто нет и все)

Возникает вопрос сип ворованный? :D

В сети с сипом пул IP можете получить?

Клиентами сип, что будет?

Share this post


Link to post
Share on other sites

Берете Cisco роутер, хоть б/у 2801, и настраиваете на нем CUBE.

Share this post


Link to post
Share on other sites

Интересно, почему нет настроек до сип сервера? (Если ответ просто нет и все)

Возникает вопрос сип ворованный? :D

В сети с сипом пул IP можете получить?

Клиентами сип, что будет?

теоретически доступ есть, главный инженер боится, что мы сип сервер сломаем) еще есть легенда, что его купили готовым вариантом и по этому страх сломать превыше всего, лично я предлагал свой сип сделать, чтоб понимать что к чему и править без страха) да ip пул можем, клиентами будут все, шлюзы, компы, андроиды

я уже готов начальство уговорить на настройку сип сервера, можно подробный конфиг под маршрутизацию описать? время поджимает, ученым срочно звонить надо))

Edited by u2256

Share this post


Link to post
Share on other sites

Вам просто нужно на сип сервере прописать обратный роут т.е. сеть с абонами 192.168.0.0/24 сеть сип сервера 192.168.1.0/24 IP сервера(192.168.1.1)

На сип сервере прописать, что сеть 192.168.0.0/24 находится за 192.168.1.2(ip микротика) в правилах фаервола запретить маскарадить в 192.168.1.0/24.

 

Должно работать.

Share this post


Link to post
Share on other sites

Вам просто нужно на сип сервере прописать обратный роут т.е. сеть с абонами 192.168.0.0/24 сеть сип сервера 192.168.1.0/24 IP сервера(192.168.1.1)

На сип сервере прописать, что сеть 192.168.0.0/24 находится за 192.168.1.2(ip микротика) в правилах фаервола запретить маскарадить в 192.168.1.0/24.

 

Должно работать.

я ничего не понял) хотябы из дано взять адреса уже бы понятней было)

Edited by u2256

Share this post


Link to post
Share on other sites
я ничего не понял)

Вам нужно нанять специалиста.

Share this post


Link to post
Share on other sites

Знаете поговорку "Тот же IP только в другой руке"

 

Советую почитать:

https://wiki.mikrotik.com/wiki/Manual:Simple_Static_Routing

 

Так же хорошо работает вот такой вариант:

https://www.google.ru/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8#q=routing+mikrotik

 

З.Ы. Наверное вам нужен был ответ в картинках или в командах?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this