Перейти к содержимому
Калькуляторы

Ограничение скорости на Mikrotik с помощью Simple Queues Правильный способ.

а еще вопрос, на родительских правилах и подродительских, может стоит чего увеличить? :-) а то вот получается у меня дерево с первым правилом типа главным и всем уже куча подглавных с диапазонами, может этим главным и подглавным стоит какие нить другие правила прописать?

 

и есть ли смысл поменять тип очереди на самом интерфейсе? счас стоит на всех ethernet-default

Изменено пользователем Olejon

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

На интерфейсе менять можно, но не всегда помогает. В принципе, если на интерфейс сразу навесить PCQ, могут быть улучшения, но не на всех устройствах. На некоторых получается так, что изменения с дефолта приводит к потерям пакетов.

 

От деревьев очередей лучше уйти. Если вам надо приоритезировать трафик внутри общего канала - нужно поставить еще один микротик перед основным шейпером со стороны интернета, и на нем обрабатывать трафик - это сразу сильно упрощает работу шейперов.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А сколько реально клиентов/трафика/пакетов CCR1036 может пережевать(юзать только для ограничения скорости) ?

Тарифы 1-2 мбита ...

Есть у кого реальные цифры ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

На таких тарифах, только шейпер, он 2-3 гига ограничит без проблем. Абонентов тут будет около 2000-4000.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Тем, кто ограничивает скорость на микротике в Simple Queues без использования деревьев очередей наверное сталкиваются с проблемой, когда при загрузке абонентом своего тарифа на всю увеличивается задержка, и появляются потери пакетов.

 

Что бы этого не происходило, нужно изменить стандартный тип шейпера default-small в разделе Queue Types, указав в нем тип шейпера PCQ со следующими параметрами:

 

Limit - 5000

Total Limit - 200000

Classifier - поставить все 4 галочки.

 

Или просто ввести команду в терминал:

 

/queue type
set [find name=default-small] kind=pcq pcq-classifier=src-address,dst-address,src-port,dst-port pcq-limit=5000KiB pcq-total-limit=200000KiB

 

После этого всем правилам шейпера будет автоматически присвоены новые параметры, вручную ничего у существующих и новых правил указывать не надо.

Во время работы правила новый трафик первые 1-5 секунд может идти с высокой задержкой, однако после этого времени задержка выравнивается и становится минимальной.

 

Например при использовании обычного типа PFIFO и 500 пакетов, задержка при полной нагрузке может достигать 400-600мс, при использовании PCQ первые 1-5 секунд задержка в районе 200-300, однако потом снижается до 1-20мс и поддерживается на этом уровне, пока поток трафика не прекратится.

 

@Saab95

Если открыть Simple Queues то вкладка Advanced показывает что используется Queue Type: default. Но в вкладке Total используется Total Queue Type: default-small. Так что же все таки используется и что править?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А если у меня PPPoE и данные по ограничению скорости прилетают из RADIUS? То тогда в pcq-limit и pcq-total-limit чего поставить?

Вам просто тип очереди изменить нужно. Радиус создает симплы с одним и тем же Queue Types, измените kind у используемого типа очереди (default-small) на необходимый.

 

Вот и я не пойму какой править, там default и default-small есть!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А если у меня PPPoE и данные по ограничению скорости прилетают из RADIUS? То тогда в pcq-limit и pcq-total-limit чего поставить?

Вам просто тип очереди изменить нужно. Радиус создает симплы с одним и тем же Queue Types, измените kind у используемого типа очереди (default-small) на необходимый.

 

Вот и я не пойму какой править, там default и default-small есть!

 

Вот что я имею в виду!

post-115583-019248600 1497274083_thumb.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

То, что вы указали - такого при нормальной настройки быть не может. Тут или в профиле PPP что-то указано, либо еще где-то. По умолчанию там везде default-small, этот тип и нужно перенастраивать на PCQ.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Да Вы правы, в в профиле PPP было неправильно указано.

Такой вопрос еще, Limit - 5000 указывать без "к"? Так как если ставлю просто 5000, он меняет на 5к. Так и должно быть?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Микротик сам ставит буквы, пересчитывает в нужную единицу измерения, что бы не было много нулей. Это нормальное явление.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Хорошо значит ставим просто 5000 без "к". Спасибо!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Можно использовать Simple Queue с PCQ и Queue Tree вместе?

Queue Tree для приоритета трафика!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@ Saab95

Или в этом случае Queue Tree вообще нужно отключить?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Деревья шейперов использовали ранее, когда делали приоритезацию протоколов и т.п. Сейчас в этом смысла нет, т.к. все равно маркировка не срабатывает из-за тех же торрентов, которые лезут по 80 портам, где идет как бы трафик веб сайтов=) И по многим другим исключениям. Поэтому шейпер разбивают на 2 этапа - первый это абонентский, второй (на отдельном устройстве) шейпит внешний канал оператора. Все симплы.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Поэтому шейпер разбивают на 2 этапа - первый это абонентский, второй (на отдельном устройстве) шейпит внешний канал оператора. Все симплы.

Нужно больше микротиков)))

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Конечно. Раньше как делали - создавали дерево очередей, а ограничение скорости шло по первым родителям этого дерева. Это хорошо работало, когда канал интернета был один. Но как быть, когда каналов 2? И у каждого своя пропускная способность и она разная? Вот тут и получается, что нужно уже 2 шейпера - основной для абонентов, и шейпер внешнего канала (если каналов больше, то и шейперов больше). Шейпер внешнего канала это простая запись в симплах, с ограничением на 10 процентов меньше скорости канала, тип шейпера - PCQ с классификаторами по всем IP и портам, размер буфера максимально возможный. Такая схема очень хорошо данные выставляет в приоритеты, получше всяких деревьев. И пинги в танчиках у абонентов очень хорошие, деревья шейперов такие дать не могут.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Допустим я уберу Queue Tree, что будет если клиент запустит торрент и забьет свой канал, и параллельно захочет открыть какую нибудь страницу? Сейчас у странице выше приоритет и она откроется, даже если он забил свой канал. Если я уберу Queue Tree будет ли также открываться страница? Так как если нет, то он будет звонить и выносить нам мозг что пропал интернет, не думая о том что у него запущен торрент.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Если вы сделаете тип шейпера в симплах PCQ как написано вверху, то клиент, запустив торрент, займет весь свой канал. Когда он откроет браузер и введет адрес страницы, то она откроется с задержкой в 2-3 секунды, потом если он опять нажмет на ссылку, то она откроется так же через 2-3 секунды. Если он запустит видео с ютуба - оно будет загружаться и прерываться не будет, канал в пределах скорости абонента поделится равномерно на все закачки. То есть любая новая закачка или попытка доступа в интернет сработает с не большой паузой, пока в очереди абонента не пройдут в интернет уже запланированные пакеты, а уже после новому соединению предоставят полосу для доступа.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

то клиент, запустив торрент, займет весь свой канал. Когда он откроет браузер и введет адрес страницы, то она откроется с задержкой в 2-3 секунды

ясно. И трахнет по полной мозг техподдержке

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Все нормально будет. Т.к. все эти приоритезации по старинке (с деревьями очередей) работают только в пределах одного устройства. А как быть, если шейперов более одного? например 3-5, которые разделяют между собой нагрузку от абонентов, или обслуживают локальную группу клиентов. В таких случаях невозможно определить итоговую скорость, под которую ограничивать канал, потому что внешние каналы могут быть медленные. А установка отдельного шейпера на выход не позволит делать приоритеты, т.к. первые, абонентские шейпера, уже ограничат трафик в общем потоке.

 

При использовании PCQ симплов можно использовать сколько угодно шейперов в цепочках.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

помогите пожалуйста правильно прописать правило ограничения скорости с приминением burst. Сейчас ограничение настроено вот так:

/ppp profile
add change-tcp-mss=no local-address=192.168.87.1 name=TARIF_1M only-one=yes \
    queue-type=default rate-limit=768k/1M use-compression=no use-encryption=no \
    use-mpls=no use-upnp=no
add change-tcp-mss=no local-address=192.168.87.1 name=TARIF_6M only-one=yes \
    queue-type=default rate-limit=768k/6M use-compression=no use-encryption=no \
    use-mpls=no use-upnp=no
Если создаю вот такое правило то оно ограничивает скорость на всех а не отдельно каждому:

/queue simple
add burst-limit=1M/7M burst-threshold=384k/3M burst-time=1m36s/1m36s max-limit=512k/4M name=speed_7 queue=default/default target=192.168.81.0/24
 

Изменено пользователем vasily

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Конечно оно будет ограничивать по всем адресам, включенным в указанную подсеть. То есть клиент как бы один с 254 адресами.

 

Скорость нужно ограничивать в секретах, тогда она будет работать по каждому абоненту своя. Если же стоит задача ограничивать скорость берстом, то ограничения скорости из профилей следует убрать, а само общее ограничение сделать средствами типа шейпера PCQ, тут в ограничении скорость не указывается, а в настройках типа шейпера указываете максимальную скорость на каждый поток.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В данный момент ограничения сделаны в профайл.и при создании абонента я выбирал тариф из профиля и ограничение создалось автоматом. Если вам не трудно напишите как правильно написать правило шейпера PCQ 

Изменено пользователем vasily

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас