Jump to content

BDCOM 3310 + Dlink + Opt82

Добрый день, форумчанам!

Возникла необходимость подключить один из домов по гибридной схеме

GePON OLT ---> GePON ONU ---> Dlink 3200 ---> Клиент

 

 

Но, у меня IP адреса раздаются DHCP сервером на основании порта свича доступа.

 

конфиг OLT:

GpoN3#sh run

Building configuration...

 

 

Current configuration:

!

!version 10.1.0E build 36566

service timestamps log date

service timestamps debug date

!

hostname GpoN3

port-protected 1

!

ip default-gateway 172.16.255.254

!

spanning-tree mode rstp

!

 

epon oam-version 1 0x21

epon oam-version 2 0x20

!

!!slot 0 89

interface GigaEthernet0/1

!

interface GigaEthernet0/2

!

interface GigaEthernet0/3

!

interface GigaEthernet0/4

!

interface GigaEthernet0/5

!

interface GigaEthernet0/6

switchport trunk vlan-allowed 1,121-125

switchport mode trunk

dhcp snooping trust

fiber-auto-config

!

interface EPON0/1

epon mpcp-registration-mode ctc 30

epon bind-onu mac f8f0.8214.041e 1

epon bind-onu mac f8f0.8214.042c 2

epon bind-onu mac f8f0.8214.042a 3

switchport mode trunk

switchport pvid 121

switchport protected 1

!

interface EPON0/1:1

!

interface EPON0/1:2

!

interface EPON0/1:3

!

interface EPON0/2

epon mpcp-registration-mode ctc 30

epon bind-onu mac f8f0.8214.0416 1

epon bind-onu mac f8f0.8214.0436 2

switchport mode trunk

switchport pvid 122

switchport protected 1

!

interface EPON0/2:1

!

interface EPON0/2:2

!

interface EPON0/3

epon mpcp-registration-mode ctc 30

epon bind-onu mac 8479.7323.8781 1

epon bind-onu mac f8f0.8214.041a 2

epon bind-onu mac fcfa.f716.65b4 3

epon bind-onu mac f8f0.8214.0410 4

switchport mode trunk

switchport pvid 123

switchport protected 1

!

interface EPON0/3:1

!

interface EPON0/3:2

!

interface EPON0/3:3

!

interface EPON0/3:4

!

interface EPON0/4

epon mpcp-registration-mode ctc 30

epon bind-onu mac f8f0.8214.0428 1

epon bind-onu mac f8f0.8214.042e 2

epon bind-onu mac f8f0.8214.0418 3

epon bind-onu mac f8f0.8214.0422 4

switchport mode trunk

switchport pvid 124

switchport protected 1

!

interface EPON0/4:1

!

interface EPON0/4:2

epon onu port 1 ctc vlan mode trunk 1 125

!

interface EPON0/4:3

!

interface EPON0/4:4

!

!!slot end

!

interface VLAN1

ip address 172.16.0.202 255.255.0.0

!

!

!

vlan 1,121-125

!

!

!

!

ip dhcp-relay snooping

ip dhcp-relay snooping information option format hn-type

ip dhcp-relay agent

ip dhcp-relay helper-address 172.25.1.65 vlan 121-124

!

!

ip http server

!

!

!

!

!

time-zone ALMT 6 0

ntp server 10.0.0.1

 

 

 

 

Итак, свич 3200 подключен за interface EPON0/4:2

epon onu port 1 ctc vlan mode trunk 1 125

 

 

Конфиг OLT упрощенно:

с каждого PON порта клиенты подключаются в вланы 121-124

125 влан предназначен для пользователей которые со свича 3200

 

все клиенты с этой OLT получают IP адрес динамически, а вот те, кто за 3200 - не получают

 

 

конфиг dhcp relay 3200:

enable dhcp_relay

config dhcp_relay hops 4 time 0

config dhcp_relay option_82 state enable

config dhcp_relay option_82 check enable

config dhcp_relay option_82 policy replace

config dhcp_relay option_82 circuit_id default

config dhcp_relay option_82 remote_id user_define 172.16.10.25

config dhcp_relay add ipif System 172.25.1.65

config dhcp_relay ports 1-26 state enable

 

 

Вопрос:

Можно ли сделать так, что бы OLT пропускала dhcp relay запросы и ответы через себя, ну и сделать так что бы данная схема заработала?

Share this post


Link to post
Share on other sites

Топтал эти грабли. Итог такой: в bdcom dhcp snooping включается глобально для всех вланов. И потому перехватывает все. Исправляться китайцы не собираются.

Share this post


Link to post
Share on other sites

Топтал эти грабли. Итог такой: в bdcom dhcp snooping включается глобально для всех вланов. И потому перехватывает все. Исправляться китайцы не собираются.

 

Поправьте, если ошибаюсь, свич 3200 ловит dhcp запрос - и к dhcp срверу уже отправляет юникастом, и по идее bdcom должен пропускать эти пакеты....

Share this post


Link to post
Share on other sites

Мы даже давали доступ на ОЛТ 3608 китайцам и они позже выпустили исправления в новых прошивках.

3608 пропускает чужие пакеты dhcp, но все равно заносит их к себе в список. Зачем я так и не понял.

 

3310 сказали старая, исправлять не будут.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.