Jump to content
Калькуляторы

selective qinq и cisco nexus 3000

Судя по документации nexus не умеет selective qinq или в каких-то версиях софта появилась его поддержка?

Share this post


Link to post
Share on other sites

N3K не умеет selective QinQ даже в NX-OS 7.x.

Share this post


Link to post
Share on other sites

Я вас категорически поздравляю. 7.0(3)I5(2) выложили на cisco.com:

 

QinQ, Private VLAN features:

- Q-in-Q + vPC on N3048

- Selective Q-in-Q on N3048 with/without VPC

- PVLAN (isolated) on a "forward" VLAN from Selective Q-in-Q on N3048 with/without VPC

- PVLAN VPC PO on 9500

Share this post


Link to post
Share on other sites

Я вас категорически поздравляю. 7.0(3)I5(2) выложили на cisco.com:

Здорово, а есть возможность слить для тех у кого нет TACa?

Share this post


Link to post
Share on other sites

Здорово, а есть возможность слить для тех у кого нет TACa?

К сожалению нет :( Но учитывая то что образ универсальный для нескольких платформ то скоро "пойдет по интернетам".

Share this post


Link to post
Share on other sites

- Selective Q-in-Q on N3048 with/without VPC

Действительно команды появились, на трафике не проверял. Увы, работает только одна selective QinQ трансляция:

(config-if)# sh run int e1/33
interface Ethernet1/33
...
 switchport mode dot1q-tunnel
 switchport vlan mapping 100-198 dot1q-tunnel 199
...
(config-if)# switchport vlan mapping 200-298 ?
 ,                   Multi range separator
 <1-3967,4048-4093>  Translated VLAN ID
 dot1q-tunnel        Selective dot1q-tunnel
 inner               Inner vlanid

(config-if)# switchport vlan mapping 200-298 dot1q-tunnel 299
ERROR: Eth1/33 : Conflicting vlan mapping dot1q-tunnel configuration on port(s) exists

В процессе обновления свитч предупреждал о "критических несовместимостях" новой ОС с работающей конфигурацией но не показывал в чем эти несовместимости выражаются. После обновления выяснилось что диапазон зарезервированных виланов вернулся к стандартным настройкам, на оборудовании в продакшене такой сюрприз был бы очень некстати.

Share this post


Link to post
Share on other sites

Коллеги, а получилось запустить Selective Q-In-Q на Nexus 3064 ?

Как работает свежий софт на этой железке вообще?

Share this post


Link to post
Share on other sites

В лабе работал но толку от одной трансляции мало, по сути это чуть измененный port-based QinQ.

7.0(3)I5(2) с "селективом" в продакшен не запускали.

Share this post


Link to post
Share on other sites

Спасибо за ответ!

 

Я тут пытаюсь обычный Q-In-Q прокинуть на Juniper MX. Не получается.

Темку даже не форуме Циски создал: https://supportforums.cisco.com/discussion/13350356/nexus-3064-and-juniper-mx-q-q-link

 

Может быть есть идеи?

Share this post


Link to post
Share on other sites
Ethernet interfaces in VLAN mode can have multiple logical interfaces. In CCC and VPLS modes, VLAN IDs from 1 through 511 are reserved for normal VLANs, and VLAN IDs 512 through 4094 are reserved for CCC or VPLS VLANs. For 4-port Fast Ethernet interfaces, you can use VLAN IDs 512 through 1024 for CCC or VPLS VLANs.

 

For encapsulation type flexible-ethernet-services, all VLAN IDs are valid.

Share this post


Link to post
Share on other sites

uxcr это для каких FPC на MX?

Share this post


Link to post
Share on other sites

Спасибо за ответ!

 

Я тут пытаюсь обычный Q-In-Q прокинуть на Juniper MX. Не получается.

Темку даже не форуме Циски создал: https://supportforums.cisco.com/discussion/13350356/nexus-3064-and-juniper-mx-q-q-link

 

Может быть есть идеи?

 

Все заработало, проблема оказалась на устройствах ниже. Никак не связанных с Juniper и Nexus.

 

set interfaces ae1 description -=Cisco=-

set interfaces ae1 stacked-vlan-tagging

set interfaces ae1 mtu 9192

set interfaces ae1 encapsulation flexible-ethernet-services

set interfaces ae1 aggregated-ether-options minimum-links 1

set interfaces ae1 aggregated-ether-options link-speed 1g

set interfaces ae1 unit 303 vlan-tags outer 303

set interfaces ae1 unit 303 vlan-tags inner 750

set interfaces ae1 unit 303 family inet address 10.110.0.30/24

 

interface Ethernet1/48

description access-switch-S2326

switchport mode dot1q-tunnel

switchport access vlan 303

speed 1000

switchport autostate exclude

 

 

interface port-channel1

description -=MX-960=-

switchport mode trunk

switchport trunk allowed vlan 303

speed 1000

Share this post


Link to post
Share on other sites

Коллеги, есть новости по этой теме? Или все так же одна трансляция?

Share this post


Link to post
Share on other sites

Друзья. А подскажите, пожалуйста, такой нюанс по 3064. Задача следующая:

Есть порт на Нексус, который смотрит на кольцо доступа. На этом порту трафик необходимо принимать следующим образом:

1. Трафик от обычных хомяков (C-VLAN 2XXX) мы должны мапить в S-VLAN 100;

2. Трафик от юриков (они разбиты по разным C-VLAN 3122, 2566 и т.д.) мы либо мапим отдельный S-VLAN 200, либо просто принимает транком (но это сингл таг будет) на этом порту;

Идея заключается в том, чтоб не гнать трафик L2VPN юриков на дистрибуцию/PE а сразу разрулить в рамках кольца.

 

К сожалению по примеру Cisco это сделать не удается.

https://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus3000/sw/interfaces/7_x/b_Cisco_Nexus_3000_Series_NX-OS_Interfaces_Configuration_Guide_7x/b_Cisco_Nexus_3000_Series_NX-OS_Interfaces_Configuration_Guide_7x_chapter_0111.html

switch(config)# interface port-channel201 
switch(config-if)# switchport vlan mapping dot1q-tunnel allowed-vlan 201-204
switch(config-if)# switchport vlan mapping 300-400 dot1q-tunnel 500 
switch(config-if)# spanning-tree port type edge trunk
switch(config-if)# spanning-tree bpdufilter enable
switch(config-if)# vpc 201

 

Пока получается сделать только 1 S-VLAN на весь порт. 

 

Есть у кого то рабочие примеры? Спасибо!

Share this post


Link to post
Share on other sites

@sind , тут где то по соседству собственно писали, что пока что можно один selective на порт и сделать. Мб в обновлениях допилят.

Share this post


Link to post
Share on other sites

@Avad0n Так писали. Только вот что значит этот 1 селектив...

Мне бы подошло по идеии: трафик с 3-10 ВЛАН-ов мапим в 10 S-VLAN, весь остальной трафик порта мапим в 20 S-VLAN. Это считается 2 селектива?)

Share this post


Link to post
Share on other sites

Как заворачивать во внешний тег, понятно. А как можно сделать, чтобы определённые вланы (исключения) не заворачивались во внешний тег, а просто пропускались как есть со своим одним тегом наверх?

Share this post


Link to post
Share on other sites

Вот я тебе влёт скажу как это сделать на длинке, а вот нексус в глаза не видел.

Т.е. на других вендорах такая задача реализуема

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this