Jump to content

Как найти, что подтормаживает на сервере? RHEL 4, Oracle 10g

Есть старый сервер с Oracle на RHEL4 (2 CPU, по 4 ядра).

К серверу смонтирован сетевой диск по iscsi, на который сохраняются бэкапы.

Сегодня что-то глюкнуло, сервер перегрузился и не смог проверить смонтированный раздел (т.к. пытался его подключить до того, как поднялась сеть).

Это я поправил, сейчас сервер загрузился и работает, но в нем наблюдается какая-то задумчивость - на ввод командой он реагирует задержкой, иногда в 5-10 секунд.

В top какой-то заметной загрузки CPU я не вижу, обычно CPU загружен не более 20%. Правда load average более 70, но для данного сервера это, мне кажется, нормально.

Подскажите, куда смотреть?

Share this post


Link to post
Share on other sites

iotop

atop

посмотреть что с вводом-выводом

проверьте тот сервер или хранилку с который цепляете диск, у хранилки явно проблемы

Share this post


Link to post
Share on other sites

Это СХД, на ней есть еще несколько томов, смонтированных на других серверах, там вроде бы никаких проблем нет. А там постоянный поток в 400-500 Mbps, там проблемы бы проявились сразу же.

В логах есть ошибки на /dev/sdb (/dev/sdb и /dev/sdc это iscsi-устройства), более криминального ничего не вижу.

С iotop и прочим на такой старой системе как RHEL4 сложновато, но попробую поставить.

Share this post


Link to post
Share on other sites

Перегрузил сервер.

Теперь вроде бы ничего не тормозит.

В логах периодически сыпется такое:

Dec 19 17:59:52 bm-db kernel: Buffer I/O error on device sdb, logical block 0
Dec 19 17:59:52 bm-db kernel: end_request: I/O error, dev sdb, sector 0
Dec 19 17:59:52 bm-db kernel: Buffer I/O error on device sdb, logical block 0
Dec 19 17:59:52 bm-db kernel:  unable to read partition table
Dec 19 17:59:52 bm-db kernel: Attached scsi disk sdb at scsi1, channel 0, id 0, lun 100
Dec 19 17:59:52 bm-db kernel:   Vendor: NETAPP    Model: INF-01-00         Rev: 0810
Dec 19 17:59:52 bm-db kernel:   Type:   Direct-Access                      ANSI SCSI revision: 05

Но /dev/sdb это вообще не том, на СХД подобные ресурсы имеют тип access.

Share this post


Link to post
Share on other sites

Ни у кого нет доступа к порталу RedHat?

Вроде бы эта проблема тут описана: https://access.redhat.com/solutions/18746

По крайней мере по описанию похоже, у меня как раз multipath.

Share this post


Link to post
Share on other sites

погляди multipath -ll

и потом multipath -ll mpathX для mpath-девайса который содержит /dev/sdb (смею предположить что mpath0).

 

PS Статья тут http://pastebin.ru/iy9uf43K

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.