Jump to content
Калькуляторы

Loopback на vlan + VRF

Появлялось желание назначить на коммутаторе 3750G адрес через Loopback на Vlan и запихнут его в VRF.

 

И вот лыжи встали:

1. Если Loopback повесить на Vlan не запихивая в VRF пинг 1 mc

2. Если Loopback повесить на Vlan и запихнуть в VRF пинг 286 mc

Edited by feeman

Share this post


Link to post
Share on other sites

Появлялось желание назначить на коммутаторе 3750G адрес через Loopback на Vlan и запихнут его в VRF.

 

И вот лыжи встали:

1. Если Loopback повесить на Vlan не запихивая в VRF пинг 1 mc

2. Если Loopback повесить на Vlan и запихнуть в VRF пинг 286 mc

Не совсем понятно, можете немного описать задачу?

Share this post


Link to post
Share on other sites

Пинг: 1 mc

3750# interface looopback0
3750(config-if)# ip address 10.0.0.10 255.255.255.255
3750(config-if)# exit

3750# interface Vlan3101
3750(config-if)# ip unnumbered Loopback0

 

Пинг: 286 mc

3750(config-vrf)# ip vrf management_network
3750(config-vrf)# rd 555:1
3750(config-vrf)#exit

3750# interface looopback0
3750(config-if)# ip address 10.0.0.10 255.255.255.255
3750(config-if)# exit

3750# interface Vlan3101
3750(config-if)# ip unnumbered Loopback0
3750(config-if)# ip vrf forwarding management_network
3750(config-if)# exit

Share this post


Link to post
Share on other sites

у меня ликинга нет, задержек тоже:

 

core#sh run int lo 2001

Building configuration...

 

Current configuration : 94 bytes

!

interface Loopback2001

ip vrf forwarding arenda

ip address 10.10.1.1 255.255.255.252

end

 

core#sh run int vlan 2001

Building configuration...

 

Current configuration : 125 bytes

!

interface Vlan2001

ip vrf forwarding arenda

ip unnumbered Loopback2001

ip access-group 2001 in

no ip unreachables

end

 

 

 

PING 10.10.1.1 (10.10.1.1): 56 data bytes

64 bytes from 10.10.1.1: icmp_seq=0 ttl=255 time=0.505 ms

64 bytes from 10.10.1.1: icmp_seq=1 ttl=255 time=2.424 ms

64 bytes from 10.10.1.1: icmp_seq=2 ttl=255 time=0.494 ms

64 bytes from 10.10.1.1: icmp_seq=3 ttl=255 time=1.112 ms

64 bytes from 10.10.1.1: icmp_seq=4 ttl=255 time=1.030 ms

64 bytes from 10.10.1.1: icmp_seq=5 ttl=255 time=1.302 ms

64 bytes from 10.10.1.1: icmp_seq=6 ttl=255 time=2.655 ms

64 bytes from 10.10.1.1: icmp_seq=7 ttl=255 time=1.630 ms

64 bytes from 10.10.1.1: icmp_seq=8 ttl=255 time=2.105 ms

64 bytes from 10.10.1.1: icmp_seq=9 ttl=255 time=2.224 ms

64 bytes from 10.10.1.1: icmp_seq=10 ttl=255 time=2.026 ms

Share this post


Link to post
Share on other sites

Почему в interface loopback не указан vrf?

Share this post


Link to post
Share on other sites

rz3dwy, а версия IOS'a у Вас какая?

 

Почему в interface loopback не указан vrf?

 

Поправьте, если ошибаюсь...

Loopback по смыслу такой же интерфейс как и Gigabitinterface1/0/1?

Если это так, то Gigabitinterface1/0/1 мы же не запихиваем в vrf ? а назначаем на него влан который находиться в vrf'е ...

Share this post


Link to post
Share on other sites

И на int lo и на int vlan пишите ip vrf management_network

Share this post


Link to post
Share on other sites

vurd,Спасибо Вам огромное!

Действительно, Вы были правы!

Share this post


Link to post
Share on other sites

rz3dwy, а версия IOS'a у Вас какая?

 

vurd (Сегодня, 10:59) писал:

Почему в interface loopback не указан vrf?

 

 

Поправьте, если ошибаюсь...

Loopback по смыслу такой же интерфейс как и Gigabitinterface1/0/1?

Если это так, то Gigabitinterface1/0/1 мы же не запихиваем в vrf ? а назначаем на него влан который находиться в vrf'е ...

 

WS-C3750G-24TS 12.2(50)SE3

 

На Gi1/0/1 не указывается vrf, если у вас интерфейс L2, т.е. switchport и на нем vlan's. Если же он используется как маршрутизирующий, то для указания таблицы маршрутизации тоже необходимо указывать ip forwarding vrf на нем.

Share this post


Link to post
Share on other sites

rz3dwy, Благодарствую за данное разъяснение!

Share this post


Link to post
Share on other sites

а можно глупый вопрос. зачем vlan на loopback?

кто мешает сделать просто другой лупбэк?

Share this post


Link to post
Share on other sites

WY6EPT Э-э-э тогда это будет ДРУГАЯ сеть уже, ведь сеть мы вешаем на Loopback в случаее ip unnumbered cisco.

Share this post


Link to post
Share on other sites

Не надо физический порт занимать транзитным "managment" вланом.

Share this post


Link to post
Share on other sites

Не надо физический порт занимать транзитным "managment" вланом.

Не понятно.

Поподробней можете описать чего вы хотите?

Просто действительно непонятен смысл конструкции:

"

3750# interface looopback0

3750(config-if)# ip address 10.0.0.10 255.255.255.255

3750(config-if)# exit

 

3750# interface Vlan3101

3750(config-if)# ip unnumbered Loopback0

"

Тут даже не /30 а /32 получается.

Share this post


Link to post
Share on other sites

Не очень понятно зачем unnumbered для /30.

А, блин, невнимальность. Это не топикстартер писал.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this