Перейти к содержимому
Калькуляторы

Infinet - Cisco настройка OSPF

подскажите как настроить ospf на инфинет правильно? сделал

 

ospf start

 

появилось

 

 ospf start
ospf interface eth0
ospf interface lo0
ospf interface null0
ospf interface rf5.0
ospf end

 

добавил

 

 ospf router
ospf  network 192.168.120.0/28 area 0.0.0.0

 

на cisco

 

router ospf 100
log-adjacency-changes
network 192.168.100.0 0.0.0.3 area 0
network 192.168.120.0 0.0.0.15 area 0

 

далее все должно идти по eigrp

 

router eigrp 5454
traffic-share min across-interfaces
redistribute connected metric 102400 1 255 1 1500
redistribute static metric 102400 1 255 1 1500
redistribute ospf 100 metric 102400 1 255 1 1500
passive-interface default
no passive-interface FastEthernet0/0
network 192.168.100.0 0.0.0.3
no auto-summary
neighbor 192.168.100.1 FastEthernet0/0

 

ospf точно начинает работать т.к. с самой дальней точки у которой подсеть 192.168.1.0/24 адрес 192.168.120.1 (висит на eth0 инфинета) доступно, а вот инфинет 192.168.120.1 не пингует 192.168.1.1

Изменено пользователем fractal

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Дайте пожалуйста вывод команды route -n

 

route -n это разве для cisco и infinet?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вообщем вот схема, в итоге конфигурация такая

 

Infinet

 

#Interfaces parameters
ifc lo0    127.0.0.1/32
ifc eth0   media auto mtu 1500 up
ifc eth0   192.168.100.1/24
ifc rf5.0  down
ifc rf5.0  192.168.200.1/28

 

#OSPF configuration
ospf start
ospf interface eth0
ospf interface lo0
ospf interface null0
ospf interface rf5.0
ospf router
ospf  passive-interface lo0
ospf  passive-interface null0
ospf  auto-interface rf5.0 area 0.0.0.0
ospf  network 192.168.100.0/24 area 0.0.0.0
ospf end

 

R3

 

interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/0/0
switchport access vlan 100
!
interface FastEthernet0/0/1
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
shutdown
!
interface FastEthernet0/0/2
!
interface FastEthernet0/0/3
!
interface FastEthernet0/1/0
!
interface FastEthernet0/1/1
!
interface FastEthernet0/1/2
!
interface FastEthernet0/1/3
!
interface Vlan1
no ip address
!
interface Vlan100
description -- mngt --
ip address 192.168.100.254 255.255.255.0
!
router eigrp 100
traffic-share min across-interfaces
redistribute connected metric 102400 1 255 1 1500
redistribute static metric 102400 1 255 1 1500
redistribute ospf 100 metric 102400 1 255 1 1500
passive-interface default
no passive-interface FastEthernet0/0
network 192.168.1.0 0.0.0.3
no auto-summary
neighbor 192.168.1.1 FastEthernet0/0
!
router ospf 100
log-adjacency-changes
traffic-share min across-interfaces
passive-interface default
no passive-interface Vlan100
network 192.168.1.0 0.0.0.3 area 0
network 192.168.100.0 0.0.0.255 area 0

 

R2

 

interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.2.1 255.255.255.252
duplex auto
speed auto
!
router eigrp 100
traffic-share min across-interfaces
redistribute connected metric 102400 1 255 1 1500
redistribute static metric 102400 1 255 1 1500
passive-interface default
no passive-interface FastEthernet0/0
no passive-interface FastEthernet0/1
network 192.168.1.0 0.0.0.3
network 192.168.2.0 0.0.0.3
no auto-summary
neighbor 192.168.1.2 FastEthernet0/0
neighbor 192.168.2.2 FastEthernet0/1

 

R1

 

interface FastEthernet0/0
ip address 192.168.2.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.3.1 255.255.255.252
duplex auto
speed auto
!
router eigrp 100
traffic-share min across-interfaces
redistribute connected metric 102400 1 255 1 1500
redistribute static metric 102400 1 255 1 1500
passive-interface default
no passive-interface FastEthernet0/0
network 192.168.2.0 0.0.0.3
no auto-summary
neighbor 192.168.2.1 FastEthernet0/0

 

с R1 пингуются все сети инфинета, а инфинет пингует только подсеть 192.168.1.0/30 и далее не ходит, если на инфинете прописать route add default 192.168.1.254 (Vlan100 - Управление инфинетом) то он начинает пинговать все сети

post-127249-066529800 1472233290_thumb.jpg

Изменено пользователем fractal

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Это всё очень хорошо, но можно всё таки на Инфинете выполнить route -n, чтобы увидеть импортированные маршруты

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Это всё очень хорошо, но можно всё таки на Инфинете выполнить route -n, чтобы увидеть импортированные маршруты

 

route -n нет такой команды говорит

 

net -r

 

Destination        Gateway               Flags       Refs   Use  Interface
default            192.168.100.254       UGS         1      407  eth0
192.168.1.0/30     192.168.100.254       UG3         0        0  eth0
10.33.97.0/30      link#3                UC          0        0  rf5.0
192.168.100.0/24   link#2                UC          0        0  eth0
192.168.100.1         00:04:35:00:d8:7f  UHL         0        0  lo0
192.168.100.254       00:23:33:d7:76:08  UHL         2     1925  eth0
127.0.0.1          127.0.0.1             UH          1       12  lo0
224.0.0.0/8        127.0.0.1             UGS         1    30541  lo0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

fractal

а почему у вас 2 ip из одной подсети 192.168.100.0 на разных интерфейсах, может оттого инфинет сети не пингует, что пытается их найти на lo0

 

я как бы в ospf не силён, но нужен ли он на интерфейсах lo0 и null0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

fractal

а почему у вас 2 ip из одной подсети 192.168.100.0 на разных интерфейсах, может оттого инфинет сети не пингует, что пытается их найти на lo0

 

я как бы в ospf не силён, но нужен ли он на интерфейсах lo0 и null0

 

это автоматически инфинет так сделал

 

так они не участвуют -

ospf passive-interface lo0

ospf passive-interface null0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Коллега, мы собираем у себя стенд, подобный вашему, чтобы разобраться, сходу увидеть проблему не вышло.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Коллега, мы собираем у себя стенд, подобный вашему, чтобы разобраться, сходу увидеть проблему не вышло.

 

тоже пока не понятно, если вместо инфинета ставить cisco для проверки ospf то все работает, и туда и обратно доступность есть

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Мы настроили на нашем стенде ваш сетап. Вот наши мысли:

1. Зачем настроено перераспределение маршрутов на R2 и R1? Предлагаю убрать.

2. На R3 сейчас все настроено таким образом, что в процесс EIGRP поступают маршруты из OSPF, но не наоборот. Поэтому на Инфинет нет информации о сетях 192.168.2.1/30 и 192.168.1.0/30

Если убрать на R1 вот эти куски:

redistribute connected metric 102400 1 255 1 1500

redistribute static metric 102400 1 255 1 1500

redistribute ospf 100 metric 102400 1 255 1 1500

и добавить вот этот:

router ospf 100

redistribute eigrp 100 metric 100 subnets

router eigrp 100

net 192.168.100.0 0.0.0.255

Тогда на Инфинете мы увидим упомянутые сети:

net -r

Routing tables

Destination Gateway Flags Refs Use Interface

127.0.0.1 127.0.0.1 UH 3 35 lo0

192.168.1.0/24 192.168.100.254 UG3 0 0 svi1

192.168.2.0/24 192.168.100.254 UG3 0 0 svi1

192.168.100.0/24 link#5 UC 0 0 svi1

192.168.100.254 link#5 UHL 2 0 svi1

224.0.0.0/8 127.0.0.1 UGS 1 1085 lo0

И сможем пропинговать дальний конец:

#1> ping 192.168.2.2

ping (192.168.2.2): 56 data bytes

64 bytes from 192.168.2.2: icmp_seq=0 ttl=253 time=50.322 ms

64 bytes from 192.168.2.2: icmp_seq=1 ttl=253 time=37.550 ms

64 bytes from 192.168.2.2: icmp_seq=2 ttl=253 time=37.796 ms

64 bytes from 192.168.2.2: icmp_seq=3 ttl=253 time=41.325 ms

64 bytes from 192.168.2.2: icmp_seq=4 ttl=253 time=43.793 ms

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Мы настроили на нашем стенде ваш сетап. Вот наши мысли:

1. Зачем настроено перераспределение маршрутов на R2 и R1? Предлагаю убрать.

2. На R3 сейчас все настроено таким образом, что в процесс EIGRP поступают маршруты из OSPF, но не наоборот. Поэтому на Инфинет нет информации о сетях 192.168.2.1/30 и 192.168.1.0/30

Если убрать на R1 вот эти куски:

redistribute connected metric 102400 1 255 1 1500

redistribute static metric 102400 1 255 1 1500

redistribute ospf 100 metric 102400 1 255 1 1500

и добавить вот этот:

router ospf 100

redistribute eigrp 100 metric 100 subnets

router eigrp 100

net 192.168.100.0 0.0.0.255

Тогда на Инфинете мы увидим упомянутые сети:

net -r

Routing tables

Destination Gateway Flags Refs Use Interface

127.0.0.1 127.0.0.1 UH 3 35 lo0

192.168.1.0/24 192.168.100.254 UG3 0 0 svi1

192.168.2.0/24 192.168.100.254 UG3 0 0 svi1

192.168.100.0/24 link#5 UC 0 0 svi1

192.168.100.254 link#5 UHL 2 0 svi1

224.0.0.0/8 127.0.0.1 UGS 1 1085 lo0

И сможем пропинговать дальний конец:

#1> ping 192.168.2.2

ping (192.168.2.2): 56 data bytes

64 bytes from 192.168.2.2: icmp_seq=0 ttl=253 time=50.322 ms

64 bytes from 192.168.2.2: icmp_seq=1 ttl=253 time=37.550 ms

64 bytes from 192.168.2.2: icmp_seq=2 ttl=253 time=37.796 ms

64 bytes from 192.168.2.2: icmp_seq=3 ttl=253 time=41.325 ms

64 bytes from 192.168.2.2: icmp_seq=4 ttl=253 time=43.793 ms

 

 

перераспределение у нас настроено, статик и конектед также нужны т.к. основной протокол у нас eigrp, по cisco вроде нашли проблему

 

1. как Вы верно заметили, забыли редистрибьют прописать в ospf из eigrp

2. неадекватная прошивка на Cisco, маршруты то появлялись то пропадали

 

Спасибо за оперативную сборку и проверку на стенде

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас