Jump to content
Калькуляторы

Различия BGP в Juniper и Cisco проблема с анонсом маршрутов

Добрый день, коллеги. Прошу совета, немного забрался в тупик.

CE клиента подключен к двум PE маршрутизаторам двух провайдеров. У обоих провайдеров бордером стоят Juniper. CE клиента тоже juniper и все работало нормально, сети анонсировались корректно. После того как CE вышел из строя поставили Cisco. После этого начались проблемы с анонсами маршрутов. Операторы не получают маршруты от CE клиента. Хотя на CE маршруты анонсируются. Ниже данные анонсов и конфиг циски. Подскажите если в конфиге чего то не хватает.

Centralniy_2#sh ip bgp sum

BGP router identifier 10.211.34.17, local AS number 3468

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

10.211.34.18 4 12389 339098 94615 956278 0 0 1w6d 14663

10.213.34.18 4 50928 768560 86222 956278 0 0 4w1d 10278

 

sh ip bgp neighbors 10.211.34.18 advertised-routes

BGP table version is 956285, local router ID is 10.211.34.17

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

 

Network Next Hop Metric LocPrf Weight Path

*> 10.34.166.0/24 0.0.0.0 0 32768 i

 

Total number of prefixes 1

 

sh ip bgp neighbors 10.213.34.18 advertised-routes

BGP table version is 956285, local router ID is 10.211.34.17

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

 

Network Next Hop Metric LocPrf Weight Path

*> 10.34.166.0/24 0.0.0.0 0 32768 i

 

Total number of prefixes 1

 

 

interface FastEthernet0/0

description Rostelekom

ip address 10.211.34.17 255.255.255.252

speed auto

full-duplex

no cdp enable

!

interface FastEthernet0/1

description LAN_UPFR

no ip address

speed auto

full-duplex

no cdp enable

!

interface FastEthernet0/1.1

description LAN_UPFR

encapsulation dot1Q 1 native

ip address 10.34.166.1 255.255.255.0

no cdp enable

!

interface FastEthernet0/1.20

description Megafon

encapsulation dot1Q 20

ip address 10.213.34.17 255.255.255.252

no cdp enable

!

router bgp 3468

bgp log-neighbor-changes

timers bgp 30 90

neighbor 10.211.34.18 remote-as 12389

neighbor 10.211.34.18 description Rostelekom-VPN

neighbor 10.211.34.18 timers 30 90

neighbor 10.213.34.18 remote-as 50928

neighbor 10.213.34.18 description Megafon

neighbor 10.213.34.18 timers 30 90

maximum-paths 2

!

address-family ipv4

neighbor 10.211.34.18 activate

neighbor 10.211.34.18 weight 300

neighbor 10.211.34.18 soft-reconfiguration inbound

neighbor 10.211.34.18 prefix-list bgp_out out

neighbor 10.211.34.18 route-map prepend-as in

neighbor 10.213.34.18 activate

neighbor 10.213.34.18 weight 200

neighbor 10.213.34.18 soft-reconfiguration inbound

neighbor 10.213.34.18 prefix-list BGP_out out

neighbor 10.213.34.18 route-map prepend-as in

maximum-paths 2

no auto-summary

no synchronization

network 10.34.166.0 mask 255.255.255.0

exit-address-family

!

ip forward-protocol nd

!

!

ip http server

!

!

ip prefix-list BGP_out seq 5 permit 10.34.166.0/24

Share this post


Link to post
Share on other sites

нормальный такой конфиг =) а не осталось конфига джунипера с вашей стороны?

Share this post


Link to post
Share on other sites

а вы у себя (на J ) получаете этот маршрут ? посмотрите может он в hidden сидит. Проверяйте почему он там , наверняка что-то не так анонсируете...

Share this post


Link to post
Share on other sites

нужен старый конфиг. а вышестоящие операторы делали диагностику? покажите sh ip bgp neighbors 10.211.34.18

может анонсировать не префикс листом, а route-map?

Share this post


Link to post
Share on other sites

Уберите нафик все тайминги в настройках циски, джун нормально подстроится по идее под ее собственные дефолтные

Share this post


Link to post
Share on other sites

Уберите нафик все тайминги в настройках циски, джун нормально подстроится по идее под ее собственные дефолтные

А при чем тут тайминги , 30/90 должно прекрасно согласовываться

Share this post


Link to post
Share on other sites

Уберите нафик все тайминги в настройках циски, джун нормально подстроится по идее под ее собственные дефолтные

А при чем тут тайминги , 30/90 должно прекрасно согласовываться

 

Формально да, как оно на деле черт его знает, я бы вообще для начала сделал бы простейший конфиг чтобы убедиться что все поднялось анонсируется и работает с каждым оператором по отдельности,

а потом бы уже начал закручивать гайки и смотреть что при этом происходит

Share this post


Link to post
Share on other sites

У вас вот эта строчка

neighbor 10.211.34.18 prefix-list bgp_out out

а префикс лист у вас

prefix-list BGP_out seq 5 permit 10.34.166.0/24

BGP большими буквами

 

А вот тут

*> 10.34.166.0/24 0.0.0.0 0 32768 i

меня смущает что next-hop 0.0.0.0.

 

Классическое clear bgp all? Возможно next-hop self ещё принудительно, но это как-то странно в этом случае.

Share this post


Link to post
Share on other sites

У вас вот эта строчка

neighbor 10.211.34.18 prefix-list bgp_out out

а префикс лист у вас

prefix-list BGP_out seq 5 permit 10.34.166.0/24

BGP большими буквами

 

А вот тут

*> 10.34.166.0/24 0.0.0.0 0 32768 i

меня смущает что next-hop 0.0.0.0.

 

Классическое clear bgp all? Возможно next-hop self ещё принудительно, но это как-то странно в этом случае.

 

а как по вашему local originated route выглядит (0.0.0.0)?

Share this post


Link to post
Share on other sites

а как по вашему local originated route выглядит (0.0.0.0)?

Возможно, я привык к другой железке, но у меня next-hop локальных маршрутов показывает на реальный адрес. Поэтому меня это и смутило.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this