Jump to content
Калькуляторы

IPTV juniper cisco pim

Приветствую, господа)

 

Имеем Juniper, который получает несколько каналов по msdp+pim от источника.

Имеем cisco, у которой есть линк c juniper'ом.

 

Задача отдать IPTV с juniper на cisco и с cisco абонам.

Делаю так:

Juniper:

interfaces {
   xe-0/0/0 {
       unit 1950 {
           description IPTV_DOWNLINK;
           vlan-id 1950;
           family inet {
               address 172.16.24.125/30;
           }
       }
   }
   lo0 {
       unit 0 {
           family inet {
               address 127.0.0.1/32;
               address 10.1.1.1/24;
           }
       }
   }
}
routing-options {
   multicast {
       ssm-groups 239.32.4.0/24;
       asm-override-ssm;
       forwarding-cache {
           timeout 60;
       }
   }
}
protocols {
   igmp {
       interface xe-0/0/0.1950 {
           version 2;
       }
       interface ae0.1132 {
           version 2;
       }
   }
   msdp {
       peer xxx.zzz.195.190 {
           local-address xxx.zzz.195.189;
       }
   }
   pim {
       rp {
           local {
               address 10.1.1.1;
               priority 5;
               hold-time 200;
               group-ranges {
                   239.32.4.0/24;
               }
               override;
           }
       }
       interface fxp0.0 {
           disable;
       }
       interface xe-0/0/0.1950 {
           mode sparse;
           version 2;
       }
       interface ae0.1132 {
           mode sparse;
           version 2;
       }
       interface lo0.0 {
           mode sparse;
           version 2;
       }
   }
}

 

Cisco:

ip multicast-routing 
ip multicast multipath
ip pim rp-address 10.1.1.1 IPTVDS override
!
interface Vlan1950
ip address 172.16.24.126 255.255.255.252
ip pim sparse-mode
end
!
interface Vlan10
ip address 10.20.30.1 255.255.255.0
ip pim sparse-mode
end
#show ip access-lists IPTVDS            
Standard IP access list IPTVDS
   10 permit 239.32.4.0, wildcard bits 0.0.0.255 (3627 matches)

 

Проблема собственно в чем. У абонента включенного в 10ый влан IPTV работает 10 минут, потом 10 минут не работает. Не могу понять в чем проблема. Подскажите куда рыть.

Share this post


Link to post
Share on other sites

за cisco ещё свитч есть? если да, то смотрите что там настроено в плане querier

Share this post


Link to post
Share on other sites

Свитч не при чем. Есть другой поток который приходит на циску по pim. И у абонента другой поток работает.

Да и напрямую с циски ситуация аналогичная, то есть, то нет. Причем настройки ни на циске ни на джуне не меняются.

Когда есть поток на циске видим следующее:

#show ip mroute 239.32.4.3
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
      L - Local, P - Pruned, R - RP-bit set, F - Register flag,
      T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
      X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
      U - URD, I - Received Source Specific Host Report,
      Z - Multicast Tunnel, z - MDT-data group sender,
      Y - Joined MDT-data group, y - Sending to MDT-data group
      V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.32.4.3), 00:35:53/stopped, RP 10.1.1.1, flags: SJC
 Incoming interface: Vlan1950, RPF nbr 172.16.24.125, Mroute
 Outgoing interface list:
   Vlan10, Forward/Sparse, 00:35:53/00:02:30

(xxx.zzz.195.1, 239.32.4.3), 00:02:26/00:00:33, flags: J
 Incoming interface: Null0, RPF nbr 0.0.0.0, Mroute
 Outgoing interface list:
   Vlan10, Forward/Sparse, 00:02:26/00:02:30

 

И когда потока нет:

#show ip mroute 239.32.4.3
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
      L - Local, P - Pruned, R - RP-bit set, F - Register flag,
      T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
      X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
      U - URD, I - Received Source Specific Host Report,
      Z - Multicast Tunnel, z - MDT-data group sender,
      Y - Joined MDT-data group, y - Sending to MDT-data group
      V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.32.4.3), 00:40:04/00:02:22, RP 10.1.1.1, flags: SJC
 Incoming interface: Vlan1950, RPF nbr 172.16.24.125, Mroute, Partial-SC
 Outgoing interface list:
   Vlan10, Forward/Sparse, 00:40:04/00:02:22, H

 

И еще. Когда есть поток, то на джунипере нагрузка цпу поднимается примерно на 10-15%

Edited by serg_sk

Share this post


Link to post
Share on other sites

Так. Есть новые подробности.

Прокинул просто влан с джунипера к абоненту и отдал мультик просто про igmp. Ситуация аналогичная. Поток то есть, то его нет. Циска тут уже не при чем. Это либо поставщик, либо какие-то настройки на джуне.

Осталось понять только какие и почему растет нагрузке на цпу на 15-20%, когда появляется поток.

Share this post


Link to post
Share on other sites

Юнипер знает маршруты до источников мультикаста? Загрузка может из-за этого быть. Аналог ip mroute в циске.

Share this post


Link to post
Share on other sites

sh route table inet.1

sh route table inet.2

show pim join

Share this post


Link to post
Share on other sites

Юнипер знает маршруты до источников мультикаста? Загрузка может из-за этого быть. Аналог ip mroute в циске.

Да.

 

wiseelf@KievMX5-T> show route table inet.1

inet.1: 18 destinations, 18 routes (18 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

224.0.0.0/4        *[Multicast/180] 3d 00:26:26
                     MultiResolve
224.0.0.0/24       *[Multicast/180] 3d 00:26:26
                     MultiDiscard
239.32.2.1,zzz.xxx.195.1/32*[PIM/105] 1d 13:55:31
                     Multicast (IPv4) Composite
239.32.2.3,zzz.xxx.195.1/32*[PIM/105] 1d 13:55:31
                     Multicast (IPv4) Composite
239.32.2.10,zzz.xxx.195.1/32*[PIM/105] 1d 13:55:31
                     Multicast (IPv4) Composite
239.32.2.33,zzz.xxx.195.1/32*[PIM/105] 1d 13:55:31
                     Multicast (IPv4) Composite
239.32.2.54,zzz.xxx.195.1/32*[PIM/105] 1d 13:55:31
                     Multicast (IPv4) Composite
239.32.2.146,zzz.xxx.195.1/32*[PIM/105] 1d 13:55:30
                     Multicast (IPv4) Composite
239.32.4.0/24      *[Multicast/180] 11:49:06
                     MultiResolve
239.32.4.1,zzz.xxx.195.1/32*[PIM/105] 11:40:58
                     Multicast (IPv4) Composite
239.32.4.3,zzz.xxx.195.1/32*[PIM/105] 11:40:58
                     Multicast (IPv4) Composite
239.32.4.3,172.16.24.126/32*[PIM/105] 14:52:01
                     Multicast (IPv4) Composite
239.32.4.5,zzz.xxx.195.1/32*[PIM/105] 00:00:53
                     Multicast (IPv4) Composite
239.32.4.59,zzz.xxx.195.1/32*[PIM/105] 1d 13:55:31
                     Multicast (IPv4) Composite
239.32.4.130,zzz.xxx.195.1/32*[PIM/105] 00:01:36
                     Multicast (IPv4) Composite
239.32.4.131,zzz.xxx.195.1/32*[PIM/105] 00:01:35
                     Multicast (IPv4) Composite
239.32.4.146,zzz.xxx.195.1/32*[PIM/105] 11:40:58
                     Multicast (IPv4) Composite
239.32.4.174,zzz.xxx.195.1/32*[PIM/105] 1d 13:55:31
                     Multicast (IPv4) Composite

wiseelf@KievMX5-T> show route table inet.2

wiseelf@KievMX5-T> show pim join
Instance: PIM.master Family: INET
R = Rendezvous Point Tree, S = Sparse, W = Wildcard

Group: 239.32.4.1
   Source: *
   RP: 10.1.1.1
   Flags: sparse,rptree,wildcard
   Upstream interface: Local

Group: 239.32.4.1
   Source: zzz.xxx.195.1
   Flags: sparse,spt
   Upstream interface: ae0.1132

Group: 239.32.4.2
   Source: zzz.xxx.195.1
   Flags: sparse,spt
   Upstream interface: ae0.1132

Group: 239.32.4.3
   Source: *
   RP: 10.1.1.1
   Flags: sparse,rptree,wildcard
   Upstream interface: Local

Group: 239.32.4.3
   Source: zzz.xxx.195.1
   Flags: sparse,spt
   Upstream interface: ae0.1132

Group: 239.32.4.3
   Source: 172.16.24.126
   Flags: sparse,spt
   Upstream interface: xe-0/0/0.1950

Group: 239.32.4.5
   Source: zzz.xxx.195.1
   Flags: sparse,spt
   Upstream interface: ae0.1132

Group: 239.32.4.74
   Source: zzz.xxx.195.1
   Flags: sparse,spt
   Upstream interface: ae0.1132

Group: 239.32.4.130
   Source: zzz.xxx.195.1
   Flags: sparse,spt
   Upstream interface: ae0.1132

Group: 239.32.4.131
   Source: zzz.xxx.195.1
   Flags: sparse,spt
   Upstream interface: ae0.1132

Group: 239.32.4.146
   Source: *
   RP: 10.1.1.1
   Flags: sparse,rptree,wildcard
   Upstream interface: Local

Group: 239.32.4.146
   Source: zzz.x.195.1
   Flags: sparse,spt
   Upstream interface: ae0.1132

Instance: PIM.master Family: INET6
R = Rendezvous Point Tree, S = Sparse, W = Wildcard

wiseelf@KievMX5-T>

Share this post


Link to post
Share on other sites

в inet.2 должны быть маршруты источников если не ошибаюсь.

иначе RPF не пройдет

Share this post


Link to post
Share on other sites

wiseelf@KievMX5-T> show route table inet.2

inet.2: 22 destinations, 22 routes (21 active, 0 holddown, 1 hidden)
+ = Active Route, - = Last Active, * = Both

10.1.1.0/24        *[Direct/0] 00:36:31
                   > via lo0.0
10.1.1.1/32        *[Local/0] 00:36:31
                     Local via lo0.0
.....
xxx.zzz.195.160/27  *[Direct/0] 00:36:31
                   > via ae0.1132
xxx.zzz.195.189/32  *[Local/0] 00:36:31
                     Local via ae0.1132
172.16.24.120/30   *[Direct/0] 00:36:31
                   > via xe-0/0/0.1949
172.16.24.121/32   *[Local/0] 00:36:31
                     Local via xe-0/0/0.1949
172.16.24.124/30   *[Direct/0] 00:36:31
                   > via xe-0/0/0.1950
172.16.24.125/32   *[Local/0] 00:36:31
                     Local via xe-0/0/0.1950
172.16.254.8/32    *[Local/0] 00:36:31
                     Reject

 

Сделал роутликинг с inet.0 в inet.2. Ситуация не поменялась.

Share this post


Link to post
Share on other sites

set proto msdp rib-group MCAST_RIB

set proto pim rib-group inet MCAST_RIB

set routing-opt rib-groups MCAST_RIB import-rib inet.2

 

а так

Share this post


Link to post
Share on other sites

Сделал. Так вообще пусто

wiseelf@KievMX5-T> show route table inet.2
wiseelf@KievMX5-T>

Share this post


Link to post
Share on other sites

что в логах на джуне в момент когда CPU подскакивает?

Share this post


Link to post
Share on other sites

Есть вот такие сообщения в логах

Jun 18 02:35:39 KievMX5-T jddosd[1484]: DDOS_PROTOCOL_VIOLATION_SET: Protocol resolve:mcast-v4 is violated at fpc 0 for 30 times, started at 2016-06-18 02:35:39 EEST
Jun 18 02:44:59 KievMX5-T jddosd[1484]: DDOS_PROTOCOL_VIOLATION_CLEAR: Protocol resolve:mcast-v4 has returned to normal. Violated at fpc 0 for 30 times, from 2016-06-18 02:35:39 EEST to 2016-06-18 02:39:59 EEST
Jun 18 03:10:14 KievMX5-T jddosd[1484]: DDOS_PROTOCOL_VIOLATION_SET: Protocol resolve:mcast-v4 is violated at fpc 0 for 31 times, started at 2016-06-18 03:10:14 EEST
Jun 18 03:22:29 KievMX5-T jddosd[1484]: DDOS_PROTOCOL_VIOLATION_CLEAR: Protocol resolve:mcast-v4 has returned to normal. Violated at fpc 0 for 31 times, from 2016-06-18 03:10:14 EEST to 2016-06-18 03:17:29 EEST
Jun 18 03:38:29 KievMX5-T jddosd[1484]: DDOS_PROTOCOL_VIOLATION_SET: Protocol resolve:mcast-v4 is violated at fpc 0 for 32 times, started at 2016-06-18 03:38:29 EEST

Однако, когда я мониторю, то поднятие нагрузки на цпу не совпадает с этими сообщениями.

Edited by serg_sk

Share this post


Link to post
Share on other sites

Сменили vlan и интерфейсную пару - все заработало.

 

Теперь есть еще вопрос.

Есть еще один поток, который я получаю по mbgp+msdp. Подскажите как мне его принять и раздать дальше по pim'у? )

Edited by serg_sk

Share this post


Link to post
Share on other sites

Апнем вопрос.

 

И так. Есть mbgp+msdp. Все установлено, все маршруты я получаю.

> show msdp peer 172.16.24.185 
Peer address    Local address   State       Last up/down Peer-Group   SA Count
172.16.24.185   172.16.24.186   Established     03:05:55              350/350

> show bgp summary group MBGP  
Groups: 8 Peers: 14 Down peers: 0
Table          Tot Paths  Act Paths Suppressed    History Damp State    Pending
inet.0               
                 596163     596161          0          0          0          0
inet.2               
                     16         16          0          0          0          0
Peer                     AS      InPkt     OutPkt    OutQ   Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped...
172.16.24.185         35297        364        396       0       0     3:00:33 Establ
 inet.2: 16/16/16/0

 

Пытаюсь все это отдать по пим или по igmp в влане 1955, но ничего не выходит.

> show configuration protocols pim 
rib-group inet mcast-rib;
assert-timeout 5;
rp {
   local {
       address 10.1.1.1;
       priority 5;
       hold-time 200;
       group-ranges {
           239.0.0.0/23;
       }
   }
   static {
       address 10.1.1.1 {
           group-ranges {
               239.0.0.0/23;
           }
       }
   }
}
interface fxp0.0 {
   disable;
}                                       
interface all {
   disable;
}
interface ge-1/0/0.1955 {
   mode sparse;
   version 2;
}

> show configuration protocols igmp   
interface all {
   disable;
}
interface ge-1/0/0.1955 {
   version 2;
   static {
       group 239.0.0.1 {
           group-count 500;
       }
   }
}
interface xe-0/0/3.137 {
   version 2;
   static {
       group 239.0.0.1 {
           group-count 500;
       }
   }
}

 

Куда рыть?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this