Jump to content
Калькуляторы

Juniper MX80, умер внутренний ssd disk По tftp и emergency usb flash не удается восстановить работоспособност

Железяка лежит на столе.

 

Так, я понимаю надо делать так:

1) Снимаем флешки-подключаем к другому компу и монтируем его.

2) находим файл passwd и стираем там пароль.

---

так делаем на обоих флешках.

--------------

 

 

Далее грузимся и заходим без пароля.

Я правильно понял?

-------------------

 

Это первый вариант

----------------------

 

Второй Вариант:

Берем обычные флешки ставим жун ос заново.

--------------------

 

А Почему консоль не работает? сейчас.

По идеи, если поставить новые флешки, то консоль должна ожить?

-------------

Share this post


Link to post
Share on other sites

Видите ли, при подключенной консоли, при включении juniper-а в любом случае должны отображаться строки вида:

 

I2C: ready

 

 

U-Boot 1.1.6 (Jun 10 2011 - 00:50:30)

 

CPU: 8572, Version: 2.1, (0x80e00021)

Core0: E500, Version: 3.0, (0x80210030)

Clock Configuration:

CPU0:1333 MHz, CPU1:1333 MHz, CCB: 533 MHz,

DDR: 267 MHz (533 MT/s data rate) (Synchronous), LBC: 33 MHz

L1: D-cache 32 kB enabled

I-cache 32 kB enabled

Board: MX5-T 1.10

CPLD: Version 0x1f

DRAM: Initializing - DDR: 2048 MB

Testing DRAM from 0x00000000 to 0x80000000

DRAM test phase 1:

DRAM test phase 2:

DRAM test passed.

Now running in RAM - U-Boot at: 0ffa0000

Enable CPLD Watchdog

POST: U-boot memory location PASSED

 

 

сообщающие о том, что идет проверка и инициализация аппаратной начинки. Если у Вас этого нет, но ос грузится и пингуется, то вероятно консоль погорела.

А там либо интерфейс, а может у Вас просто кабель испортился. У джуниперов нужно их родной подключать,с другими не заработает. Да и параметры скорости, четность, и т.п. должны быть верные: speed-9600, data bits - 8, stop bit - 1, harity - none, flow control - x0n/xoff. Погуглите начальную настройку джуноса через консольный порт.

 

Рихтовать надо не passwd, а /config/juniper.conf.gz. Конфиги архивированными хранятся.

Edited by DemonS

Share this post


Link to post
Share on other sites

У джуниперов нужно их родной подключать,с другими не заработает.

Пользуюсь одним кабелем для хождения на кошки и mx80. ЧЯДНТ? :-)

Share this post


Link to post
Share on other sites

У джуниперов нужно их родной подключать,с другими не заработает.

чушь

Share this post


Link to post
Share on other sites

Спасибо за инфу. Я как-то от циски не пробовал кабель, поэтому не владею инфой. Я пробовал от какого-то другого девайса, оно не заработало, и я сделал не совсем верный вывод.

Share this post


Link to post
Share on other sites

А если консоль выключена в конфиге, то и старт загрузки и вообще ничего не увижу?

Share this post


Link to post
Share on other sites

Имхо, при включении, что-то должно быть. До загрузки конфига еще 2 минуты. Тесты железа должны отобразиться.

Возможно, я ошибаюсь и многоуважаемые гуру меня поправят.

Share this post


Link to post
Share on other sites

Не много не в тему, но всё же спрошу тут. Должен прийти второй RE-S-1800X4-32G-S, хотели бы подключить его в дубль с первым. Какова правильная последовательность подключения, хотелось бы при этом обойтись без downtime.

Share this post


Link to post
Share on other sites
Джуны отличная железка, но время шатдауна у свича (в моем случае EX, и там полновесная freebsd похоже) и постоянные косяки при сбросе питания отбивают желание ставить их на необслуживаемые обьекты.
так j и запилил журнал для уфс во фряше специально для этого и дуалбут запилил. уже давно нет проблемы с хотрезетом. но грузятся они не быстро, но вряд ли тут дело во фряше.
Не много не в тему, но всё же спрошу тут. Должен прийти второй RE-S-1800X4-32G-S, хотели бы подключить его в дубль с первым. Какова правильная последовательность подключения, хотелось бы при этом обойтись без downtime.
это не ***ская циска 65/76, никакой магии не нужно. просто вставляешь второй SCB, в него RE и ждешь когда оно загрузится. проваливаешься в него и делаешь что угодно: обновляешь софт, рестартишь, синкаешь конфиг; затем настраиваешь редунданси и успех.

инструкцию, конечно, почитай перед экшном.

Share this post


Link to post
Share on other sites

так j и запилил журнал для уфс во фряше специально для этого и дуалбут запилил. уже давно нет проблемы с хотрезетом. но грузятся они не быстро, но вряд ли тут дело во фряше.

 

Не заметно. На днях у одного из небольших клиентов взорвался новый PDU (что-то нахалтурил местный поставщик, пробило кондер с неонкой в выключателе), итог традиционный:

--- JUNOS 15.1R2.9 built 2015-10-19 09:57:06 UTC                                                                                                                                                                    

***********************************************************************                                                                                                                                             
**                                                                   **                                                                                                                                             
**  WARNING: THIS DEVICE HAS BOOTED FROM THE BACKUP JUNOS IMAGE      **                                                                                                                                             
**                                                                   **                                                                                                                                             
**  It is possible that the primary copy of JUNOS failed to boot up  **                                                                                                                                             
**  properly, and so this device has booted from the backup copy.    **                                                                                                                                             
**                                                                   **                                                                                                                                             
**  Please re-install JUNOS to recover the primary copy in case      **                                                                                                                                             
**  it has been corrupted and if auto-snapshot feature is not        **                                                                                                                                             
**  enabled.                                                         **                                                                                                                                             
**                                                                   **                                                                                                                                             
***********************************************************************                                                                                                                                             

 

Такие грабли на EX регулярно, и на junos 12, и на 15.

Share this post


Link to post
Share on other sites
Джуны отличная железка, но время шатдауна у свича (в моем случае EX, и там полновесная freebsd похоже) и постоянные косяки при сбросе питания отбивают желание ставить их на необслуживаемые обьекты.
так j и запилил журнал для уфс во фряше специально для этого и дуалбут запилил. уже давно нет проблемы с хотрезетом. но грузятся они не быстро, но вряд ли тут дело во фряше.
Не много не в тему, но всё же спрошу тут. Должен прийти второй RE-S-1800X4-32G-S, хотели бы подключить его в дубль с первым. Какова правильная последовательность подключения, хотелось бы при этом обойтись без downtime.
это не ***ская циска 65/76, никакой магии не нужно. просто вставляешь второй SCB, в него RE и ждешь когда оно загрузится. проваливаешься в него и делаешь что угодно: обновляешь софт, рестартишь, синкаешь конфиг; затем настраиваешь редунданси и успех.

инструкцию, конечно, почитай перед экшном.

 

Вообще есть ли профит\отказоустойчивость от двух RE - master->backup ? Софт мы бы не хотели трогать, полагаю нам нужно влить на новый RE такой же софт как и не текущем? Как я понял нам нужен простейший вариант:

 

chassis {
redundancy {
routing-engine 0 master;
routing-engine 1 backup;
failover {
on-loss-of-keepalives;
on-disk-failure;
}
inactive: graceful-switchover;
}

 

Пните в меня документацией на дуал RE :)

Edited by hsvt

Share this post


Link to post
Share on other sites

Не много не в тему, но всё же спрошу тут. Должен прийти второй RE-S-1800X4-32G-S, хотели бы подключить его в дубль с первым. Какова правильная последовательность подключения, хотелось бы при этом обойтись без downtime.

1.вставляешь в слот, загружаешь

проверяешь статус командами sh chassis route-engine

 

2. проверяешь версию софта на новом RE

show version invoke on all routing engines

 

3. по необходимости приводить софт к общему виду с RE0

 

4. собираешь redundancy как ты описал

groups {
   re0 {
       system {
           host-name M9_MX960;
       }
       interfaces {
           fxp0 {
               unit 0 {
                   family inet {
                       address xxxxx/24;
                   }
               }
           }
       }
   }
   re1 {
       system {
           host-name M9_MX960_RE1;
       }
       interfaces {
           fxp0 {
               unit 0 {
                   family inet {
                       address xxxx/24;
                   }
               }
           }
       }
   }
}
apply-groups [ re0 re1 ];

routing-options commit synchronize
routing-options nonstop-routing
chassis {
   redundancy {
       graceful-switchover;
   }

 

 

5. проверяешь репликацию между RE

show task replication

 

Вообще есть ли профит\отказоустойчивость от двух RE - master->backup ?

профит есть с настроенным redundancy, тк при отказе одного RE FPC не ребутнутся для заливки нового FIB

Share this post


Link to post
Share on other sites

Народ, а подскажите по шейперу на junos, если навесить шейпер на /24, это будет сумарный на всю сеть или на каждый /32 ?

Share this post


Link to post
Share on other sites

Народ, а подскажите по шейперу на junos, если навесить шейпер на /24, это будет сумарный на всю сеть или на каждый /32 ?

на всю сеть

 

вот пример из соседних веток для /32

set firewall policer example1 if-exceeding bandwidth-limit 5m burst-size-limit 156250
set firewall policer example1 then discard
set firewall family inet prefix-action example1-s policer example1 subnet-prefix-length 24 source-prefix-length 32
set firewall family inet prefix-action example1-d policer example1 subnet-prefix-length 24 destination-prefix-length 32
set firewall family inet filter example1 term 1 from source-prefix-list example1
set firewall family inet filter example1 term 1 then prefix-action example1-s
set firewall family inet filter example1 term 2 from destination-prefix-list example1
set firewall family inet filter example1 term 2 then prefix-action example1-d
set policy-options prefix-list example1 10.10.10.10/32
set policy-options prefix-list example1 10.10.10.11/32
set policy-options prefix-list example1 10.10.10.12/32



set ge-1/1/1.1 family inet filter input example1
set ge-1/1/1.1 family inet filter output example1

Share this post


Link to post
Share on other sites

И так.

Консоль как не работала, так и не работает.

 

Сняли флешки подмонтировали к фре.

Сняли на всякий случай полный дамп флешки.

Попытались в конфиге снести строчку с паролем- не помогает логин инкоррект, пытались снести весь раздел аутентификации, тоже самое.

 

Блин куда грести дальше?

Ситуация в том , что пароль зашифрован в МД5 "с солью". Как быть?

Share this post


Link to post
Share on other sites

Саппорт купить :)

давно бы уже железку получили по RMA

Share this post


Link to post
Share on other sites

Блин куда грести дальше?

У Вас был только один пользователь, который root?

 

Саппорт купить :)

давно бы уже железку получили по RMA

Саппорт денег немеряно стоит. Нам выставили цену чуть больке 2к вечнозеленых. Покопавшись в инете стало ясно, что купить модули + доставка - 200 у.е.

Экономия - 90%. Саппорт будет куплен, если что-то более серьезное испортится. Что касается неотображаемой консоли, то тут скорее всего консолька погорела, тут только саппорт покупать.

Share this post


Link to post
Share on other sites

Блин куда грести дальше?

У Вас был только один пользователь, который root?

 

Саппорт купить :)

давно бы уже железку получили по RMA

Саппорт денег немеряно стоит. Нам выставили цену чуть больке 2к вечнозеленых. Покопавшись в инете стало ясно, что купить модули + доставка - 200 у.е.

Экономия - 90%. Саппорт будет куплен, если что-то более серьезное испортится. Что касается неотображаемой консоли, то тут скорее всего консолька погорела, тут только саппорт покупать.

 

Оно так не работает :)

1) покупка занимает ощутимое количество времени

2) он должен быть как минимум core plus, чтобы было RMA

3) За неиспользуемые года вам захотят насчитать штраф стоимостью в Core саппорт за это время

 

Политика конечно дурацкая, но получается менее геморней и дешевле платить. Ну и zip никто не отменял, с ним проще.

Share this post


Link to post
Share on other sites

И так.

Консоль как не работала, так и не работает.

 

Сняли флешки подмонтировали к фре.

Сняли на всякий случай полный дамп флешки.

Попытались в конфиге снести строчку с паролем- не помогает логин инкоррект, пытались снести весь раздел аутентификации, тоже самое.

 

Блин куда грести дальше?

Ситуация в том , что пароль зашифрован в МД5 "с солью". Как быть?

Попробуй добавить юзера с известным паролем

Вот для логина newuser, пароль 12-34-56-

      user newuser {
           uid 2100;                   
           class super-user;
           authentication {
               encrypted-password "$1$SqzkHrbx$DgZ15zV34mIaTVoRUGeSh."; ## SECRET-DATA
           }
       }

Share this post


Link to post
Share on other sites

И так.

Консоль как не работала, так и не работает.

 

Во-первых, надо убедиться, что нормально работает терминал и консольный кабель.

Гарантированно отключить flow control и установить параметры 8,1,none.

Хорошо поюзанный консольный кабель от cisco не контачит в разъеме MX80, поэтому

надо взять новый.

Подключаться к консольному порту желательно ноутбуком с отключенным внешним блоком питания.

Если, все-таки порт сожгли, можно воспользоваться портом auxillary.

Для этого в конфиге надо разрешить auxillary порт.

set system ports auxiliary type vt100

 

После загрузки Junos и конфига, можно пользоваться портом auxillary, как консольным.

Share this post


Link to post
Share on other sites

Хорошо поюзанный консольный кабель от cisco не контачит в разъеме MX80, поэтому

надо взять новый.

Подключаться к консольному порту желательно ноутбуком с отключенным внешним блоком питания.

Аргументируйте оба высказывания. Особенно второе.

Share this post


Link to post
Share on other sites

Если одна железка заземлена, а вторая - нет, а если еще и на разных фазах подключены... То возможны разные чудеса.

Share this post


Link to post
Share on other sites

Если одна железка заземлена, а вторая - нет, а если еще и на разных фазах подключены... То возможны разные чудеса.

это вы сейчас про ноутбук и консольный порт жунипера?

Share this post


Link to post
Share on other sites

Если, все-таки порт сожгли, можно воспользоваться портом auxillary.

Для этого в конфиге надо разрешить auxillary порт.

set system ports auxiliary type vt100

 

После загрузки Junos и конфига, можно пользоваться портом auxillary, как консольным.

Если получится, то это действительно выход из ситуации!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now