Jump to content
Калькуляторы

cisco 7206 и скачивание в один поток

Доброго времени суток, есть небольшой вопрос по цискам. Работаю в небольшом провайдере, имеем два разных аплинка, один на cisco 3845, второй на cisco 7206. Не так давно начали замечать, что через cisco 7206 при скачивании файлов в один поток скорость не поднимается выше 3-5 мегабит. В то же время через 3845 тот же самый файл скачивается в 10 раз быстрее. Меняли местами аплинки, патчкорды, проблема не в них. Priority queue не настроен. Настроено лишь bgp и access-lists одинаково на обоих устройствах. Ломаем голову, в чем может быть проблема. Версия прошивки на 7206: 12.4, 3845: 15.0.

Share this post


Link to post
Share on other sites

Так если меняли раутеры местами - и проблема на аплинке сохранилась - может быть проблема на стороне аплинка?

PS

аплинк по оптике? включите flowcontrol - и проверьте (либо наоборот). Если поможет - проблема в физике, если нет - и смена маршрутизатора не помогала - все вопросы в аплинкеру.

Share this post


Link to post
Share on other sites

Так если меняли раутеры местами - и проблема на аплинке сохранилась - может быть проблема на стороне аплинка?

PS

аплинк по оптике? включите flowcontrol - и проверьте (либо наоборот). Если поможет - проблема в физике, если нет - и смена маршрутизатора не помогала - все вопросы в аплинкеру.

 

Роутеры меняли местами, но проблема оставалась на одном роутере(7206), не зависимо от того, какой аплинк в данный момент находится в роутере. Аплинк по оптике.

Share this post


Link to post
Share on other sites

Покажите весь конфиг, кроме паролей конечно.

Share this post


Link to post
Share on other sites

Извиняюсь за возможно обидное предположение, но согласование дуплекса проверили?

Share this post


Link to post
Share on other sites

у оптики дуплекс по определению

Share this post


Link to post
Share on other sites

трансиверы проверяли? меняли местами?

Share this post


Link to post
Share on other sites

у оптики дуплекс по определению

а если с другой стороны конвертор?

Share this post


Link to post
Share on other sites

Какая разница? Именно в оптической среде полудуплекс не имеет никакого смысла

Share this post


Link to post
Share on other sites

Какая разница? Именно в оптической среде полудуплекс не имеет никакого смысла

однако бывает что порты встают в халф...

Share this post


Link to post
Share on other sites

вот на LinkSys SRW2048 при включенном автосогласовании:

# show int st e g23

Flow Link Back Mdix

Port Type Duplex Speed Neg ctrl State Pressure Mode

-------- ------------ ------ ----- -------- ---- ----------- -------- -------

g23 1G-Combo-F Half 1000 Enabled Off Up Disabled Off

 

вот явно указали скорость и дуплекс:

# show int st e g23

Flow Link Back Mdix

Port Type Duplex Speed Neg ctrl State Pressure Mode

-------- ------------ ------ ----- -------- ---- ----------- -------- -------

g23 1G-Combo-F Full 1000 Disabled Off Up Disabled Off

 

с другой стороны китайский медюк.

Share this post


Link to post
Share on other sites

Это бывает на комбо-портах.

И HD относится именно к конфигурации электрического порта.

На оптическом в любом случае FD.

ИМХО.

Share this post


Link to post
Share on other sites

Это бывает на комбо-портах.

И HD относится именно к конфигурации электрического порта.

На оптическом в любом случае FD.

ИМХО.

наверное на старом оборудовании тоже бывает

Share this post


Link to post
Share on other sites

Когда роутеры меняли местами, все патчкорды и оптические конвертеры автоматически тоже менялись местами, так что эту часть мы исключили. Конфиг сейчас подготовлю, выложу чуть позже.

Share this post


Link to post
Share on other sites

Проверьте согласование дуплекса на 7200. На ней это частая проблема. Просто sh int fa x/x и смотрите на дуплекс и счётчики ошибок. 100%, что проблема в этом.

Share this post


Link to post
Share on other sites

Проверьте согласование дуплекса на 7200. На ней это частая проблема. Просто sh int fa x/x и смотрите на дуплекс и счётчики ошибок. 100%, что проблема в этом.

Вы недавно сдавали экзамен на траблшутинг :)?

Я помню, когда-то duplex mismatch был там одним из самых популярных ответов.

Share this post


Link to post
Share on other sites

Именно в оптической среде полудуплекс не имеет никакого смысла

вообще-то имеет - такой же как и в коксе (на одной лямбде можно в обе стороны гонять траф). хотя, думаю, граблей там можно насобирать больше, чем получить профита, и применимо будет только на коротких линиях (несколько км), но все же...

 

какая утилизация проца? что будет если воткнуть в еще один порт какой-то медюк/медную сфп и погонять айперф?

 

и да, flow control стоит выключить. с ним могут быть волшебные глюки. особенно - на длинных линках.

Share this post


Link to post
Share on other sites

Но зачем?

2 канала вместо одного упаковать к примеру в забитый CWDM. хоть и полезность этого сравнима с полезностью полудуплекса на 100BaseT...

Share this post


Link to post
Share on other sites

Наконец то могу снова отправить еще 3 сообщения сегодня. В часы пик нагрузка на цпу роутера не превышает 60-70%.

 

 

c7206-1#sh run view full

Building configuration...

 

Current configuration : 41406 bytes

!

! Last configuration change at 10:47:25 MSK Wed Apr 27 2016 by san

! NVRAM config last updated at 14:29:27 MSK Tue Apr 26 2016 by san

!

version 12.4

no service pad

service timestamps debug datetime msec localtime

service timestamps log datetime localtime

service password-encryption

!

hostname c7206-1

!

boot-start-marker

boot-end-marker

!

logging buffered 24000

enable secret XXX

!

aaa new-model

!

aaa authentication login default local

!

aaa session-id common

clock timezone MSK 3

ip wccp web-cache redirect-list debtors

ip cef

!

ip domain name domain.ru

ip name-server 1.1.4.37

ip name-server 1.1.2.138

!

multilink bundle-name authenticated

!

username san password xxx

archive

path tftp://10.10.2.45/cisco/$H

time-period 1440

!

!

interface GigabitEthernet0/1

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

duplex auto

speed auto

media-type rj45

no negotiation auto

!

interface GigabitEthernet0/1.2

description intranet

encapsulation dot1Q 2

ip address 10.10.2.2 255.255.255.0 secondary

ip address 1.1.4.33 255.255.255.240

no ip redirects

no ip unreachables

no ip proxy-arp

ip ospf cost 10

vrrp 1 description vrrp1

vrrp 1 ip 1.1.4.33

vrrp 1 ip 10.10.2.2 secondary

no cdp enable

!

interface GigabitEthernet0/1.3

description intranet2

encapsulation dot1Q 3

ip address 1.1.4.193 255.255.255.224 secondary

ip address 10.10.16.209 255.255.255.240

no ip redirects

no ip unreachables

no ip proxy-arp

no cdp enable

!

interface GigabitEthernet0/1.951

encapsulation dot1Q 951

ip address 10.10.25.3 255.255.255.0 secondary

ip address 10.10.27.3 255.255.255.0 secondary

ip address 10.10.23.3 255.255.255.0

ip access-group ServicePorts out

no ip redirects

no ip unreachables

no ip proxy-arp

ip ospf cost 10

ip ospf priority 150

ip ospf mtu-ignore

no cdp enable

!

interface GigabitEthernet0/2

mtu 1504

bandwidth inherit 850000

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

duplex auto

speed auto

media-type rj45

no negotiation auto

no cdp enable

no mop enabled

!

interface GigabitEthernet0/2.18

encapsulation dot1Q 18

ip access-group block_in in

ip access-group debtorsnonwww out

no ip redirects

no ip unreachables

no ip proxy-arp

ip wccp web-cache redirect out

no cdp enable

!

interface GigabitEthernet0/3

ip address 2.2.2.2 255.255.255.252

ip access-group block_in in

ip access-group debtorsnonwww out

no ip redirects

no ip unreachables

no ip proxy-arp

ip wccp web-cache redirect out

duplex auto

speed auto

media-type rj45

no negotiation auto

no cdp enable

!

router ospf 100

router-id 10.10.23.3

log-adjacency-changes

redistribute connected metric-type 1 subnets

redistribute static metric 1 metric-type 1 subnets

network 10.10.23.0 0.0.0.255 area 0.0.0.0

default-information originate metric 1 metric-type 1

!

router bgp XXXXX

bgp router-id 10.10.25.3

bgp log-neighbor-changes

neighbor 10.10.25.8 remote-as 65000

... (20 private neighbors)...

 

neighbor 2.2.2.1 remote-as YYYYY

neighbor 2.2.2.1 update-source GigabitEthernet0/3

neighbor 2.2.2.1 timers 20 60

!

address-family ipv4

neighbor 10.10.25.8 activate

neighbor 10.10.25.8 default-originate route-map prepend2

neighbor 10.10.25.8 distribute-list ournet_10 in

neighbor 10.10.25.8 distribute-list ournet_10 out

... (20 private neighbors) ...

 

neighbor 2.2.2.1 activate

neighbor 2.2.2.1 weight 300

neighbor 2.2.2.1 prefix-list DefaultOnly in

neighbor 2.2.2.1 distribute-list AllowOurnetOut out

neighbor 2.2.2.1 route-map uplink out

 

no auto-summary

no synchronization

network 1.1.2.0 mask 255.255.255.0

network 1.1.3.0 mask 255.255.255.0

network 1.1.4.0 mask 255.255.255.0

network 1.1.5.0 mask 255.255.255.0

network 1.1.6.0 mask 255.255.255.0

network 1.1.7.0 mask 255.255.255.0

network 1.1.8.0 mask 255.255.255.0

network 1.1.9.0 mask 255.255.255.0

exit-address-family

!

address-family nsap

maximum-paths 2

no synchronization

exit-address-family

!

ip route 10.4.0.0 255.255.0.0 10.10.16.211

ip route 10.5.0.0 255.255.0.0 10.10.16.211

ip route 1.1.2.0 255.255.255.0 Null0

ip route 1.1.3.0 255.255.255.0 Null0

ip route 1.1.4.0 255.255.255.0 Null0

ip route 1.1.5.0 255.255.255.0 Null0

ip route 1.1.6.0 255.255.255.0 Null0

ip route 1.1.7.0 255.255.255.0 Null0

ip route 1.1.8.0 255.255.255.0 Null0

ip route 1.1.9.0 255.255.255.0 Null0

no ip http server

no ip http secure-server

!

!

ip access-list standard AllowOurnetOut

permit 1.1.2.0 0.0.0.255

permit 1.1.3.0 0.0.0.255

permit 1.1.4.0 0.0.0.255

permit 1.1.5.0 0.0.0.255

permit 1.1.6.0 0.0.0.255

permit 1.1.7.0 0.0.0.255

permit 1.1.8.0 0.0.0.255

permit 1.1.9.0 0.0.0.255

!

ip access-list standard ournet_10

deny 10.7.0.0 0.0.255.255

permit 1.1.2.0 0.0.7.255

permit 10.0.0.0 0.255.255.255

!

ip access-list extended ServicePorts

permit tcp 10.0.0.0 0.255.255.255 any eq telnet

permit tcp 10.0.0.0 0.255.255.255 any eq 22

permit tcp host 1.1.4.41 any

permit tcp host 1.1.4.39 any eq telnet

permit tcp host 1.1.4.39 any eq 22

... (30 rules) ...

permit tcp any host 1.1.4.44 eq 22

deny tcp any any eq 22

deny tcp any any eq telnet

permit ip any any

!

ip access-list extended debtors

deny ip host 1.1.4.196 any

deny tcp any host 1.1.4.38 eq www

deny ip host 1.1.4.50 any

permit tcp host 1.1.5.68 any eq www

permit tcp host 1.1.5.72 any eq www

permit tcp host 1.1.5.69 any eq www

.... (286 rules) ...

permit tcp host 1.1.5.131 any eq www

!

ip access-list extended debtorsnonwww

deny ip host 1.1.5.68 any

deny ip host 1.1.5.72 any

deny ip host 1.1.5.69 any

.... (286 rules) ....

deny ip host 1.1.5.131 any

permit ip any any

!

ip prefix-list DefaultOnly seq 10 permit 0.0.0.0/0

!

ip prefix-list subnet2 seq 10 permit 1.1.2.0/24

!

ip prefix-list subnet3 seq 10 permit 1.1.3.0/24

!

ip prefix-list subnet4 seq 10 permit 1.1.4.0/24

!

ip prefix-list subnet5 seq 10 permit 1.1.5.0/24

!

ip prefix-list subnet6 seq 10 permit 1.1.6.0/24

!

ip prefix-list subnet7 seq 10 permit 1.1.7.0/24

!

ip prefix-list subnet8 seq 10 permit 1.1.8.0/24

!

ip prefix-list subnet9 seq 10 permit 1.1.9.0/24

!

logging alarm informational

logging facility local0

logging source-interface GigabitEthernet0/1.2

access-list 10 permit 10.0.0.0 0.255.255.255

!

snmp-server view cutdown at excluded

snmp-server community community1 RW 10

!

snmp-server ifindex persist

snmp-server trap-source GigabitEthernet0/1.2

snmp-server location location1

no cdp run

!

route-map prepend2 permit 10

set as-path prepend XXXXX

!

route-map uplink permit 20

match ip address prefix-list subnet2

set as-path prepend XXXXX

!

route-map uplink permit 30

match ip address prefix-list subnet3

set as-path prepend XXXXX

!

route-map uplink permit 40

match ip address prefix-list subnet4

set as-path prepend XXXXX

!

route-map uplink permit 50

match ip address prefix-list subnet5

set as-path prepend XXXXX

!

route-map uplink permit 60

match ip address prefix-list subnet6

set as-path prepend XXXXX

!

route-map uplink permit 70

match ip address prefix-list subnet7

set as-path prepend XXXXX

!

route-map uplink permit 80

match ip address prefix-list subnet8

set as-path prepend XXXXX

!

route-map uplink permit 90

match ip address prefix-list subnet9

set as-path prepend XXXXX XXXXX

!

control-plane

!

gatekeeper

shutdown

!

line con 0

stopbits 1

line aux 0

stopbits 1

line vty 0 4

access-class 10 in

!

scheduler allocate 20000 1000

process cpu threshold type total rising 2 interval 60

ntp logging

ntp clock-period 17179793

ntp source GigabitEthernet0/3

ntp server 194.190.168.1

!

end

 

 

 

ip адреса и AS заменил на всякий случай.

Share this post


Link to post
Share on other sites

А если сделать negotiation auto на 0/0 - что будет?

show interfaces gigabitEthernet 0/1 покажите

Share this post


Link to post
Share on other sites

Интерфейса 0/0 на роутере нет, скинул 0/1

negotiation auto пробовали вчера, ничего не изменилось.

 

 

 

c7206-1>sh int GigabitEthernet 0/1

GigabitEthernet0/1 is up, line protocol is up

Hardware is BCM1250 Internal MAC, address is 00b0.4a5d.081b (bia 00b0.4a5d.081b)

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 137/255, rxload 15/255

Encapsulation 802.1Q Virtual LAN, Vlan ID 1., loopback not set

Keepalive set (10 sec)

Full-duplex, 1000Mb/s, media type is RJ45

output flow-control is XON, input flow-control is XON

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 1/75/2/0 (size/max/drops/flushes); Total output drops: 9

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 62421000 bits/sec, 26883 packets/sec

5 minute output rate 539324000 bits/sec, 68016 packets/sec

2060573550 packets input, 4152094755 bytes, 0 no buffer

Received 2477318 broadcasts, 0 runts, 0 giants, 0 throttles

3895 input errors, 0 CRC, 0 frame, 3895 overrun, 0 ignored

0 watchdog, 1217742 multicast, 0 pause input

0 input packets with dribble condition detected

1382600572 packets output, 415080464 bytes, 0 underruns

2 output errors, 0 collisions, 1 interface resets

0 babbles, 0 late collision, 0 deferred

2 lost carrier, 0 no carrier, 0 pause output

0 output buffer failures, 0 output buffers swapped out

 

c7206-1>sh int GigabitEthernet 0/1 switching

GigabitEthernet0/1

Throttle count 0

Drops RP 2 SP 0

SPD Flushes Fast 0 SSE 0

SPD Aggress Fast 0

SPD Priority Inputs 3128443 Drops 0

 

Protocol IP

Switching path Pkts In Chars In Pkts Out Chars Out

Process 2709661 195335515 1904042 146303658

Cache misses 34028 - - -

Fast 2059742455 462201669 1388360152 3800106344

Auton/SSE 0 0 0 0

 

Protocol DEC MOP

Switching path Pkts In Chars In Pkts Out Chars Out

Process 0 0 191 14707

Cache misses 0 - - -

Fast 0 0 0 0

Auton/SSE 0 0 0 0

 

Protocol ARP

Switching path Pkts In Chars In Pkts Out Chars Out

Process 1498535 85749748 152913 9786432

Cache misses 0 - - -

Fast 0 0 0 0

Auton/SSE 0 0 0 0

 

Protocol Other

Switching path Pkts In Chars In Pkts Out Chars Out

Process 118179 10994457 11432 685920

Cache misses 0 - - -

Fast 0 0 0 0

Auton/SSE 0 0 0 0

 

NOTE: all counts are cumulative and reset only after a reload.

 

 

 

Share this post


Link to post
Share on other sites

А под правила wccp этот трафик попадает?

Share this post


Link to post
Share on other sites

А под правила wccp этот трафик попадает?

 

Нет, не попадает, да и wccp у нас не используется пока, на этапе настройки находится.

Пока суть да дело, уже начинаем склоняться к приобретению 6500 циски вместо 7206. На SE100 поглядывали, но что то дороговато.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this