Jump to content
Калькуляторы

Quagga OSPF,RIP . Запустил параллельно RIPv2, теряет маршруты.

Добрый вечер, коллеги! Имеется простая схема. Border с nat и 2 браса (их больше, но это для примера) . Bras accel-ppp , PPPoE . Использую сейчас OSPF. уже почти по 10к маршрутов. Проблем пока нет, но мне кажется и как на форуме говорили, для /32 лучше использовать RIP.

 

 

Вообщем проблема с RIP v2. На каждом брасе , обычно больше 2к сессий. RIP почему-то принимает с каждого по 600-607 маршрутов(как будто ограничение какое-то)

 

Конфиг бордера


root@rnet:~# cat /etc/quagga/ripd.conf
!
! Zebra configuration saved from vty
!   2015/10/05 16:15:57
!
hostname border_rip
password *****
log stdout
!
key chain *****
key 1
 key-string quagga
!
interface eth5
ip rip authentication mode md5 auth-length old-ripd
ip rip authentication key-chain *****
!
router rip
version 2
default-information originate
network 172.31.0.0/27
!
line vty
!

 

 

 

PPPoE1

 

root@pppoe1:~# cat /etc/quagga/ripd.conf
!
! Zebra configuration saved from vty
!   2015/10/05 20:21:20
!
hostname PPPoE1_RIP
password  *****
log stdout
!
key chain  *****
key 1
 key-string quagga
!
interface bond0
ip rip authentication mode md5 auth-length old-ripd
ip rip authentication key-chain *****
!
router rip
version 2
redistribute kernel
redistribute connected
network 172.31.0.0/27
!
line vty
!

 

 

root@rnet:~# vtysh -e 'show ip route sum'

Route Source         Routes               FIB                  
kernel               10                   10                   
connected            254                  254                  
rip                  3674                 0                    
ospf                 8510                 8506                 
------
Totals               12448                8770                 

post-88211-035796000 1444071158_thumb.png

Share this post


Link to post
Share on other sites

я бы не стал, лучше все в bgp убрать. лучше всех подходит под такое количество маршрутов, и демон наверняка лучше вылизан чем рип

Share this post


Link to post
Share on other sites

Закрепите за каждым БРАСом свою большую серую сеть.

Потом на бордере пропишите эти сети статиком.

И OSPF не понадобится.

 

 

P.S. Обновите кваггу до самой последней версии (0.99.24.1)

Share this post


Link to post
Share on other sites

при более 15к маршрутов /32 (белые) перешли с ospf на bgp

рип пробовали и работало но остановились и внедрили bgp

Share this post


Link to post
Share on other sites

при более 15к маршрутов /32 (белые) перешли с ospf на bgp

рип пробовали и работало но остановились и внедрили bgp

Можете показать конфиг bgp ?

Share this post


Link to post
Share on other sites

bgp работает отлично, с кваггой на nat, сервера доступа cisco и mpd.

Share this post


Link to post
Share on other sites

У меня есть похожая проблема с RIP. Между 3 CCR маршруты распространяются нормально, а если в эту конфигурацию добавить quagga то Mikrotik от quagga получает все маршруты, а quagga от Mikrotik по 150-200 (из 500). Причем маршруты пропадают как то избирательно - то одни, то другие, хотя таймеры на всех устройствах одинаковые. Аналогичная проблема с Mikrotik и коммутатором D-Link.

Share this post


Link to post
Share on other sites

Покажите кто нибудь пример конифга на BGP для данной схемы

Share this post


Link to post
Share on other sites

... Использую сейчас OSPF. уже почти по 10к маршрутов. Проблем пока нет, но мне кажется и как на форуме говорили, для /32 лучше использовать RIP.

...

при более 15к маршрутов /32 (белые) перешли с ospf на bgp

Тоже на форуме часто видел такое утверждение, кто-то может объяснить откуда ноги растут?

т.к. /32 маршруты redistribute (т.е. external) то отсылки к сложности SPF будут неуместны, алгоритмическая сложность как у дистанс вектор.

Количество записей в FIB - не зависит от протокола... У ТС - проблем нет, но "кажется ... и говорили ...."

существует ли сейчас какая-либо объективная причина уходить от OSPF? или кто-то реально сталкивался с проблемами на софте младше 5ти лет?

Share this post


Link to post
Share on other sites

уходят не потому что начались проблемы, а потому что могут начаться проблемы. ospf устроен так что без тюнинга будет потреблять слишком много CPU. Варианты всегда в том чтобы либо продолжать агонию, либо сразу уйти на протокол готовый к подобному развитию ситуации, а именно большому количеству маршрутов. конечно всегда можно таймеры покрутить, сервер побольше поставить, но итог все равно один, так зачем тянуть

Share this post


Link to post
Share on other sites

существует ли сейчас какая-либо объективная причина уходить от OSPF? или кто-то реально сталкивался с проблемами на софте младше 5ти лет?

http://forum.nag.ru/forum/index.php?showtopic=63865

Сталкивался, с OSPF были проблемы, с RIP проблем нет до сих пор, хотя префиксы и загрузка выросли на порядок.

Share this post


Link to post
Share on other sites

существует ли сейчас какая-либо объективная причина уходить от OSPF? или кто-то реально сталкивался с проблемами на софте младше 5ти лет?

http://forum.nag.ru/forum/index.php?showtopic=63865

Сталкивался, с OSPF были проблемы, с RIP проблем нет до сих пор, хотя префиксы и загрузка выросли на порядок.

Так вот добавил RIP v2 и почему-то не все маршруты добавляются. На всех nas-ах их до 600 (как будто ограничение) . Можете показать свой конфиг quagga?

Edited by roysbike

Share this post


Link to post
Share on other sites

roysbike

hostname nas3-rip
password 8 XXXXX
enable password 8 XXXXXX
! log file /var/log/quagga/ripd.log
service password-encryption
!
!debug rip events
!debug rip packet
!
interface bond0.2
!
router rip
version 2
passive-interface default
no passive-interface bond0.2
network bond0.2
timers basic 60 180 120
distribute-list private-only in bond0.2
redistribute connected route-map rip-map
!
access-list zeus permit 1111/1
access-list zeus permit 2222/2
access-list zeus permit 3333/3
access-list zeus deny any
!
route-map rip-map permit 1
match ip address zeus
!
access-list private-only deny any

2-3к ppp сессий на этих серверах бывает, маршруты не теряются.

Share this post


Link to post
Share on other sites

roysbike

hostname nas3-rip
password 8 XXXXX
enable password 8 XXXXXX
! log file /var/log/quagga/ripd.log
service password-encryption
!
!debug rip events
!debug rip packet
!
interface bond0.2
!
router rip
version 2
passive-interface default
no passive-interface bond0.2
network bond0.2
timers basic 60 180 120
distribute-list private-only in bond0.2
redistribute connected route-map rip-map
!
access-list zeus permit 1111/1
access-list zeus permit 2222/2
access-list zeus permit 3333/3
access-list zeus deny any
!
route-map rip-map permit 1
match ip address zeus
!
access-list private-only deny any

2-3к ppp сессий на этих серверах бывает, маршруты не теряются.

 

Спасибо за конфиг. Но все равно не могу победить. Ровно 600 маршрутов добавляется и все. Больше 600 не хочет , не пойму что может мешать

Share this post


Link to post
Share on other sites

при более 15к маршрутов /32 (белые) перешли с ospf на bgp

рип пробовали и работало но остановились и внедрили bgp

Можете показать конфиг bgp ?

 

 

 

это на насе

 

router bgp 65000

redistribute connected route-map set-origin-igp

redistribute static route-map set-origin-igp

redistribute kernel route-map set-origin-igp

neighbor x.y.20.25 remote-as 65000

neighbor x.y.20.25 next-hop-self

neighbor x.y.20.25 prefix-list announce-in in

neighbor x.y.20.25 prefix-list announce-out out

!

ip prefix-list announce-out seq 10 permit x.y.z.0/19 le 32 (можна сделать чтобы только 32....)

ip prefix-list announce-out seq 20 deny 0.0.0.0/0 le 32

 

 

ip prefix-list announce-in seq 10 permit x.y.z.0/19 le 32

ip prefix-list announce-in seq 20 deny 0.0.0.0/0 le 32

!

route-map set-origin-igp permit 10

set origin igp

 

 

на бордере похоже но на бордере еще врублен роутрефлектор

Share this post


Link to post
Share on other sites

Поясните нубу, а зачем вообще на брасах\насах используют route server и тем более где pppoe ? На bordere понятно, bgp или ebgp с uplinkom ну и в своих сетях ещё может с кем. Или это так называемая внутренняя маршрутизация для уменьшения количества хопов?

 

уже почти по 10к маршрутов

 

Вы unnumbered не используете ведь?

Edited by hsvt

Share this post


Link to post
Share on other sites

Поясните нубу, а зачем вообще на брасах\насах используют route server и тем более где pppoe ? На bordere понятно, bgp или ebgp с uplinkom ну и в своих сетях ещё может с кем. Или это так называемая внутренняя маршрутизация для уменьшения количества хопов?

 

уже почти по 10к маршрутов

 

Вы unnumbered не используете ведь?

unnumbered использую и ухожу с PPPoE.Настроил BGP, все ок. Всем спасибо!

Edited by roysbike

Share this post


Link to post
Share on other sites

Поясните нубу, а зачем вообще на брасах\насах используют route server и тем более где pppoe ?

 

1) Если насов несколько, а клиентам выдаются IP из одного общего диапазона. При этом реальников сильно мало чтобы закрепить за каждым насом определенный диапазон статически.

2) Если насов несколько и клиент может подключиться к любому, при том что у него статический IP на PPPoE.

Edited by avb1987

Share this post


Link to post
Share on other sites

 

unnumbered использую и ухожу с PPPoE.Настроил BGP, все ок. Всем спасибо!

Та же проблема. Что только не испробовал - результат = 0..:(

Если не сложно, получившийся конфиг BGP для роутера и NAS-ов покажите, пожалуйста.

Share this post


Link to post
Share on other sites

AlKov

У некоторых версий quagga(на вскидку - от 0.99.15 до 0.99.22) есть беда с RIPv2, теряются маршруты. И эти кривые версии лежат в репах дистрибутивов, в центосе 6 точно кривая лежит.

У меня терялись случайным образом одиночные маршруты, собрал из сорцов с оффсайта свежую 0.99.24, все проблемы исчезли.

Share this post


Link to post
Share on other sites

 

unnumbered использую и ухожу с PPPoE.Настроил BGP, все ок. Всем спасибо!

Та же проблема. Что только не испробовал - результат = 0..:(

Если не сложно, получившийся конфиг BGP для роутера и NAS-ов покажите, пожалуйста.

Конфиг прост.

 

Border

!
! Zebra configuration saved from vty
!   2015/10/07 23:24:35
!
hostname Border_iBGP
password xxxx
log stdout
!
router bgp 64700
bgp router-id 172.31.0.30
neighbor 172.31.0.1 remote-as 64701
neighbor 172.31.0.2 remote-as 64702
neighbor 172.31.0.3 remote-as 64703
neighbor 172.31.0.4 remote-as 64704
neighbor 172.31.0.5 remote-as 64705
neighbor 172.31.0.6 remote-as 64706
neighbor 172.31.0.29 remote-as 64729
!
line vty
!

 

PPPoE1

!
! Zebra configuration saved from vty
!   2015/10/07 23:29:37
!
hostname PPPoE1_iBGP
password xxxx
enable password xxxx
log stdout
!
router bgp 64701
bgp router-id 172.31.0.1
redistribute kernel
redistribute connected
neighbor 172.31.0.3 remote-as 64703
neighbor 172.31.0.4 remote-as 64704
neighbor 172.31.0.5 remote-as 64705
neighbor 172.31.0.6 remote-as 64706
neighbor 172.31.0.29 remote-as 64729
neighbor 172.31.0.30 remote-as 64700
!
line vty
!

Share this post


Link to post
Share on other sites

Какой-то у вас конфиг повышенной хитрости. Несмотря на iBGP в камментах, у вас там полноценный eBGP :)

Что мешало сделать iBGP с одной автономкой везде? И для чего вообще серверам сессии друг с другом?

Share this post


Link to post
Share on other sites

А почему для каждого браса отдельная as?

Share this post


Link to post
Share on other sites

Сначала я хотел сделать iBGP , но чет не взлетело.

Share this post


Link to post
Share on other sites

я даже догадываюсь почему

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this