Jump to content
Калькуляторы

ERPro-8 DHCP-Relay как завести?Приветствую! Появилась надобность на ERPro-8 на bridge интерфейсе сделать dhcp-relay, делаю вот так: Код: set interface

Приветствую!

Появилась надобность на ERPro-8 на bridge интерфейсе сделать dhcp-relay, делаю вот так:

 

set interfaces bridge br0
set interfaces bridge br0 address dhcp
set interfaces ethernet eth3 bridge-group bridge br0
set interfaces ethernet eth4 bridge-group bridge br0
set interfaces ethernet eth5 bridge-group bridge br0
set interfaces ethernet eth6 bridge-group bridge br0
set interfaces ethernet eth7 bridge-group bridge br0

set service dhcp-relay interface br0
set service dhcp-relay interface eth1
set service dhcp-relay server 172.16.0.2

set service nat rule 5010 outbound-interface eth1
set service nat rule 5010 type masquerade

eth1 - получает ip адрес из сети 172.16.0.0 по DHCP;

 

 

 

но ни чего не работает... подскажите что не правильно?

 

 

P.S. если посмотреть tcpdump'ом - пакеты от моста через eth1 не проходят(и соответственно в логе dhcp-сервера ни чего нет)...

P.S.2. если на br0 поставить статический ip - тоже не помогает...

P.S.3. поправьте пожалуйста название темы

-----------------------------------------

Подумал, убрал маскарад, сделал вот так:

set firewall name br0local rule 10 action accept
set firewall name br0local rule 10 protocol udp
set firewall name br0local rule 10 destination port 67
set firewall name br0local rule 10 source port 68
set firewall name br0local rule 10 state new enable
set firewall name br0local rule 10 state established enable
set firewall name br0local rule 10 state related enable

set interfaces bridge br0 firewall local name br0local

set firewall name eth1local rule 10 action accept
set firewall name eth1local rule 10 protocol udp
set firewall name eth1local rule 10 destination port 67
set firewall name eth1local rule 10 source port 67
set firewall name eth1local rule 10 state established enable
set firewall name eth1local rule 10 state related enable

set interfaces ethernet eth1 firewall local name eth1local

set protocols static route 0.0.0.0/0 next-hop 172.16.0.2

результат тот же:

 0.0.0.0.68 > 255.255.255.255.67: [udp sum ok] BOOTP/DHCP, Request from xx:xx:xx:xx:xx:xx, length 375, xid 0x383c16bf, Flags [none] (0x0000)

и всё...

Edited by iTCenter

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this