Jump to content
Калькуляторы

cisco 4948-10g Высокая периодическая нагрузка на CPU

Периодически раз в 30 секунд примерно процессор уходит в полку и дропает пакеты.

Switch#sh proc cpu sort 1


CPU utilization for five seconds: 100%/0%; one minute: 55%; five minutes: 53%
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
101    92959752    612456     151783 90.72% 29.35% 24.89%   0 L2MM
 40    29712304 105135242        282  8.08% 13.50% 11.59%   0 Cat4k Mgmt HiPri
 41   112971776  61605586       1833  0.55% 11.69% 15.78%   0 Cat4k Mgmt LoPri
  4     1167652      9201     126904  0.00%  0.53%  0.37%   0 SpanTree Helper
  7     8790032    607558      14467  0.31%  0.29%  0.39%   0 Check heaps
122      333104  11956280         27  0.07%  0.11%  0.07%   0 PM Callback
 34      156052   2029798         76  0.07%  0.06%  0.07%   0 IDB Work
 72      301748   3728728         80  0.07%  0.03%  0.02%   0 CDP Protocol
 38      570652     40935      13940  0.00%  0.02%  0.00%   0 Per-minute Jobs
 77       39432    515483         76  0.07%  0.01%  0.00%   0 IP Input
 13      421264   2723763        154  0.07%  0.01%  0.00%   0 ARP Input
 64       16116   2442822          6  0.07%  0.00%  0.00%   0 UDLD
 83       11060   2442268          4  0.07%  0.00%  0.00%   0 CEF: IPv4 proces
 48        9052    412458         21  0.00%  0.00%  0.00%   0 Compute load avg
 27        1180    507306          2  0.00%  0.00%  0.00%   0 HC Counter Timer
 14           0         1          0  0.00%  0.00%  0.00%   0 AAA_SERVER_DEADT
 15           0         2          0  0.00%  0.00%  0.00%   0 AAA high-capacit
 12           4         1       4000  0.00%  0.00%  0.00%   0 ifIndex Receive
 16           0         1          0  0.00%  0.00%  0.00%   0 Policy Manager
 11           0         1          0  0.00%  0.00%  0.00%   0 Crash writer
 19          16     34747          0  0.00%  0.00%  0.00%   0 IPC Dynamic Cach
  8           0        11          0  0.00%  0.00%  0.00%   0 Pool Manager
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
 23        1036   2021620          0  0.00%  0.00%  0.00%   0 IPC Deferred Por
 17        1692        26      65076  0.00%  0.00%  0.00%   0 Entity MIB API
 18           0         1          0  0.00%  0.00%  0.00%   0 IFS Agent Manage
 26           0         1          0  0.00%  0.00%  0.00%   0 client_entity_se
 20           0         1          0  0.00%  0.00%  0.00%   0 IPC Zone Manager
 28           0         1          0  0.00%  0.00%  0.00%   0 SERIAL A'detect
 29           0         1          0  0.00%  0.00%  0.00%   0 ARP Snoop
 30        1580   2021620          0  0.00%  0.00%  0.00%   0 Dynamic ARP Insp
  9           0         2          0  0.00%  0.00%  0.00%   0 Timers
  2        1656    407885          4  0.00%  0.00%  0.00%   0 Load Meter
 10           0         2          0  0.00%  0.00%  0.00%   0 Serial Backgroun
  6           0         1          0  0.00%  0.00%  0.00%   0 IPC ISSU Receive
 35          12       723         16  0.00%  0.00%  0.00%   0 Logger
  5           0         1          0  0.00%  0.00%  0.00%   0 Retransmission o
 37        3156   2023049          1  0.00%  0.00%  0.00%   0 Per-Second Jobs
  3           0         1          0  0.00%  0.00%  0.00%   0 Deferred Events
 22           0         1          0  0.00%  0.00%  0.00%   0 IPC Managed Time
 21        1492   2021620          0  0.00%  0.00%  0.00%   0 IPC Periodic Tim
 24           0         1          0  0.00%  0.00%  0.00%   0 IPC Seat Manager
 42        3376    533720          6  0.00%  0.00%  0.00%   0 Galios Reschedul
 43           0         1          0  0.00%  0.00%  0.00%   0 IOS ACL Helper
 44           0         2          0  0.00%  0.00%  0.00%   0 NAM Manager
 45           0         2          0  0.00%  0.00%  0.00%   0 Switch IP Host T
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
 46          32         2      16000  0.00%  0.00%  0.00%   0 rf task
 47          16      1494         10  0.00%  0.00%  0.00%   0 Net Input
 25           0         1          0  0.00%  0.00%  0.00%   0 IPC Session Serv
 49          28      9113          3  0.00%  0.00%  0.00%   0 BACK CHECK
 31        1232   2021582          0  0.00%  0.00%  0.00%   0 GraphIt
 51           0         2          0  0.00%  0.00%  0.00%   0 cpf_process_msg_
 52           0         1          0  0.00%  0.00%  0.00%   0 cpf_process_ipcQ
 53           0         1          0  0.00%  0.00%  0.00%   0 AggMgr Process
 54           0         1          0  0.00%  0.00%  0.00%   0 SFF8472
 55           4         4       1000  0.00%  0.00%  0.00%   0 Collection proce
 56           0         3          0  0.00%  0.00%  0.00%   0 CEF switching ba
 57           0        17          0  0.00%  0.00%  0.00%   0 Dot1x Mgr Proces
 58           0         2          0  0.00%  0.00%  0.00%   0 802.1x Accountin
 59           4      4564          0  0.00%  0.00%  0.00%   0 802.1x switch
 60    60433436   2675324      22589  0.00%  0.00%  0.00%   0 DTP Protocol
 32           0         1          0  0.00%  0.00%  0.00%   0 Critical Bkgnd
 62          20     34876          0  0.00%  0.00%  0.00%   0 Port-Security
 63         168    206181          0  0.00%  0.00%  0.00%   0 Ethchnl
 33       12768    388088         32  0.00%  0.00%  0.00%   0 Net Background
 65           0         2          0  0.00%  0.00%  0.00%   0 Switch IP Host T
 36        1748   2021579          0  0.00%  0.00%  0.00%   0 TTY Background
 67           0         2          0  0.00%  0.00%  0.00%   0 ARP HA
 68           0         1          0  0.00%  0.00%  0.00%   0 IPv6 RIB Redistr
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
 69           0         2          0  0.00%  0.00%  0.00%   0 AAA Server
 70           0         1          0  0.00%  0.00%  0.00%   0 AAA ACCT Proc
 71           0         1          0  0.00%  0.00%  0.00%   0 ACCT Periodic Pr
 39           0         1          0  0.00%  0.00%  0.00%   0 ISSU PROCESS IPC
 73           0         1          0  0.00%  0.00%  0.00%   0 CEF IPC Backgrou
 74        2520   2080362          1  0.00%  0.00%  0.00%   0 NTP
 75           0         2          0  0.00%  0.00%  0.00%   0 AAA Dictionary R
 76          80     17768          4  0.00%  0.00%  0.00%   0 DHCP Snooping
  1         124      8936         13  0.00%  0.00%  0.00%   0 Chunk Manager
 78           0         1          0  0.00%  0.00%  0.00%   0 ICMP event handl
 80      709640   1017035        697  0.00%  0.00%  0.00%   0 Spanning Tree
 81        1060     44049         24  0.00%  0.00%  0.00%   0 CEF background p
 82           0         1          0  0.00%  0.00%  0.00%   0 IP IRDP
 50           0         1          0  0.00%  0.00%  0.00%   0  CHKPT rcv MSG p
 84          76      8835          8  0.00%  0.00%  0.00%   0 ADJ background
 85           0         3          0  0.00%  0.00%  0.00%   0 XDR mcast
 86           0         1          0  0.00%  0.00%  0.00%   0 IPC LC Message H
 87           0         1          0  0.00%  0.00%  0.00%   0 XDR RP Ping Back
 88          28     17419          1  0.00%  0.00%  0.00%   0 XDR RP backgroun
 89           0         1          0  0.00%  0.00%  0.00%   0 XDR RP Test Back
 90          16     26122          0  0.00%  0.00%  0.00%   0 Cluster L2
 91         260    206183          1  0.00%  0.00%  0.00%   0 Cluster RARP
 92          96      9545         10  0.00%  0.00%  0.00%   0 TCP Timer
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
 93           0        20          0  0.00%  0.00%  0.00%   0 TCP Protocols
 94           0         1          0  0.00%  0.00%  0.00%   0 COPS
 95           0         1          0  0.00%  0.00%  0.00%   0 Socket Timers
 96           4      6957          0  0.00%  0.00%  0.00%   0 HTTP CORE
 97           0         1          0  0.00%  0.00%  0.00%   0 Probe Input
 98           0         1          0  0.00%  0.00%  0.00%   0 RARP Input
 99           0         1          0  0.00%  0.00%  0.00%   0 MAB Framework
100           0         1          0  0.00%  0.00%  0.00%   0 802.1x Critical
 61           0         1          0  0.00%  0.00%  0.00%   0 EAP Framework
102       23472    717069         32  0.00%  0.00%  0.00%   0 MRD
103       58996   1142946         51  0.00%  0.00%  0.00%   0 IGMPSN
104           0         2          0  0.00%  0.00%  0.00%   0 L2TRACE SERVER
105           0         1          0  0.00%  0.00%  0.00%   0 IGMPSN-HA
106           0         1          0  0.00%  0.00%  0.00%   0 DHCP Snooping HA
107           0         1          0  0.00%  0.00%  0.00%   0 HSRP HA
108        1820     47849         38  0.00%  0.00%  0.00%   0 IP Background
109         156     34744          4  0.00%  0.00%  0.00%   0 IP RIB Update
110           0         1          0  0.00%  0.00%  0.00%   0 Auth-proxy AAA B
111           8      6951          1  0.00%  0.00%  0.00%   0 IP Admin SM Proc
112         432      2046        211  0.00%  0.00%  0.00%   0 DHCPD Receive
113           0         2          0  0.00%  0.00%  0.00%   0 AAA Cached Serve
114           0         2          0  0.00%  0.00%  0.00%   0 LOCAL AAA
115           0         2          0  0.00%  0.00%  0.00%   0 TPLUS
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
116           0         4          0  0.00%  0.00%  0.00%   0 Crypto CA
117           0         1          0  0.00%  0.00%  0.00%   0 Crypto PKI-CRL
118           0         1          0  0.00%  0.00%  0.00%   0 Crypto SSL
119           0         2          0  0.00%  0.00%  0.00%   0 VTPMIB EDIT BUFF
120           0         2          0  0.00%  0.00%  0.00%   0 DHCP Security He
121           0         1          0  0.00%  0.00%  0.00%   0 DiagCard1/-1
 66           0         2          0  0.00%  0.00%  0.00%   0 EAPoUDP Process
123       27512    221001        124  0.00%  0.00%  0.00%   0 VLAN Manager
124          56     17403          3  0.00%  0.00%  0.00%   0 DHCPD Timer
125          96      9079         10  0.00%  0.00%  0.00%   0 VTP Trap Process
126           0         3          0  0.00%  0.00%  0.00%   0 RADIUS TEST CMD
127           0         2          0  0.00%  0.00%  0.00%   0 AAA SEND STOP EV
128           0         1          0  0.00%  0.00%  0.00%   0 Syslog Traps
129           8       145         55  0.00%  0.00%  0.00%   0 SPAN switch
130        1452   1014895          1  0.00%  0.00%  0.00%   0 System polling
131        2444    571882          4  0.00%  0.00%  0.00%   0 DHCPD Database
132          76       616        123  0.00%  0.00%  0.00%   1 Virtual Exec

 

sh run:

Switch# sh run
Building configuration...

Current configuration : 5506 bytes
!
! Last configuration change at 18:23:11 Moscow Tue Sep 1 2015
! NVRAM config last updated at 12:11:24 Moscow Tue Sep 1 2015
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
enable secret 5 ********************
enable password *********************
!
no aaa new-model
clock timezone Moscow 3
ip subnet-zero
!
!
!
!
!
!
power redundancy-mode redundant
no file verify auto
!
spanning-tree mode pvst
spanning-tree extend system-id
no spanning-tree vlan 1-4094
!
vlan internal allocation policy ascending
!
vlan 1006-4094
!
interface GigabitEthernet1/1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/2
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/3
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/4
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/5
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/6
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1-3000,3002-4094
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/7
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/8
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/9
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/10
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/11
!
interface GigabitEthernet1/12
!
interface GigabitEthernet1/13
!
interface GigabitEthernet1/14
!
interface GigabitEthernet1/15
!
interface GigabitEthernet1/16
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/17
!
interface GigabitEthernet1/18
!
interface GigabitEthernet1/19
!
interface GigabitEthernet1/20
!
interface GigabitEthernet1/21
!
interface GigabitEthernet1/22
!
interface GigabitEthernet1/23
!
interface GigabitEthernet1/24
!
interface GigabitEthernet1/25
!
interface GigabitEthernet1/26
!
interface GigabitEthernet1/27
!
interface GigabitEthernet1/28
!
interface GigabitEthernet1/29
!
interface GigabitEthernet1/30
switchport trunk encapsulation dot1q
switchport trunk native vlan 1288
switchport mode trunk
!
interface GigabitEthernet1/31
!
interface GigabitEthernet1/32
!
interface GigabitEthernet1/33
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/34
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/35
switchport trunk encapsulation dot1q
switchport trunk native vlan 555
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/36
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/37
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/38
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/39
switchport trunk encapsulation dot1q
switchport trunk native vlan 1012
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/40
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/41
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/42
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/43
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/44
switchport access vlan 120
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/45
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/46
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/47
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/48
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface TenGigabitEthernet1/49
!
interface TenGigabitEthernet1/50
!
interface Vlan1
ip address 10.0.1.224 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 10.0.1.7
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
stopbits 1
line vty 0 4
password ***********
login
!
ntp clock-period 17180971
ntp server 10.0.1.7
end

Куда копать? конфиг простой как пробка. что такое l2mm в гугле сумбурно и как на него можно повлиять ни фига не понятно. Трафик по портам суммарно в пределах 2-3 гиг не больше 300-350 мегабит/с на порт.

Share this post


Link to post
Share on other sites

l2mm - это igmp и мультик. копать в сторону CoPP с последующим рейт-лимитом на igmp пакеты.

на время рисования copp можно навесить storm control на мультикаст.

 

Попутно имеет смысл прошерстить сегмент на предмет активной генерации tcn - может где линк капитально флапает или и вовсе кольца туда-сюда гуляют. Хотя такая беда чаще сопровождается повышенной загрузкой от spanning-tree.

Share this post


Link to post
Share on other sites

l2mm - это igmp и мультик. копать в сторону CoPP с последующим рейт-лимитом на igmp пакеты.

на время рисования copp можно навесить storm control на мультикаст.

 

Попутно имеет смысл прошерстить сегмент на предмет активной генерации tcn - может где линк капитально флапает или и вовсе кольца туда-сюда гуляют. Хотя такая беда чаще сопровождается повышенной загрузкой от spanning-tree.

Колец нет, топология чистая звезда. stp зарублен

мультик циска не обрабатывает он проходит через нее в определенном vlan но не более того.

Share this post


Link to post
Share on other sites

Хотя такая беда чаще сопровождается повышенной загрузкой от spanning-tree.

При детальном изучении в момент "пика" картина такая:

Switch# sh proc cpu sort 1
CPU utilization for five seconds: 100%/0%; one minute: 51%; five minutes: 47%
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
 40    10826452    416864      25971  0.00% 26.00% 22.91%   0 Cat4k Mgmt HiPri
  4     5343544       878    6086041 99.91% 15.13% 11.82%   0 SpanTree Helper
 41     2147028    430765       4984  0.00%  9.34% 11.81%   0 Cat4k Mgmt LoPri
  7      105220      6364      16533  0.00%  0.43%  0.57%   0 Check heaps
122       50012     60440        827  0.00%  0.28%  0.36%   0 PM Callback
 34        1888     12123        155  0.00%  0.04%  0.07%   0 IDB Work
101       13608      1047      12997  0.00%  0.04%  0.05%   0 L2MM
 72        8332     17831        467  0.00%  0.03%  0.01%   0 CDP Protocol
 38        7764       453      17139  0.00%  0.02%  0.00%   0 Per-minute Jobs
 77        3064     15793        194  0.00%  0.01%  0.00%   0 IP Input
135          28       163        171  0.00%  0.00%  0.00%   3 Virtual Exec
 13        1920     12699        151  0.00%  0.00%  0.00%   0 ARP Input
 83         116     17387          6  0.00%  0.00%  0.00%   0 CEF: IPv4 proces
 12           0         1          0  0.00%  0.00%  0.00%   0 ifIndex Receive
 14           0         1          0  0.00%  0.00%  0.00%   0 AAA_SERVER_DEADT
 16           0         1          0  0.00%  0.00%  0.00%   0 Policy Manager
 15           0         2          0  0.00%  0.00%  0.00%   0 AAA high-capacit
 17        1688        24      70333  0.00%  0.00%  0.00%   0 Entity MIB API
 19           8       436         18  0.00%  0.00%  0.00%   0 IPC Dynamic Cach
 20           0         1          0  0.00%  0.00%  0.00%   0 IPC Zone Manager
 21          52     12602          4  0.00%  0.00%  0.00%   0 IPC Periodic Tim
 11           0         1          0  0.00%  0.00%  0.00%   0 Crash writer

Что такое SpanTree Helper и почему он грузит проц, если spanning tree отключен во всех вланах?

Share this post


Link to post
Share on other sites

Поздравляю, ищите коммутаторы на сети, где у вас включен forward bpdu, и вырубайте, заодно на портах доступа включайте bpdu filter. Либо вам вдувают чужую сеть через мыльницу, либо несколько ваших клиентов устроили кольцо через себя. На 4948 включите spanning-tree во всех вланах и смотрите где будет наибольшее количество tcn поймано.

Share this post


Link to post
Share on other sites

spanning-tree mode pvst
spanning-tree extend system-id
no spanning-tree vlan 1-4094
vlan 1006-4094

Куда копать? конфиг простой как пробка. что такое l2mm в гугле сумбурно и как на него можно повлиять ни фига не понятно. Трафик по портам суммарно в пределах 2-3 гиг не больше 300-350 мегабит/с на порт.

 

PVST это Per-VLAN STP, т.е. 3 тысячи экземпляров. Может оно как-то не до конца выключается?

Включи режим MSTP и повесь BPDU-filter на интерфейсы, где STP не нужен.

Ну и IOS стабильный? крайний?

Share this post


Link to post
Share on other sites

 

 

PVST это Per-VLAN STP, т.е. 3 тысячи экземпляров. Может оно как-то не до конца выключается?

Включи режим MSTP и повесь BPDU-filter на интерфейсы, где STP не нужен.

Ну и IOS стабильный? крайний?

Переключил режим.. стало хуже. STP вообще не нужен. Фильтры на интерфейсы сейчас попробую навесить..

Share this post


Link to post
Share on other sites

BPDU-filter на интерфейсы

Фильтры повесил на все интерфейсы.. легче не стало :-( Куда копать?

Share this post


Link to post
Share on other sites

Куда копать?

В глубь сети. Отключайте все порты кроме аплинка, и поднимайте по очереди пока не появится паразитная нагрузка; как нашли больную ветку - switchport trunk allowed vlan ctrl_vlanID на уходящем порту и прочесываете все до упора.

Проблема не на 4948, она в том зверинце, что находится за ним.

Share this post


Link to post
Share on other sites

Куда копать?

В глубь сети. Отключайте все порты кроме аплинка, и поднимайте по очереди пока не появится паразитная нагрузка; как нашли больную ветку - switchport trunk allowed vlan ctrl_vlanID на уходящем порту и прочесываете все до упора.

Проблема не на 4948, она в том зверинце, что находится за ним.

Свич в агрегации, отключать порты совсем не вариант: буду класть сразу дофига клиентов, что очень не хочется. Есть идеи как вычислить? на коммутаторах по пути к кошке тишина: нагрузка низкая, лупов и чего-то нестандартного не фиксируется.

Share this post


Link to post
Share on other sites

А если погасить влан, в котором мультик? Просто без снуппинга в этом влане, мультикаст будет валить во все порты.

Share this post


Link to post
Share on other sites

Есть идеи как вычислить?

уже озвучивал выше:

1) включить на нисходящих портах storm control на мультикаст с небольшим порогом - позволит сразу увидеть в каком порту валит мультикаст;

2) включить spanning-tree (при rapid-pvst mode) на всех вланах - позволит мониторить влетающие bpdu и соответственно увидеть в каком влане какого порта прилетает паразит;

Share this post


Link to post
Share on other sites

show platform cpu packet statistics

Покажет что, но не покажет откуда. Тем более и так известно что - проц уходит в полочку от l2mm и spanning-tree.

Share this post


Link to post
Share on other sites

2) включить spanning-tree (при rapid-pvst mode)

Сколько инстансов влезет? У автора 3000 вланов.

Share this post


Link to post
Share on other sites

show platform cpu packet statistics

Покажет что, но не покажет откуда. Тем более и так известно что - проц уходит в полочку от l2mm и spanning-tree.

 

забыл добавить - предварительно debug platform packet all count на 15-30 секунд, главное что бы железка не сдохла %) хотя итак 100% CPU ужо..

Share this post


Link to post
Share on other sites

[ проц уходит в полочку от l2mm и spanning-tree.

l2mm нагрузка ушла.. зарубил igmp все стало ок.

остался spannnigtree helper

Share this post


Link to post
Share on other sites

2mm нагрузка ушла.. зарубил igmp все стало ок.

Ушла долбежка igmp на cpu, а трафик как был так и остался, и storm control его выявит.

Если честно, решение подобной проблемы в чужой сети отнимает у меня, обычно, не более 10 минут, при условии что у меня есть карта сети и удаленный доступ к оборудованию.

Очень странно, что обсуждение проблемы затянулось настолько долго.

 

Кстати, storm control на broadcast тоже нужен, причем везде и всегда.

Share this post


Link to post
Share on other sites

 

Ушла долбежка igmp на cpu, а трафик как был так и остался, и storm control его выявит.

 

Я просто пока мультикаст остановил. он для нас не критичный: разберусь потом.

Share this post


Link to post
Share on other sites

Есть идеи как вычислить?

уже озвучивал выше:

1) включить на нисходящих портах storm control на мультикаст с небольшим порогом - позволит сразу увидеть в каком порту валит мультикаст;

2) включить spanning-tree (при rapid-pvst mode) на всех вланах - позволит мониторить влетающие bpdu и соответственно увидеть в каком влане какого порта прилетает паразит;

Если я сейчас включу stp во всех вланах при включенном bpdufilter, увижу ли что то?

Share this post


Link to post
Share on other sites

Нет конечно. bpdufilter включать надо исключительно на портах доступа, но никак не на магистральных.

Share this post


Link to post
Share on other sites

исключительно на портах доступа

 

А на межоператорских стыках какая практика?

Share this post


Link to post
Share on other sites

Нет конечно. bpdufilter включать надо исключительно на портах доступа, но никак не на магистральных.

В этой кошке нет ни одного порта доступа, все транки. я правильно понимаю, что фильтр бесполезен был?

Share this post


Link to post
Share on other sites

А на межоператорских стыках какая практика?

Где заканчивается зона ответственности - там и включается фильтр или даже гвард.

 

В этой кошке нет ни одного порта доступа, все транки. я правильно понимаю, что фильтр бесполезен был?

Когда идет речь о портах доступа, подразумевается не конкретно данная кошка, а все порты доступа коммутаторов данного сегмента, т.е. фильтр нужно вешать там, где заканчивается зона ответственности.

Вешать bpdufilter на магистральных линках - все равно что зарядить двустволкой в ногу. А за portfast trunk одно время даже штрафовали коллег.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this