Jump to content
Калькуляторы

Простые очереди микротик

Есть микротик RB2011Uias. Аплинк 100Мбит/с. При использовании простых очередей режет скорость на 50Мбит/с. При использовании дерева загружает канал полностью (но на дереве процессор загружается на 100%, поэтому перешёл на простые). Где косяк?

/queue type

add kind=pcq name=down pcq-classifier=dst-address pcq-dst-address6-mask=64 \

pcq-limit=1k pcq-src-address6-mask=64 pcq-total-limit=12k

add kind=pcq name=up pcq-classifier=src-address pcq-dst-address6-mask=64 \

pcq-src-address6-mask=64 pcq-total-limit=10k

/queue simple

add max-limit=60M/90M name=All packet-marks=Down,Up queue=up/down target=\

х.х.х.х/16

add burst-limit=50M/90M burst-threshold=7M/7M burst-time=6s/6s limit-at=7M/7M \

max-limit=50M/90M name=User1 packet-marks=Down,Up parent=All queue=\

up/down target=x.x.x.x/32

....

/queue tree

add disabled=yes limit-at=8M max-limit=89M name=Bolshaya_down packet-mark=Down \

parent=global queue=down

add disabled=yes limit-at=8M max-limit=60M name=Bolshaya_up packet-mark=Up \

parent=global queue=up

Edited by atihomirov

Share this post


Link to post
Share on other sites

Скудное условие.

 

Телепаты только начали возвращаться из летних отпусков, и подсказывают что возможно проблема в том, что simple-queue в прошивках 6.x+ используют тип очереди defaul-small и нужно для начала посмотреть, как она у вас настроена.

Share this post


Link to post
Share on other sites

Есть микротик RB2011Uias. Аплинк 100Мбит/с. При использовании простых очередей режет скорость на 50Мбит/с. При использовании дерева загружает канал полностью (но на дереве процессор загружается на 100%, поэтому перешёл на простые). Где косяк?

/queue type

add kind=pcq name=down pcq-classifier=dst-address pcq-dst-address6-mask=64 \

pcq-limit=1k pcq-src-address6-mask=64 pcq-total-limit=12k

add kind=pcq name=up pcq-classifier=src-address pcq-dst-address6-mask=64 \

pcq-src-address6-mask=64 pcq-total-limit=10k

/queue simple

add max-limit=60M/90M name=All packet-marks=Down,Up queue=up/down target=\

х.х.х.х/16

add burst-limit=50M/90M burst-threshold=7M/7M burst-time=6s/6s limit-at=7M/7M \

max-limit=50M/90M name=User1 packet-marks=Down,Up parent=All queue=\

up/down target=x.x.x.x/32

....

/queue tree

add disabled=yes limit-at=8M max-limit=89M name=Bolshaya_down packet-mark=Down \

parent=global queue=down

add disabled=yes limit-at=8M max-limit=60M name=Bolshaya_up packet-mark=Up \

parent=global queue=up

и что полуится ???

Share this post


Link to post
Share on other sites

и что полуится ???

Получается, что при активной простой очереди трафик режется (соответственно дерево деактивировано).

 

Скудное условие.

 

Телепаты только начали возвращаться из летних отпусков, и подсказывают что возможно проблема в том, что simple-queue в прошивках 6.x+ используют тип очереди defaul-small и нужно для начала посмотреть, как она у вас настроена.

Понятно, после обновления сразу не заметил. То есть не воспринимает тип очереди (в моём случае up и down)?

Share this post


Link to post
Share on other sites

Понятно, после обновления сразу не заметил. То есть не воспринимает тип очереди (в моём случае up и down)?

 

В 6ой версии, был переработан механизм simple queue, мануалы для 5 версии уже не годятся. Да и схема прохождения пакетов была изменена.

 

Совет для начала - я вам дал, куда смотреть.

Если вы мигрировали из 5.х в 6.х то да, вам нужно серьёзно поглядеть на изменения, и возможно изменить схему.

 

А в будущем, лучше подробнее объяснять что есть и что нужно. Я вот помню что у вас правила на базе ipv6, и в случае такого железа как микротик -это может стать во главе стола. Это вовсе не тот вендор, который задаёт моду.

Share this post


Link to post
Share on other sites

Так вот дело-то в том, что я перешёл с 6.19 на 6.30.2. И правило создавал по мануалу 6 версии.

Edited by atihomirov

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this