Jump to content
Калькуляторы

Полисинг/шейпинг на Cisco 7600/6500 не работаю шейперы 2Gbps и выше

Доброе время суток!

 

Столкнулся с проблемой ограничения клиентов с высоким потреблением трафика - конструкция представленного ниже вида не работает при лимитах в 2Gbps и выше:

term#sh run int te3/4.858
Building configuration...

Current configuration : 301 bytes
!
interface TenGigabitEthernet3/4.10
description -= CLIENT =-
encapsulation dot1Q 10
ip address XXX.XXX.XXX.XXX 255.255.255.252
no ip redirects
no cdp enable
service-policy input CLIENT-OUT
service-policy output CLIENT-IN
end

term#sh policy-map CLIENT-IN
 Policy Map CLIENT-IN
   Class class-default
    police cir 2000000000 bc 62500000
      conform-action transmit
      exceed-action drop

term#sh policy-map CLIENT-OUT
 Policy Map CLIENT-OUT
   Class class-default
    police cir 2000000000 bc 62500000
      conform-action transmit
      exceed-action drop

term#sh policy-map interface te3/4.10
TenGigabitEthernet3/4.10

 Service-policy input:CLIENT-OUT

   class-map: class-default (match-any)
     Match: any
     police :
2000000000 bps 62500000 limit 62500000 extended limit
     Earl in slot 1 :
50924765741154 bytes
5 minute offered rate 450539272 bps
aggregate-forwarded 50924765741154 bytes action: transmit
exceeded 0 bytes action: drop
aggregate-forward 446375640 bps exceed 0 bps

 Service-policy output: CLIENT-IN

   class-map: class-default (match-any)
     Match: any
     police :
2000000000 bps 62500000 limit 62500000 extended limit
     Earl in slot 1 :
23063758884662 bytes
5 minute offered rate 3270968 bps
aggregate-forwarded 23063758884662 bytes action: transmit
exceeded 0 bytes action: drop
aggregate-forward 1067232 bps exceed 0 bps

при этом на небольших скоростях шейпер работает корректно.

 

Эффект наблюдается на Cisco 7604 / RSP720-3CXL / WS-6704-10GE / IOS c7600rsp72043_rp-ADVIPSERVICESK9-M Version 15.2(4)S2 и на Cisco 6504E / SUP720-3BXL / WS-6704-10GE / IOS s72033_rp-ADVENTERPRISEK9-M Version 15.1(1)SY.

 

Может надо шейпить по другому?

Share this post


Link to post
Share on other sites

5 minute offered rate 450539272 bps
5 minute offered rate 3270968 bps

 

А offered rate совпадает с загрузкой интерфейса или некорректно отображается?

Просто пока не видно, что что-то не работает.

 

interface TenGigabitEthernet3/4.10
service-policy input CLIENT-OUT
service-policy output CLIENT-IN

 

Быть может нужно на родительском интерфейсе полисить? Матчить виланы.

Share this post


Link to post
Share on other sites

allan_sundry

 

добрый день, не так давно успешно использовали следующий полисер на Port-Channel из двух десяток

 

Policy Map Rate9Gb-in
 Class All-traf-in
  police cir 8700000000 bc 30000000 be 30000000
    conform-action transmit
    exceed-action drop
    violate-action drop
Policy Map Rate9Gb-out
 Class All-traf-out
  police cir 8700000000 bc 30000000 be 30000000
    conform-action transmit
    exceed-action drop
    violate-action drop

 

работало нормально, sup-bootdisk:c7600rsp72043-adventerprisek9-mz.152-4.S6.bin

Share this post


Link to post
Share on other sites

allan_sundry

 

добрый день, не так давно успешно использовали следующий полисер на Port-Channel из двух десяток

 

Policy Map Rate9Gb-in
 Class All-traf-in
  police cir 8700000000 bc 30000000 be 30000000
    conform-action transmit
    exceed-action drop
    violate-action drop
Policy Map Rate9Gb-out
 Class All-traf-out
  police cir 8700000000 bc 30000000 be 30000000
    conform-action transmit
    exceed-action drop
    violate-action drop

 

работало нормально, sup-bootdisk:c7600rsp72043-adventerprisek9-mz.152-4.S6.bin

 

Покажите пожалуйста Class All-traf-out.

Какая у вас линейная плата?

 

 

 

5 minute offered rate 450539272 bps
5 minute offered rate 3270968 bps

 

А offered rate совпадает с загрузкой интерфейса или некорректно отображается?

Просто пока не видно, что что-то не работает.

 

 

Не совпадает, в это время через интерфейс шло около 3Gbps входа от клиента

 

 

 

Можете привести пример как полисить на родительском интерфейсе и матчить VLANы?

Edited by allan_sundry

Share this post


Link to post
Share on other sites

5 minute offered rate 450539272 bps
5 minute offered rate 3270968 bps

 

А offered rate совпадает с загрузкой интерфейса или некорректно отображается?

Просто пока не видно, что что-то не работает.

 

 

Не совпадает, в это время через интерфейс шло около 3Gbps входа от клиента

 

 

 

Можете привести пример как полисить на родительском интерфейсе и матчить VLANы?

 

class-map match-any CM_VOICE_VIDEO
match vlan  400
match vlan  401
match vlan  300
match vlan  301

 

У меня правда платформа другая, но по идее должно быть также.

Edited by ShyLion

Share this post


Link to post
Share on other sites

Покажите пожалуйста Class All-traf-out.

Какая у вас линейная плата?

 

тупо заглушка :)

 

Class Map match-all All-traf-in (id 6)

Match access-group 96

Standard IP access list 96

10 permit any

 

модуль 6708

Share this post


Link to post
Share on other sites

Сегодня снова наблюдал эту же картину:

 

 

term#sh policy-map interface TenGigabitEthernet3/4.858TenGigabitEthernet3/4.858 Service-policy input: CLIENT-OUT   class-map: ALL (match-all)     Match: access-group 2     police :       1300000000 bps 40625000 limit 40625000 extended limit     Earl in slot 2 :       7944033441 bytes       5 minute offered rate 237431296 bps       aggregate-forwarded 7944033441 bytes action: transmit       exceeded 0 bytes action: drop       aggregate-forward 229197360 bps exceed 0 bps   Class-map: class-default (match-any)     0 packets, 0 bytes     5 minute offered rate 0000 bps, drop rate 0000 bps     Match: any Service-policy output: CLIENT-IN   class-map: ALL (match-all)     Match: access-group 2     police :       1300000000 bps 40625000 limit 40625000 extended limit     Earl in slot 2 :       83427640773 bytes       5 minute offered rate 2086938968 bps       aggregate-forwarded 83427640773 bytes action: transmit       exceeded 0 bytes action: drop       aggregate-forward 1968499696 bps exceed 0 bps   Class-map: class-default (match-any)     0 packets, 0 bytes     5 minute offered rate 0000 bps, drop rate 0000 bps     Match: anyterm#sh policy-map CLIENT-IN Policy Map CLIENT-IN   Class ALL    police cir 1300000000 bc 40625000 be 40625000      conform-action transmit      exceed-action drop      violate-action dropterm#sh class-map ALLClass Map match-all ALL (id 2)  Match access-group   2term#sh access-lists 2Standard IP access list 2   10 permit any (158108 matches)

 

 

 

Что я делаю не так?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this