Jump to content
Калькуляторы

dhcp broadcast suppress

Добрый день.

 

Есть такая железка:

 

Orion Alpha A26 Device, Compiled on Jul 08 16:32:20 2013
SoftWare Version 7.0.3.1(R0073.0008)
BootRom Version 7.1.10
HardWare Version 1.0.1
CPLD Version N/A

 

Можно ли подавить все dhcp-сообщения в определённых вланах? Т.е. если на свиче есть вланы, на которых dhcp должен работать, и есть вланы, в которых нужно убрать все dhcp-запросы.

 

Если использовать для этого ip dhcp snooping trust на портах, то почему-то перестаёт работает broadcast suppress:

 

с таким конфигом:

service dhcp
!
ip forward-protocol udp bootps
ip dhcp relay information option
ip dhcp relay information option subscriber-id format hex
ip dhcp relay share-vlan 13 sub-vlan 92
!
ip dhcp snooping enable
ip dhcp snooping vlan 92
!
ip dhcp snooping broadcast suppress
...
Interface Ethernet1/1
switchport access vlan 92
...
Interface Ethernet1/24
switchport mode trunk
switchport trunk allowed vlan 1;13;92
...
interface Vlan13
ip address 10.1.17.205 255.255.255.0
 !forward protocol udp 67(active)!
ip helper-address 10.1.17.2
...

 

клиент с первого порта получает ip без проблем:

Aug 19 16:19:57 m33 dhcpd: DHCPDISCOVER from 00:e0:4c:4b:a8:65 via 10.1.17.205
Aug 19 16:19:58 m33 dhcpd: DHCPOFFER on 10.5.0.3 to 00:e0:4c:4b:a8:65 (asus_m5200n) via 10.1.17.205
Aug 19 16:19:58 m33 dhcpd:  Lease IP 10.5.0.3 MAC 0:e0:4c:4b:a8:65 port 01 VLAN 92
Aug 19 16:19:58 m33 dhcpd: DHCPREQUEST for 10.5.0.3 (10.1.15.2) from 00:e0:4c:4b:a8:65 (asus_m5200n) via 10.1.17.205
Aug 19 16:19:58 m33 dhcpd: DHCPACK on 10.5.0.3 to 00:e0:4c:4b:a8:65 (asus_m5200n) via 10.1.17.205
Aug 19 16:20:01 m33 dhcpd: DHCPINFORM from 10.5.0.3 via 10.1.17.205
Aug 19 16:20:01 m33 dhcpd: DHCPACK to 10.5.0.3 (00:e0:4c:4b:a8:65) via vlan1

 

если же добавить на Interface Eth1/24 стоку

ip dhcp snooping trust

то dhcp-запрос с первого порта начинает рассылаться бродкастом по всей сети и его начинают релееить другие свичи, возникают проблемы на сервере:

Aug 19 16:15:18 m33 dhcpd: DHCPDISCOVER from 00:e0:4c:4b:a8:65 via vlan9: network shared-network: no free leases
Aug 19 16:15:18 m33 dhcpd:  Lease IP 10.5.0.3 MAC 0:e0:4c:4b:a8:65 port 01 VLAN 92
Aug 19 16:15:18 m33 dhcpd: DHCPDISCOVER from 00:e0:4c:4b:a8:65 via 10.1.17.205
Aug 19 16:15:18 m33 dhcpd: DHCPDISCOVER from 00:e0:4c:4b:a8:65 via 10.1.16.254: network shared-network: no free leases
Aug 19 16:15:18 m33 dhcpd: DHCPDISCOVER from 00:e0:4c:4b:a8:65 via 10.1.16.252: network shared-network: no free leases
Aug 19 16:15:19 m33 dhcpd: DHCPOFFER on 10.5.0.3 to 00:e0:4c:4b:a8:65 (asus_m5200n) via 10.1.17.205
Aug 19 16:15:19 m33 dhcpd: DHCPREQUEST for 10.5.0.3 (10.1.15.2) from 00:e0:4c:4b:a8:65 via vlan9: lease 10.5.0.3 unavailable.
Aug 19 16:15:19 m33 dhcpd: DHCPNAK on 10.5.0.3 to 00:e0:4c:4b:a8:65 via vlan9
Aug 19 16:15:19 m33 dhcpd: DHCPREQUEST for 10.5.0.3 (10.1.15.2) from 00:e0:4c:4b:a8:65 via 10.1.15.215: lease 10.5.0.3 unavailable.
Aug 19 16:15:19 m33 dhcpd: DHCPNAK on 10.5.0.3 to 00:e0:4c:4b:a8:65 via 10.1.15.215

 

в итоге он так ip и не получает. При этом на 1-м порту snooping trust - нету.

 

PS: и не совсем понятно в чём разница между командами

ip dhcp broadcast suppress

и

ip dhcp snooping broadcast suppress

?

Edited by PES-nsk

Share this post


Link to post
Share on other sites

И тишина...

 

Подскажите, возможно ли включив функцию dhcp-relay убрать broadcast тех dhcp-запросов которые релеятся, только в определённом влане (или на определённом порту), чтобы все остальные dhcp-запросы, которые relay не захватывает, рассылались broadcast-ом?

 

Тот же d-link делает это по умолчанию при включении "dhcp_relay add vlanid" - в нужном влане идёт релей, а бродаста нет, а в остальных - остаётся нормальный рабочий бродкаст.

Share this post


Link to post
Share on other sites

Добрый день,

1. Обновите коммутатор на последнюю прошивку: http://data.nag.ru/Orion%20Networks/Firmwares/A26/Orion_A26_7.0.3.5%28R0203.0020%29.zip

2. В тех vlan, которые не указаны как sub-vlan в команде "ip dhcp relay share-vlan xx sub-vlan yy", dhcp бродкаст должен проходить без релеинга

Share this post


Link to post
Share on other sites

Обновил:

 

SoftWare Version 7.0.3.5(R0203.0020)

 

Вот конфиг:

 

service dhcp
!
ip forward-protocol udp bootps
ip dhcp relay information option
ip dhcp relay information option subscriber-id format hex
ip dhcp broadcast suppress
ip dhcp relay share-vlan 13 sub-vlan 92
!
ip dhcp snooping enable
ip dhcp snooping vlan 92
...
vlan 1;3;13;92
!
Interface Ethernet1/1
switchport access vlan 92
!
Interface Ethernet1/3
switchport access vlan 3
...
Interface Ethernet1/24
switchport mode trunk
switchport trunk allowed vlan 1;3;13;92
...
interface Vlan13
ip address 10.1.17.205 255.255.255.0
 !forward protocol udp 67(active)!
ip helper-address 10.1.17.2

 

На 3-м порту (в 3-м влане) DHCP запросы от клиента блокируются, клиент ip не получает.

Если поставить вместо "ip dhcp broadcast suppress" команду "ip dhcp snooping broadcast suppress", то запросы от клиента на 3-м порту проходят, но при этом транзитные unicast-dhcp-запросы в управляющем влане (релеи от других свичей, стоящих ниже) с опцией 82 выцепляются и блокируются.

Share this post


Link to post
Share on other sites

Какие-нибудь изменения есть?

 

Последние данные:

 

Коммутатор: Orion A26, SoftWare Version 7.0.3.5(R0203.0020)

 

Задача: убрать broadcast от клиентов, которые получают dhcp через relay

 

ip dhcp broadcast suppress - с этой командой клиент вообще не получает ip, dhcp-запрос релеится, до сервера доходит, сервер высылает offer, но этот offer клиенту не доходит. В дебаге (debug ip dhcp relay packet) ответов от сервера на свиче не видно.

ip dhcp snooping broadcast suppress - с этой командой клиент по релею ip получает, но при этом транзитные unicast-dhcp-запросы в управляющем влане (релеи от других свичей, стоящих ниже) с опцией 82 выцепляются и блокируются.

без обеих команд клиент ip по релею получает, но в клиентском влане рассылается broadcast-запрос и все свичи в округе начинают этот запрос релеить, в связи с чем на сервере много левых запросов

Share this post


Link to post
Share on other sites

Есть ли решение по вопросу? У нас тоже много таких коммутаторов и есть такая задача...

Share this post


Link to post
Share on other sites

Pharaoh, в описанной схеме ip dhcp broadcast suppress работает корректно.

Если у вас возникли проблемы с данной конфигурацией, обратитесь, пожалуйста, с подробным описанием проблематики к нам в support.

Share this post


Link to post
Share on other sites

Pharaoh, в описанной схеме ip dhcp broadcast suppress работает корректно.

Если у вас возникли проблемы с данной конфигурацией, обратитесь, пожалуйста, с подробным описанием проблематики к нам в support.

 

Уменя тоже стоит задача - убрать broadcast от клиентов, которые получают dhcp через relay

 

ip dhcp broadcast suppress

ip dhcp snooping broadcast suppress

 

Какая из двух комманд корректно отработает на последней прошивке?

Отмечу, главное чтобы транзитные запросы не вырезались.

Share this post


Link to post
Share on other sites

Pharaoh, используйте ip dhcp broadcast suppress.

 

Спасибо, попробую.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this