Jump to content
Калькуляторы

SNR S2990G-24FX настройка Q-in-Q и translition port настройка Q-in-Q и translition port

Ситуация такая, настраиваем q-in-q на двух snr'ах которые стоят между клиентскими свичами (клиент. коммут1 e0/25 -> e1/0/10 SNR1 e1/0/25-> e1/0/25 SNR2 e1/0/10 -> e0/25 клиент. коммут2). от клиентского оборудования влан 3700-3799 необходимо завернуть в 3760 и после второго SNR развернуть, а 2100 влан управления необходимо чтобы он ходил свободно между всеми коммутами. Проблема в том что translition не настраивается на тех портах на которых настроен selective qinq, если мы не заворачиваем 2100 то за первым СНРом ни что недоступно. На клиентских коммутах 2100 в тэгированных портах.

настройка 10го порта на СНРах:

Interface Ethernet1/0/10
dot1q-tunnel enable
dot1q-tunnel selective s-vlan 3760 c-vlan 3700-3799
dot1q-tunnel selective s-vlan 2100 c-vlan 2100
dot1q-tunnel selective enable
switchport mode hybrid
switchport hybrid allowed vlan 2100;3760 untag

настройка 25го порта на СНРах:

Interface Ethernet1/0/25
speed-duplex force1g-full
switchport mode hybrid
switchport hybrid allowed vlan 2100;3760 tag

при таких настройках все доступно и пакеты доходят как клиентские, так и управления.

Вопрос, как настроить чтоб на одном порту работал q-in-q и заворачивал в 3760 определенные вланки(3700-3799), так же чтоб тегетом пробрасывались другие вланки(2100) не заворачиваясь.

Share this post


Link to post
Share on other sites

Здравствуйте.

 

Ниже пример конфигурации коммутатора с Flexible Q-in-Q, Vlan-Translation и прозрачным пропуском тегов:

class-map c1
match vlan 10 11 12
policy-map p1
class c1
add s-vid 31
exit
!
Interface Ethernet1/0/21
description CustomerPort
service-policy input p1
vlan-translation enable
vlan-translation 40 to 1000 in
vlan-translation 1000 to 40 out
switchport mode hybrid
switchport hybrid allowed vlan 1000;1002 tag
switchport hybrid allowed vlan 31 untag
!

 

На VLAN'ы 10,11,12 добавляем сервисный тег 31.

VLAN 40 транслируем в VLAN 1000

VLAN 1002 пропускаем прозрачно.

 

Номера тегов в вашем случае могут отличаться.

Share this post


Link to post
Share on other sites

Artem Enborisov, такая еще проблема, включае между этими СНРами еще один, чисто для транзита, пробрасываем на нем тагетом нужные вланки. Пакеты с одним тегом(2100) проходят, с двумя(3760) не проходят.

Interface Ethernet1/0/24
speed-duplex force1g-full
switchport mode hybrid
switchport hybrid allowed vlan 2100;3760 tag
!
Interface Ethernet1/0/25
speed-duplex force1g-full
switchport mode hybrid
switchport hybrid allowed vlan 2100;3760 tag

Что нужно настроить, чтобы пропускал пакеты с двумя тегами?

Share this post


Link to post
Share on other sites

Всем спасибо за помощь, все заработало. вланку потерял в одном месте(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this