Jump to content

В 100500 раз quagga и резервирование каналов

Сразу прошу сильно не пинать и тапками не забрасывать, чем больше гуглю и читаю тем больше каша в голове, смешались препенды as-match веса и преференсы. В общем задача банальная, есть один маршрутизатор с поднятой квагой. своя AS и пулы адресов. есть 2 аплинка, основной и резервный на случай падения, надо поднимать резервный после падения основного и переключаться обратно при восстановлении канала. От обоих аплинков получаю только дефолтовые маршруты.

cat /etc/quagga/zebra.conf

! -*- zebra -*-

!

! zebra sample configuration file

!

! $Id: zebra.conf.sample,v 1.1 2002/12/13 20:15:30 paul Exp $

!

hostname foton-border

password zebra

enable password sys2Alfa

!

! Interface's description.

! Local net

interface bond1

! Primary ISP

interface bond0

!Backup ISP

interface eth7.1000 -

!interface lo

! description test of desc.

!

!interface sit0

! multicast

 

!

! Static default route sample.

!

!

line vty

!

log file /var/log/quagga/zebra.log

 

router bgp xxx88

bgp router-id xxx.xxx.xx.158

network xxx.xxx.xx.0/23

network yyy.yyy.yyy.0/22

network zzz.zzz.zzz.0/21

! Primary

neighbor xxx.xxx.xxx.157 remote-as 3216

neighbor xxx.xxx.xxx.157 description Beeline

neighbor xxx.xxx.xxx.157 next-hop-self

neighbor xxx.xxx.xx.157 soft-reconfiguration inbound

neighbor xxx.xxx.xx.157 route-map Beeline-in in

neighbor xxx.xxx.xx.157 route-map Beeline-out out

! Backup

neighbor aaa.aaa.aaa.109 remote-as 31133

neighbor aaa.aaa.aaa.109 description Megafon

neighbor aaa.aaa.aaa.109 next-hop-self

neighbor aaa.aaa.aaa.109 soft-reconfiguration inbound

neighbor aaa.aaa.aaa.109 route-map Megafon-in in

neighbor aaa.aaa.aaa.109 route-map Megafon-out out

 

ip prefix-list bogons description bogus nets

ip prefix-list bogons seq 20 permit 127.0.0.0/8 le 32

ip prefix-list bogons seq 30 permit 10.0.0.0/8 le 32

ip prefix-list bogons seq 35 permit 172.16.0.0/12 le 32

ip prefix-list bogons seq 40 permit 192.168.0.0/16 le 32

ip prefix-list bogons seq 45 permit 169.254.0.0/16 le 32

ip prefix-list bogons seq 50 permit 224.0.0.0/4 le 32

ip prefix-list bogons seq 55 permit 240.0.0.0/4 le 32

 

route-map Beeline-in deny 110

match ip address prefix-list bogons

 

route-map Beeline-in permit 200

set local-preference 200

route-map Beeline-out deny 200

 

route-map Megafon-in deny 110

match ip address prefix-list bogons

 

route-map Megafon-in permit 200

set local-preference 100

route-map Megafon-out deny 200

 

Если есть что дополнить или где я накосячил прошу подсказать, заранее спасибо.

Share this post


Link to post
Share on other sites

На мегафоне поставьте коммун

Если я правильно понял то вот так ?

 

ip prefix-list upstream-out seq 10 permit xxx.xxx.xx.0/23

ip prefix-list upstream-out seq 20 permit yyy.yyy.yyy.0/22

ip prefix-list upstream-out seq 30 permit zzz.zzz.zzz.0/21

 

route-map Megafon-out permit 100

match ip address prefix-list ourIP

или не так?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.