Jump to content
Калькуляторы

2 pppoe в одной сети Mikrotik RB951-2n Балансировка нагрузки по группам пользователей

Появилась необходимость сделать сеть с двумя каналами интернет.

(схема сети прилагается)

 

Нужно чтобы пользователи, объединенные в группы в Adress lists, пользовались каждый своим каналом, но между ними была сеть

 

Что сделано:

К двум WAN-ам подключены ADSL модемы в бридже. Созданы 2 pppoe соединения

LAN3 и WLAN в бридже, который является выходным интерфейсом.

 

Для настройки балланса по группам пользователей применял этот конфиг:

 

/ip firewall mangle
add chain=prerouting in-interface=WAN1_8 src-address-list=!exclude action=add-src-to-address-list address-list="WAN1_8" address-list-timeout=2m disabled=no
add chain=prerouting in-interface=WAN2_5 src-address-list=!exclude action=add-src-to-address-list address-list="WAN2_5" address-list-timeout=2m disabled=no
add chain=input in-interface=WAN1_8 src-address-list=!exclude action=add-src-to-address-list address-list="WAN1_8" address-list-timeout=2m disabled=no
add chain=input in-interface=WAN2_5 src-address-list=!exclude action=add-src-to-address-list address-list="WAN2_5" address-list-timeout=2m disabled=no
add chain=prerouting src-address-list=!exclude dst-address-list=WAN1_8 action=mark-routing new-routing-mark=route_WAN1_8 passthrough=no disabled=no
add chain=prerouting src-address-list=!exclude dst-address-list=WAN2_5 action=mark-routing new-routing-mark=route_WAN2_5 passthrough=no disabled=no
add chain=output dst-address-list=WAN1_8 action=mark-routing new-routing-mark=route_WAN1_8 passthrough=no disabled=no
add chain=output dst-address-list=WAN2_5 action=mark-routing new-routing-mark=route_WAN2_5 passthrough=no disabled=no

/ip firewall mangle
add chain=prerouting src-address-list=MyLAN1 dst-address-list=!exclude action=mark-routing new-routing-mark=route_WAN1_8 passthrough=no disabled=no
add chain=prerouting src-address-list=MyLAN2 dst-address-list=!exclude action=mark-routing new-routing-mark=route_WAN2_5 passthrough=no disabled=no

/ip route 
add dst-address=0.0.0.0/0 gateway=WAN1 scope=255 target-scope=10 routing-mark=route_WAN1_8 disabled=no
add dst-address=0.0.0.0/0 gateway=WAN2 scope=255 target-scope=10 routing-mark=route_WAN2_5 disabled=no
add dst-address=0.0.0.0/0 gateway=WAN1 scope=255 target-scope=10 disabled=no


/ip firewall address-list 
add list="exclude" address=192.168.0.30-192.168.0.254
add list="MyLAN1" address=192.168.0.10-192.168.0.19
add list="MyLAN2" address=192.168.0.20-192.168.0.29

 

При нем роутер не раздает интернет никуда и пингуется только с адресов, находящихся в исключении.

С дефолтным маршрутом интернет раздается с одного из WAN

 

Что_я_делаю_не_так?

post-128553-019269800 1436278766_thumb.jpg

Edited by antikillerbm

Share this post


Link to post
Share on other sites

Ну почему всем так хочется на ровном месте PBR попользовать, корпус что ли у роутера слабо прогревается без этого...

Вам ни роутов ни маркировок не надо, достаточно этого:

 

/ip firewall nat
add action=masquerade chain=srcnat src-address-list=MyLAN1 out-interface=pppoe-out1
add action=masquerade chain=srcnat src-address-list=MyLAN2 out-interface=pppoe-out2

P.S> А вообще согласен с первым ответом, но предлагаю 5, два в горячем резерве;) Сааб!...

Edited by DRiVen

Share this post


Link to post
Share on other sites

Не знаю почему, я в mikrotik-е нуб полный. В любом примере, выходящем за рамки уровня "домашнего роутера на один комп" все юзают PBR

Отдачи ADSL в 512кбит с одной линии на 15 машин маловато, а провайдер один на всю страну, вот и извращаемся.

 

 

Способ с NAT не работает. При включении группы, трафик через pppoe просто перестает идти.

Edited by antikillerbm

Share this post


Link to post
Share on other sites

Если под

между ними была сеть

подразумевается просто ip-связность, то достаточно сделать для них две разные подсети, и nat'ить их в разные каналы. Без заморочек с маркировкировками.

Тов. DRiVen только что написал то же самое.

Share this post


Link to post
Share on other sites

Вам нужно поставить 3 микротика - первые 2 подключаете каждый к своему PPPoE соединению, настраиваете NAT. Третий подключаете к двум первым, для связи между ними выделяете две подсети /30 и включаете OSPF. На 3 микротике либо ничего не делаете, т.к. первые 2 анонсируют дефолтный маршрут и трафик сам распараллелится, либо настраиваете маркировку маршрутов с отправлением нужных серых IP по своему каналу, делать это можно либо автоматически через маркировку по определенным правилам, например разбив все адреса абонентов на 2 группы, либо вручную, добавив нужные адреса в свои адрес листы.

Share this post


Link to post
Share on other sites

Ну у меня есть 2 ADSL модема, на которых я могу поднять PPPOE и направить их в микротик.

Попробую так.

Подсети низя, общий доступ к файла нужен.

Share this post


Link to post
Share on other sites

Подсети низя, общий доступ к файла нужен.

 

Подсети можно, вы можете адреса выдавать поштучно, навесив их на любые интерфейсы, через прокси-арп компьютеры узнают о соседях.

Share this post


Link to post
Share on other sites

Не работает ни тем, ни другим способом.

На WAN1 WAN2 уже приходит интернет

В маршрутах один из WAN не активен. К инету имеет доступ только mylan1

Если выключить интерфейс WAN1, весь траф сразу идет через WAN2, и к инету имеет доступ только группа mylan2

Одновременно трафик никак не идет через оба WAN-а

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this