Jump to content
Калькуляторы

Хочется странного. v4 over v6 ospf

Добрый день коллеги. Коснулась нас таки тема V6.

 

Есть gre туннель

 

interface Tunnel10302
description # ROU2_ASR1001_ROU2 #
no ip address
ip mtu 1400
ipv6 address 2002:A03::10:3:0:1/64
ipv6 enable
ipv6 ospf 1 area 0
ipv6 ospf cost 40
qos pre-classify
tunnel source 1.1.1.1
tunnel destination 2.2.2.2

 

На другой стороне зеркальный туннель.

 

Настройки ospfv3

 

router ospfv3 1
router-id 1.1.1.2
!
address-family ipv4 unicast
 redistribute ospf 1 metric-type 1
exit-address-family
!
address-family ipv6 unicast
exit-address-family

 

Соседство поднимается.

#sh ipv6 ospf neighbor  

           OSPFv3 Router with ID (1.1.1.2) (Process ID 1)

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
1.3.1.2           0   FULL/  -        00:00:34    19              Tunnel10302

Нужно передать v4 маршруты из ospf 1 через ospfv3 1

 

Это вообще возможно? В варианте приведенном выше никакие маршруты не передаются.

Share this post


Link to post
Share on other sites

Хм, OSPF, ведь, имеет свою DB, и уже из неё строит маршруты.

Мне кажется, имея соседство V6 нельзя построить маршрут V4.

Share this post


Link to post
Share on other sites

Хм, OSPF, ведь, имеет свою DB, и уже из неё строит маршруты.

Мне кажется, имея соседство V6 нельзя построить маршрут V4.

Ну вот и я задался этим вопросом, но пока внятной инфы не нашел.

По идее v3 это лишь энчансинг v2, тоесть структура базы то одна, причин не передавать маршруты нет.

Плюс есть команда

address-family ipv4 unicast

redistribute ospf 1 metric-type 1

 

Что как бы намекает.

Share this post


Link to post
Share on other sites

а почему просто не сконфигурить на этом же туннеле ipv4 дареса и не настроить там ospf ?

Share this post


Link to post
Share on other sites

а почему просто не сконфигурить на этом же туннеле ipv4 дареса и не настроить там ospf ?

Долго объяснять, это пока лаба, но в последствии скорее всего придется использовать именно v6 для стыков. Если заведется конечно.

Share this post


Link to post
Share on other sites

Назначайте для концов туннеля v4-адреса, поднимайте ospf по ним.

Для "лаб" и прочих забав, не имеющих v6-связности, используйте префикс 2001:db8::/32.

Добавлю, что ничего (от слова абсолютно) странного в такой схеме нет, разве что немного кривовата (привет, mtu!).

А ещё я, кажется, не совсем понял постановки задачи.

Edited by Sergeylo

Share this post


Link to post
Share on other sites

Назначайте для концов туннеля v4-адреса, поднимайте ospf по ним.

Для "лаб" и прочих забав, не имеющих v6-связности, используйте префикс 2001:db8::/32.

Добавлю, что ничего (от слова абсолютно) странного в такой схеме нет, разве что немного кривовата (привет, mtu!).

А ещё я, кажется, не совсем понял постановки задачи.

Задача:

Имеется пачка ABR c ipv4 сетями.

Необходимо их связать GRE туннелями поверх v4 сетей, но с туннельной (транзитной) адресацией v6.

 

Что имеем: Туннели подняты, соседство ospfv3 устанавливается редистрибьюции из процесса router ospf 1 в процесс router ospfv3 1 нет.

Есть подозрение что надо произнести какое то заклинание дополнительно к

address-family ipv4 unicast

redistribute ospf 1 metric-type 1

Но непонятно какое. Все сценарии в инете предусматривают обмен маршрутной информацией из ospfv3 в другие протоколы.

Share this post


Link to post
Share on other sites

v3 вроде оба типа адресов поддерживает и тогда напрашивается замена процессов v2 на v3.

Но чтоб трафик v4 то ходил через линк на линке то всё равно нужны адреса v4 - или я ошибаюсь?

Share this post


Link to post
Share on other sites

myst, если на тоннеле нет ipv4 адресов, то что OSPF должен подставить в качестве next-hop?

Share this post


Link to post
Share on other sites

myst, если на тоннеле нет ipv4 адресов, то что OSPF должен подставить в качестве next-hop?

v6 адрес, не?

Share this post


Link to post
Share on other sites
v6 адрес, не
аааа, простите, это как? Это, как бы, разные address family. Так не будет никогда.

 

sh ip route себе только представьте.

Share this post


Link to post
Share on other sites
v6 адрес, не
аааа, простите, это как? Это, как бы, разные address family. Так не будет никогда.

 

sh ip route себе только представьте.

Собственно вот я и думал, может v6 продвинулось с момента моего последнего касания оного.

sh ip rou кстати представить себе легко. Почему нет то?

Share this post


Link to post
Share on other sites

А тут ipv6 не причём вообще. Тут дело в разделении сущностей. Теоретически, нет ничего сложного в транспорте ip датаграмм через любой линк. Реальный или виртуальный. Для транспорта надо только знать l2 или аналогичные адреса этого линка. Пример: транспорт через PPP соединение без назначенных адресов.

 

А вот таблицы маршрутизации и смежности должны будут дополниться новым полем: тип линка. И L2 адрес в табличке смежности и next-hop в табличке роутинга должны стать переменной длинны.

Share this post


Link to post
Share on other sites

А тут ipv6 не причём вообще. Тут дело в разделении сущностей. Теоретически, нет ничего сложного в транспорте ip датаграмм через любой линк. Реальный или виртуальный. Для транспорта надо только знать l2 или аналогичные адреса этого линка. Пример: транспорт через PPP соединение без назначенных адресов.

 

А вот таблицы маршрутизации и смежности должны будут дополниться новым полем: тип линка. И L2 адрес в табличке смежности и next-hop в табличке роутинга должны стать переменной длинны.

Ну собственно l2 менять незачем, табличку роутинга да. Но было бы вполне интересной фичей.

Share this post


Link to post
Share on other sites

Хм, OSPF, ведь, имеет свою DB, и уже из неё строит маршруты.

Мне кажется, имея соседство V6 нельзя построить маршрут V4.

Ну вот и я задался этим вопросом, но пока внятной инфы не нашел.

По идее v3 это лишь энчансинг v2, тоесть структура базы то одна, причин не передавать маршруты нет.

Плюс есть команда

address-family ipv4 unicast

redistribute ospf 1 metric-type 1

 

Что как бы намекает.

 

Я имел ввиду не структуру самой базы. А то, что в этой базе есть LSA (не помню какой тип, тот, который роутеры), а у вас этих LSA нет.

То есть нет того, что он укажет в кач-ве шлюза для сети при построении таблицы.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this