Jump to content
Калькуляторы

Возможности Mikrotik2011

Добрый день. Столкнулся с проблемой 100% загрузки процессора на модели 2011Uias-RM. На нём висит 10 пользователей, настроен NAT, маркируются соединения затем пакеты, настроен файервол на ограничение количества сессий до 250, и 10 простых очередей. Канал делится между всеми пользователями поровну. Канал 100 Мбит/с. Если один клиент запускает торрент, трафик подскакивает до максимума ~85 Мбит/с, загрузка процессора 100%. В profile firewall занимает 55-65 %? queuing -15%, если отключить правило ограничения кол-ва сессий до 250 загрузка процессора падает до 85-90%, в profile firewall 25%, queuing 30% (видно для очередей не хватало ресурса.). В любом случае если подключится ещё один любитель торрентов то загрузка процессора будет всегда 100%. Скажите пропускная способность 100 Мбит/с это предел данной модели? Если повесить на него ещё 10 пользователей, и добавить ещё один 100 битный канал, то он уже не справиться?

Share this post


Link to post
Share on other sites

У него слабоватый CPU, на все не хватит.

Я его вообще как CPE рассматриваю.

Или побольше трафика без обработки, или поменьше трафика с обработкой.

Share this post


Link to post
Share on other sites

Да у меня такая же беда

Edited by atihomirov

Share this post


Link to post
Share on other sites

Получается для 30 клиентов (200 Мбит канал) мне CCR1009 покупать?))

Share this post


Link to post
Share on other sites

Получается для 30 клиентов (200 Мбит канал) мне CCR1009 покупать?))

А кто сказал, что это операторское оборудование?

Это удобная CPE, но сажать на него десяток абонентов я бы не стал.

Share this post


Link to post
Share on other sites

Тогда нужен ваш совет. Какое оборудование прикупить с перспективой на 80 клиентов (700 Мбит/с), ну соответственно с правилами, PPPoE, очередями?

Share this post


Link to post
Share on other sites

По оборудованию советов я дать не могу.

Но 700 Мбит/с на 80 абонентов по PPPoE это довольно странно.

Тут нет ошибки?

Share this post


Link to post
Share on other sites

Получается для 30 клиентов (200 Мбит канал) мне CCR1009 покупать?))

Да. Это я вам на своей практике скажу 100%. Эта штука больше 150Мбит (около 200Мбит in+out) не в состоянии переварить, причем без ната и прочего.

Заменил ее именно на CCR1009.

Share this post


Link to post
Share on other sites

на последней прошивке добавлен функционал Fasttrack , позволяет снизить нагрузку на проц конкретно

Share this post


Link to post
Share on other sites

Какое оборудование прикупить с перспективой на 80 клиентов (700 Мбит/с), ну соответственно с правилами, PPPoE, очередями?

Самосборный Core i5 с парой Intel CT.

 

Если хочется фирменно, тогда http://supermicro.nl/products/system/1U/5017/SYS-5017C-LF.cfm либо http://supermicro.nl/products/system/Mini-ITX/1018/SYS-1018L-MP.cfm

Share this post


Link to post
Share on other sites

Тогда нужен ваш совет. Какое оборудование прикупить с перспективой на 80 клиентов (700 Мбит/с), ну соответственно с правилами, PPPoE, очередями?

У вас клиенты юрики или операторы? Если обычные физики, то вам и 100 мегабит хватит за глаза)

Share this post


Link to post
Share on other sites

маркируются соединения затем пакеты,

 

Зачем? Какой смысл в этих маркировках?

 

настроен файервол на ограничение количества сессий до 250,

 

Зачем? Какой смысл в этих ограничениях?

 

и 10 простых очередей

 

Зачем 10 правил?

 

Канал делится между всеми пользователями поровну

 

Если делится поровну, создайте одно правило PCQ на всех и готово.

 

Канал 100 Мбит/с. Если один клиент запускает торрент, трафик подскакивает до максимума ~85 Мбит/с, загрузка процессора 100%. В profile firewall занимает 55-65 %? queuing -15%, если отключить правило ограничения кол-ва сессий до 250 загрузка процессора падает до 85-90%, в profile firewall 25%, queuing 30% (видно для очередей не хватало ресурса.). В любом случае если подключится ещё один любитель торрентов то загрузка процессора будет всегда 100%. Скажите пропускная способность 100 Мбит/с это предел данной модели? Если повесить на него ещё 10 пользователей, и добавить ещё один 100 битный канал, то он уже не справиться?

 

Указанное устройство легко пропускает с натом 100-200 мегабит. Шейпер на PCQ практически не занимает ресурсов. Если хотите предоставлять канал на скорости 700 мегабит, следует использовать Mikrotik CCR как минимум 16 ядер.

Share this post


Link to post
Share on other sites

Зачем? Какой смысл в этих маркировках?

 

- Как я правильно понял из мануала, пакеты маркируются для того, чтобы потом их отловить в очереди (поправьте если не прав).

 

Зачем? Какой смысл в этих ограничениях?

 

- 1 клиент запуская торрент создаёт 5000 сессий, трафик 90 Мбит/с и загрузка процессора 100%. Хоть как-о пытался снизить активность торрента. Отмаркировать торрент так и не получилось.

 

Зачем 10 правил?

 

- Пробовал сделать одну очередь где target указал всю сеть, установил max limit и limit at, установил pcq, маркировались пакеты - шейпинг не работал. Пришлось для каждого пользователя создавать свою очередь.

 

У вас клиенты юрики или операторы? Если обычные физики, то вам и 100 мегабит хватит за глаза)

 

- Клиенты физики. За глаза на 50 клиентов? Существующие 10 клиентов загружают канал полностью (оооочень активные). Условие - у каждого должен быть гарантированный канал 8 Мбит/с....

Edited by georgii

Share this post


Link to post
Share on other sites
На нём висит 10 пользователей, настроен NAT, маркируются соединения затем пакеты, настроен файервол на ограничение количества сессий до 250, и 10 простых очередей. Канал делится между всеми пользователями поровну. Канал 100 Мбит/с.

Зачем этот онанизм?) У вас колхоз или провайдерство? Если колхоз, не надо вашу сотку вообще никак формально резать, уберите вообще все маркировки и очереди, убедитесь, что без них работает лучше.

Если типа провайдерство - придумайте тарифы и режьте в PCQ примерно так, как советует Saab.

Edited by Барагоз

Share this post


Link to post
Share on other sites

Зачем этот онанизм?) У вас колхоз или провайдерство? Если колхоз, не надо вашу сотку вообще никак формально резать, уберите вообще все маркировки и очереди, убедитесь, что без них работает лучше.

Если типа провайдерство - придумайте тарифы и режьте в PCQ примерно так, как советует Saab.

 

- Вы хотите сказать, что если убрать маркировки, очереди, канал будет поровну делиться между пользователями? Не совсем понятно, что вы представляете под колхозом и провайдерством? Мне необходимо выполнить условие: Тариф один - безлимит до 90 Мбит с гарантированной 8. Как это сделать без очередей?

Edited by georgii

Share this post


Link to post
Share on other sites

- Как я правильно понял из мануала, пакеты маркируются для того, чтобы потом их отловить в очереди (поправьте если не прав).

 

Да, только такие маркировки занимают ресурсы процессора, нужно вам это?

 

- 1 клиент запуская торрент создаёт 5000 сессий, трафик 90 Мбит/с и загрузка процессора 100%. Хоть как-о пытался снизить активность торрента. Отмаркировать торрент так и не получилось.

 

Да, но вы таким образом, еще больше загружаете процессор. Менее затратно по ресурсам просто ограничивать скорость.

 

- Пробовал сделать одну очередь где target указал всю сеть, установил max limit и limit at, установил pcq, маркировались пакеты - шейпинг не работал. Пришлось для каждого пользователя создавать свою очередь.

 

Создаете 2 таких типа шейперов, вместо 1M ставите ваши 8М, при этом абоненты все будут зарезаны на скорости 8М. Что бы это правило работало, просто создаете правило шейпера, не указываете скорость, в качестве типов шейпера на прием и передачу указываете соответствующие значения.

 

/queue type
add kind=pcq name=PCQ_Download pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-limit=500 pcq-rate=1M pcq-src-address6-mask=64 pcq-total-limit=20000
add kind=pcq name=PCQ_Upload pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-limit=500 pcq-rate=1M pcq-src-address6-mask=64 pcq-total-limit=20000

 

Так же вы там можете и 50М поставить, тогда если один клиент качает, у него будет 50М, если 2 начнут качать, им обрежется до 25М и так далее. Только задержка станет более высокой, т.к. микротик будет буферизовать данные.

 

- Вы хотите сказать, что если убрать маркировки, очереди, канал будет поровну делиться между пользователями? Не совсем понятно, что вы представляете под колхозом и провайдерством? Мне необходимо выполнить условие: Тариф один - безлимит до 90 Мбит с гарантированной 8. Как это сделать без очередей?

 

Как я уже написал, вы не сможете сделать так и что бы никто не жаловался. Например у вас тариф 100, следовательно 100 вы никак не сможете раздать, потому что поток данных будет более 100 и его порежет ваш вышестоящий, нужно установить 90, тогда напор трафика извне будет под 100, а вы ограничиваете его на 90, входящие пакеты будут помещаться в буфер, который следует сделать побольше, что бы уже пришедшие данные не отбрасывались, но из-за этого увеличится задержка, порой до 100 и более мс. Разные игры и прочие приложения, критичные к задержкам, нормально работать не смогут. Поэтому если вы хотите давать гарантированные 8, то и давайте 8 с ограничением по 8, для этого подойдут те настройки, что я писал выше.

Share this post


Link to post
Share on other sites

- Оговорюсь. Из опыта все 10 клиентов одновременно не используют канал. Всегда можно сделать скидку на 1-2 клиентов оффлайн.

 

Да, но вы таким образом, еще больше загружаете процессор. Менее затратно по ресурсам просто ограничивать скорость.

 

- Тогда не будет выполнятся условие Max limit - 90 Мбит/с

 

Создаете 2 таких типа шейперов, вместо 1M ставите ваши 8М, при этом абоненты все будут зарезаны на скорости 8М. Что бы это правило работало, просто создаете правило шейпера, не указываете скорость, в качестве типов шейпера на прием и передачу указываете соответствующие значения.

 

/queue type
add kind=pcq name=PCQ_Download pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-limit=500 pcq-rate=1M pcq-src-address6-mask=64 pcq-total-limit=20000
add kind=pcq name=PCQ_Upload pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-limit=500 pcq-rate=1M pcq-src-address6-mask=64 pcq-total-limit=20000

 

Так же вы там можете и 50М поставить, тогда если один клиент качает, у него будет 50М, если 2 начнут качать, им обрежется до 25М и так далее. Только задержка станет более высокой, т.к. микротик будет буферизовать данные.

 

- Изначально использовал деревья (pcq rate=0. Max limit 90M. Limit at 8M), но потом прочитал, что для версий старше 6 оптимальнее использовать простые очереди.

 

Как я уже написал, вы не сможете сделать так и что бы никто не жаловался. Например у вас тариф 100, следовательно 100 вы никак не сможете раздать, потому что поток данных будет более 100 и его порежет ваш вышестоящий, нужно установить 90, тогда напор трафика извне будет под 100, а вы ограничиваете его на 90, входящие пакеты будут помещаться в буфер, который следует сделать побольше, что бы уже пришедшие данные не отбрасывались, но из-за этого увеличится задержка, порой до 100 и более мс. Разные игры и прочие приложения, критичные к задержкам, нормально работать не смогут. Поэтому если вы хотите давать гарантированные 8, то и давайте 8 с ограничением по 8, для этого подойдут те настройки, что я писал выше.

 

- Опять же не будет выполнятся условие Max limit - 90 Мбит/с

Edited by georgii

Share this post


Link to post
Share on other sites

этот 2011 использует тот же процессор что и 951G только в железном корпусе?

 

Упирался в 200 мбит вообще без очередей. Только голый нат.

Share this post


Link to post
Share on other sites

на последней прошивке добавлен функционал Fasttrack , позволяет снизить нагрузку на проц конкретно

 

К сожалению используя fasttrack, трафик не попадает под ограничение очередей.

Share this post


Link to post
Share on other sites

этот 2011 использует тот же процессор что и 951G только в железном корпусе?

 

Упирался в 200 мбит вообще без очередей. Только голый нат.

 

Кроме ната ничего больше настроено не было?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this