Jump to content
Калькуляторы

Access порты и Trunk

Всем доброго времени суток, настраиваю в точности по примеру как в вики, но почему-то не работает, подскажите плиз что упустил.

http://wiki.mikrotik.com/wiki/Manual:CRS_examples

Example 1 (Trunk and Access ports)

 

У меня следующий конфиг

/interface ethernet

set [ find default-name=ether21 ] master-port=ether24

set [ find default-name=ether22 ] master-port=ether24

 

/interface ethernet switch ingress-vlan-translation

add customer-vid=0 new-customer-vid=21 ports=ether21 sa-learning=yes

add customer-vid=0 new-customer-vid=22 ports=ether22 sa-learning=yes

 

/interface ethernet switch egress-vlan-tag

add tagged-ports=ether24 vlan-id=21

add tagged-ports=ether24 vlan-id=22

 

/interface ethernet switch vlan

add ports=ether21,ether24 vlan-id=21

add ports=ether22,ether24 vlan-id=22

 

 

/interface ethernet switch

set drop-if-invalid-or-src-port-not-member-of-vlan-on-ports=ether24,ether21,ether22

 

На транкпорту работает centos

настроены интерфейсы

ifcfg-eth1.21 и ifcfg-eth1.22

 

VLAN=yes

DEVICE=eth1.ХХ

ONBOOT=yes

 

Ну и проблема в том что три девайса, подключенные в эти порты, друг друга не видят.

 

Настраивал эту же конструкцию через бриджи - работает

/interface bridge

add name=bridge21

add name=bridge22

 

/interface vlan

add interface=ether24 l2mtu=1584 name=vlan21 vlan-id=21

add interface=ether24 l2mtu=1584 name=vlan22 vlan-id=22

 

/interface bridge port

add bridge=bridge21 interface=vlan21

add bridge=bridge21 interface=ether21

add bridge=bridge22 interface=vlan22

add bridge=bridge22 interface=ether22

 

 

PS Mikrotik только осваивать начинаю, сильно не пинайте)

Edited by xvld

Share this post


Link to post
Share on other sites

Ваше:

/interface ethernet switch vlan
add ports=ether21,ether24 vlan-id=21
add ports=ether22,ether24 vlan-id=22

 

Мануальное;

/interface ethernet switch vlan
add ports=ether2,ether6 vlan-id=200 learn=yes
add ports=ether2,ether7 vlan-id=300 learn=yes
add ports=ether2,ether8 vlan-id=400 learn=yes

 

Без изучения MAC-адресов, видимо, не алё.

Edited by jagamaster

Share this post


Link to post
Share on other sites

learn=yes указан, в выводе export его нет

# VLAN-ID PORTS SVL LEARN FLOOD INGRESS-MIRROR QOS-GROUP

 

2 21 ether21 no yes no no none

ether24

3 22 ether22 no yes no no none

ether24

 

Share this post


Link to post
Share on other sites

Удалось выяснить почему не работает

На выходе из access-порта не снимается vlan-тег

В вики пишут необходимо использовать параметр vlan-header=always-strip, но в своей железке я его не наблюдаю.

Подскажите как выйти из ситуации?

Свитч CRS125-24G-1S-RM

Share this post


Link to post
Share on other sites

Продвинулся дальше, тег должен удаляться с помощью egress-vlan-translation, но этого не происходит.

Немного упростил пример

tagged VLAN100 <-> ether5 <-> ether4 <-> untagged VLAN100

/interface ethernet switch egress-vlan-tag
add tagged-ports=ether5 vlan-id=100

/interface ethernet switch egress-vlan-translation
add customer-vid=100 new-customer-vid=0 ports=ether4

/interface ethernet switch ingress-vlan-translation
add customer-vid=0 new-customer-vid=100 ports=ether4 sa-learning=yes

/interface ethernet switch vlan
add ports=ether4,ether5 vlan-id=100

Edited by xvld

Share this post


Link to post
Share on other sites

Это единственная свитч группа на коммутаторе?

Не единственная.

Тестовая группа из двух портов ether4 и ether5 (set [ find default-name=ether4 ] master-port=ether5)

Устальные по умолчанию slave с мастер портом ether1

Share this post


Link to post
Share on other sites

Выдержка из Вики

Note: Multiple master-port configuration is designed as fast and simple port isolation solution, but it limits part of VLAN functionality supported by CRS switch-chip. For advanced configurations use one master-port within CRS switch chip for all ports, configure VLANs and isolate port groups with port isolation profile configuration.

Share this post


Link to post
Share on other sites

Выдержка из Вики

Note: Multiple master-port configuration is designed as fast and simple port isolation solution, but it limits part of VLAN functionality supported by CRS switch-chip. For advanced configurations use one master-port within CRS switch chip for all ports, configure VLANs and isolate port groups with port isolation profile configuration.

А можно перевести(объяснить)? А то что с моим "английским"(и с гуглтранслейтером) не совсем понятно.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this