Jump to content
Калькуляторы

Подземный стук ASR1002-X, 10G@LACP

Свежая кошка, port-channel 2*10G, нагрузки нет.

Поверх port-channel есть влан, в котором бегает ospf.

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.2.204.33    1   2WAY/DROTHER    00:00:30    1.2.204.33  Port-channel1.5
1.2.204.34    1   2WAY/DROTHER    00:00:30    1.2.204.34  Port-channel1.5
1.2.204.35    1   2WAY/DROTHER    00:00:39    1.2.204.35  Port-channel1.5
1.2.204.37    1   2WAY/DROTHER    00:00:32    1.2.204.37  Port-channel1.5
1.2.204.38    1   2WAY/DROTHER    00:00:30    1.2.204.38  Port-channel1.5
1.2.204.42    1   2WAY/DROTHER    00:00:35    1.2.204.42  Port-channel1.5
1.2.204.47    1   2WAY/DROTHER    00:00:31    1.2.204.47  Port-channel1.5
1.2.204.49    1   2WAY/DROTHER    00:00:36    1.2.204.49  Port-channel1.5
1.2.204.50    1   2WAY/DROTHER    00:00:37    1.2.204.50  Port-channel1.5
1.2.204.52    1   2WAY/DROTHER    00:00:31    1.2.204.52  Port-channel1.5
1.2.204.56    1   FULL/DR         00:00:39    1.2.204.56  Port-channel1.5
1.2.204.57    1   FULL/BDR        00:00:39    1.2.204.57  Port-channel1.5
1.2.204.62    1   2WAY/DROTHER    00:00:34    1.2.204.62  Port-channel1.5

 

Грабельки:

В зависимости от фазы луны, и от очерёдности передёргивания портов-патчей, пингуются либо нейборы с последним чётным октетом ip либо, после передёргивания портов - с нечётным.

Соответственно всё что рулится через недоступные хосты - недоступно.

 

В arp все записи есть, маршруты тоже на месте.

 

Аналогичная ситуация была на боевой, точно такой же железке. Там помогло обновление до 03.13.00.S. На этой железке - не помогает.

 

Проблема возникает только в ситуации, когда включены оба порта. Если погасить любой из портов - всё работает штатно.

 

 

Конфиг тривиален:

ASR:

 

interface Port-channel1
no ip address
end

interface TenGigabitEthernet0/2/0
no ip address
channel-group 1 mode passive
end

interface TenGigabitEthernet0/3/0
no ip address
channel-group 1 mode active
end

interface Port-channel1.5
encapsulation dot1Q 5
ip address 1.2.204.39 255.255.255.224
end

 

Диагностика со стороны ASR:

 

ASR1002-X-2#sh lacp 1 in d
Flags:  S - Device is requesting Slow LACPDUs
       F - Device is requesting Fast LACPDUs
       A - Device is in Active mode       P - Device is in Passive mode

Channel group 1

Actor (internal) information:

                Actor                 Actor                Actor
Port             System ID             Port Number  Age     Flags
Te0/2/0          32768,78ba.f9ec.0400  0x81         15s    SP

         LACP Actor           Actor           Actor
         Port Priority        Oper Key        Port State
         32768                0x1             0x3C

         Port State Flags Decode:
         Activity:   Timeout:   Aggregation:   Synchronization:
         Passive     Long       Yes            Yes

         Collecting:   Distributing:   Defaulted:   Expired:
         Yes           Yes             No           No
                Actor                 Actor                Actor
Port             System ID             Port Number  Age     Flags
Te0/3/0          32768,78ba.f9ec.0400  0xC1         14s    SA

         LACP Actor           Actor           Actor
         Port Priority        Oper Key        Port State
         32768                0x1             0x3D

         Port State Flags Decode:
         Activity:   Timeout:   Aggregation:   Synchronization:
         Active      Long       Yes            Yes

         Collecting:   Distributing:   Defaulted:   Expired:
         Yes           Yes             No           No

ASR1002-X-2#sh lacp ne d
Flags:  S - Device is requesting Slow LACPDUs
       F - Device is requesting Fast LACPDUs
       A - Device is in Active mode       P - Device is in Passive mode

Channel group 1 neighbors

Partner's information:

         Partner               Partner                     Partner
Port           System ID             Port Number     Age         Flags
Te0/2/0         32768,f866.f2d2.f280  0x60A             5s        SA

         LACP Partner         Partner         Partner
         Port Priority        Oper Key        Port State
         32768                0x40            0x3D

         Port State Flags Decode:
         Activity:   Timeout:   Aggregation:   Synchronization:
         Active      Long       Yes            Yes

         Collecting:   Distributing:   Defaulted:   Expired:
         Yes           Yes             No           No
         Partner               Partner                     Partner
Port           System ID             Port Number     Age         Flags
Te0/3/0         32768,f866.f2d2.f280  0x60E             0s        SP

         LACP Partner         Partner         Partner
         Port Priority        Oper Key        Port State
         32768                0x40            0x3C

         Port State Flags Decode:
         Activity:   Timeout:   Aggregation:   Synchronization:
         Passive     Long       Yes            Yes

         Collecting:   Distributing:   Defaulted:   Expired:
         Yes           Yes             No           No

 

Другая сторона, 7609 RSP720-3cxl, ws6716

 

 

interface Port-channel64
description ASR1002X-2
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 5,200,1634
switchport mode trunk
switchport nonegotiate
storm-control broadcast level 1.00
storm-control multicast level 1.00
end

interface TenGigabitEthernet6/9
switchport
switchport trunk allowed vlan 5,200,1634
switchport mode trunk
switchport nonegotiate
storm-control broadcast level 1.00
storm-control multicast level 1.00
no cdp enable
channel-group 64 mode active
end

interface TenGigabitEthernet6/13
switchport
switchport trunk allowed vlan 5,200,1634
switchport mode trunk
switchport nonegotiate
storm-control broadcast level 1.00
storm-control multicast level 1.00
no cdp enable
channel-group 64 mode passive
end

interface Vlan5
ip address 1.2.204.35 255.255.255.224
no ip proxy-arp
end

 

Диагностика со стороны 7609:

 

router#sh lacp 64 in de
Flags:  S - Device is requesting Slow LACPDUs
       F - Device is requesting Fast LACPDUs
       A - Device is in Active mode       P - Device is in Passive mode

Channel group 64

Actor (internal) information:

                Actor                 Actor                Actor
Port             System ID             Port Number  Age     Flags
Te6/9            32768,f866.f2d2.f280  0x60A        98s    SA

         LACP Actor           Actor           Actor
         Port Priority        Oper Key        Port State
         32768                0x40            0x3D

         Port State Flags Decode:
         Activity:   Timeout:   Aggregation:   Synchronization:
         Active      Long       Yes            Yes

         Collecting:   Distributing:   Defaulted:   Expired:
         Yes           Yes             No           No
                Actor                 Actor                Actor
Port             System ID             Port Number  Age     Flags
Te6/13           32768,f866.f2d2.f280  0x60E        95s    SP

         LACP Actor           Actor           Actor
         Port Priority        Oper Key        Port State
         32768                0x40            0x3C

         Port State Flags Decode:
         Activity:   Timeout:   Aggregation:   Synchronization:
         Passive     Long       Yes            Yes

         Collecting:   Distributing:   Defaulted:   Expired:
         Yes           Yes             No           No

router#sh lacp 64 ne d
Flags:  S - Device is requesting Slow LACPDUs
       F - Device is requesting Fast LACPDUs
       A - Device is in Active mode       P - Device is in Passive mode

Channel group 64 neighbors

Partner's information:

         Partner               Partner                     Partner
Port           System ID             Port Number     Age         Flags
Te6/9           32768,78ba.f9ec.0400  0x81            112s        SP

         LACP Partner         Partner         Partner
         Port Priority        Oper Key        Port State
         32768                0x1             0x3C

         Port State Flags Decode:
         Activity:   Timeout:   Aggregation:   Synchronization:
         Passive     Long       Yes            Yes

         Collecting:   Distributing:   Defaulted:   Expired:
         Yes           Yes             No           No
         Partner               Partner                     Partner
Port           System ID             Port Number     Age         Flags
Te6/13          32768,78ba.f9ec.0400  0xC1            109s        SA

         LACP Partner         Partner         Partner
         Port Priority        Oper Key        Port State
         32768                0x1             0x3D

         Port State Flags Decode:
         Activity:   Timeout:   Aggregation:   Synchronization:
         Active      Long       Yes            Yes

         Collecting:   Distributing:   Defaulted:   Expired:
         Yes           Yes             No           No

 

Куда бы покопать?

Share this post


Link to post
Share on other sites

lacp active / active с обоих сторон

Share this post


Link to post
Share on other sites

lacp active / active с обоих сторон

 

Было исходно, с тем же эффектом.

Share this post


Link to post
Share on other sites

У вас не подземный стук, а тупо portchannel не работает. Разберите его полностью да соберите заново для начала с каждой стороны.

И зачем passive/active на разных шнурках?

Share this post


Link to post
Share on other sites

И зачем passive/active на разных шнурках?

я тоже не понял что это за финт такой

Share this post


Link to post
Share on other sites

для более быстрой сходимости внутри ядра все же лучше active / active..

Edited by zhenya`

Share this post


Link to post
Share on other sites

active-passive это следы битья в бубен.

 

Как я уже говорил, изначально оно было в active-active.

 

Контрольно пересобрал port-channel с обоих сторон в active-active. Эффект стабилен.

Share this post


Link to post
Share on other sites

Попробуйте какой-нибудь рекомендованный Cisco TAC софт, например 3.10.5. Такая простая штука там должна работать без проблем.

 

+1 за active/active

Share this post


Link to post
Share on other sites

Cisco IOS XE Software, Version 03.13.03.S - Extended Support Release

 

"Состояние стальное, идём ко дну". =)

Share this post


Link to post
Share on other sites

Предварительный результат.

 

Включили третий линк в port-channel.

Задышало.

Причём задышало даже если гасить линки поштучно.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this