Jump to content
Калькуляторы

Помогите не сломать мозг окончательно Mikrotik 951G2HnD + 4g LTE Megafon (M150-1)

Доброго времени суток!

Ни как не могу побелить в битве с Микротиком. В него воткнут 4Г модем он определился как LTE1 его настроил вроде все ок (модем перешил в hilink) Суть проблемы что подключаясь к микротику по вайфай в интернет выпускает и все хорошо а подключаясь по проводу пишет что проблемы с DNS, помогите советом где что я упустил в настройках микротика??? мозг взрывается переодически, всякие инструкции и гайды по настройке перечитал делал все как там написано, но толку НОЛЬ по вайфаю микротик в интернет выпускает а по проводу нет.

 

Может уже где то проскакивала такая тема? Ткните плиз в нее, если ни кто не может объяснить ...

Edited by novatir

Share this post


Link to post
Share on other sites

Сбрасываете настройки микротика полностью, убрав начальную конфигурацию.

 

Подключаете модем обратно, вешаете на его интерфейс DHCP клиента. Включаете, при необходимости, локальный DNS.

Создаете бридж и добавляете туда беспроводной адаптер и сетевой порт, вешаете на бридж адрес локальной сети вида 192.168.0.1/24, настраиваете DHCP сервер на выдачу локальных адресов.

В файрволе создаете правило маскардинга по src.address=192.168.0.0/24.

 

Все работает.

Share this post


Link to post
Share on other sites

Сбрасываете настройки микротика полностью, убрав начальную конфигурацию.

 

Подключаете модем обратно, вешаете на его интерфейс DHCP клиента. Включаете, при необходимости, локальный DNS.

Создаете бридж и добавляете туда беспроводной адаптер и сетевой порт, вешаете на бридж адрес локальной сети вида 192.168.0.1/24, настраиваете DHCP сервер на выдачу локальных адресов.

В файрволе создаете правило маскардинга по src.address=192.168.0.0/24.

 

Все работает.

 

Сбросил настройки, сбросил начальную конфигурацию, воткнул модем lte1 нашелся модем засветился синим глазом, далее повесил на него dncp клиента, сделал бридж вообщем проделал все манипуляции и нифига не заработало по проводу в сеть не пускает, может есть где посмотреть по шагово или в терминальном режиме что писать ....

Share this post


Link to post
Share on other sites

Сбросил настройки, сбросил начальную конфигурацию, воткнул модем lte1 нашелся модем засветился синим глазом, далее повесил на него dncp клиента, сделал бридж вообщем проделал все манипуляции и нифига не заработало по проводу в сеть не пускает, может есть где посмотреть по шагово или в терминальном режиме что писать ....

 

Вот конфиг для 5 портового роутера. Если у вас один порт на нем, то в бридж добавьте нужный порт. После этого все работает по поводу выдачи адресов, достаточно подключить провайдера, получить от него дефолтный маршрут как все заработает. Когда DHCP клиента настраиваете, там надо галочку поставить. Ниже команда для вставки в терминал, ether1 замените на имя вашего интерфейса lte.

 

/ip dhcp-client
add default-route-distance=0 disabled=no interface=ether1

 

 

 

/interface bridge

add name=bridge1

/ip pool

add name=dhcp_pool1 ranges=192.168.0.2-192.168.0.254

/ip dhcp-server

add address-pool=dhcp_pool1 disabled=no interface=bridge1 lease-time=10m name=dhcp1

/interface bridge port

add bridge=bridge1 interface=ether5

add bridge=bridge1 interface=ether4

add bridge=bridge1 interface=ether3

add bridge=bridge1 interface=ether2

/ip address

add address=192.168.0.1/24 interface=bridge1

/ip dhcp-server network

add address=192.168.0.0/24 dns-server=192.168.0.1 gateway=192.168.0.1

/ip dns

set allow-remote-requests=yes

/ip firewall nat

add action=masquerade chain=srcnat src-address=192.168.0.0/24

Share this post


Link to post
Share on other sites

Все сделал прописал, при подключении компа по проводу к микротику появляется сеть, С доступок к интернету, но при открытии страниц выскакивает DNS_config_error и все на этом (

Share this post


Link to post
Share on other sites

Галочка стоит, эфекта ноль, на самом деле уже не знаю что надо прописать что б это коробка нормально заработала

Share this post


Link to post
Share on other sites

Может, Вы ничего упустили в микротике?

 

К какому DNS-серверу обращается компьютер?

Share this post


Link to post
Share on other sites

К какому DNS-серверу обращается компьютер?

 

 add address=192.168.0.0/24 dns-server=192.168.0.1 gateway=192.168.0.1

/ip dns

set allow-remote-requests=yes

 

действительно к какому, мб к 10.87.200.999 ? %)

 

/ip firewall nat

add action=masquerade chain=srcnat src-address=192.168.0.0/24

это вот натит куда?

Share this post


Link to post
Share on other sites

Это натит через тот интерфейс, через который пакет улетает согласно таблицы маршрутизации. И да, лучше конкретезируйте это правило через внешний интерфейс.

 

А вообще, запустите torch на внутреннем интерфейсе и изучайте судьбу DNS-пакетов.

Share this post


Link to post
Share on other sites

Это натит через тот интерфейс, через который пакет улетает согласно таблицы маршрутизации. И да, лучше конкретезируйте это правило через внешний интерфейс.

 

Не нужно делать нат через внешний интерфейс в правилах, его нужно делать только по src.address, при необходимости добавив исключения. Микротик сам определит через какой интерфейс делать нат в зависимости от маршрутной информации.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this