Jump to content
Калькуляторы

isis Redback---Cisco Не работает isis Redback---Cisco Не работает

cisco_1

 

interface GigabitEthernet0/0.22

description IS-IS

encapsulation dot1Q 22

ip address 10.46.1.2 255.255.255.0

ip router isis

ipv6 address FE80::A2E:102 link-local

ipv6 enable

ipv6 router isis

!

interface GigabitEthernet0/0.25

encapsulation dot1Q 25

ip address 192.168.25.248 255.255.255.0

ipv6 address FE80::C0A8:19F8 link-local

ipv6 enable

ipv6 address 2001:0002::45a/64

 

!

router isis

net 49.0001.0000.0000.2002.00

metric-style wide

log-adjacency-changes

redistribute static ip

passive-interface default

no passive-interface GigabitEthernet0/0.22

!

address-family ipv6

multi-topology

redistribute static

exit-address-family

!

----------------------------------------------------

cisco_2

 

interface FastEthernet0/0.22

encapsulation dot1Q 22

ip address 10.46.1.1 255.255.255.0

ipv6 address FE80::A2E:101 link-local

ipv6 enable

ipv6 address 2001:0002::45c/64

ip router isis

ipv6 router isis

!

 

router isis

net 49.0001.0000.0000.2001.00

metric-style wide

log-adjacency-changes

redistribute static ip

passive-interface default

no passive-interface FastEthernet0/0.22

!

address-family ipv6

multi-topology

redistribute static

exit-address-family

!

---------------------------------------------------

 

%CLNS-5-ADJCHANGE: ISIS: Adjacency to 0000.0000.2002 (FastEthernet0/0.22) Up, new adjacency

%CLNS-5-ADJCHANGE: ISIS: Adjacency to 0000.0000.2002 (FastEthernet0/0.22) Up, new adjacencyxit

 

Проверка

cisco_1

 

ping 2001:0002::45c

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2001:2::45C, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

 

cisco_2

 

ping 192.168.25.248

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.25.248, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

 

ping 2001:2::45A

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2001:2::45A, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/4 ms

 

-----------------------------------------------------------------------------------

Роутинг с Cisco_1

 

Gateway of last resort is not set

 

172.16.0.0/32 is subnetted, 1 subnets

i L1 172.16.172.1 [115/10] via 10.46.1.1, 00:01:00, GigabitEthernet0/0.22

 

show ipv6 route isis

IPv6 Routing Table - default - 2 entries

Codes: C - Connected, L - Local, S - Static, U - Per-user Static route

B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP

H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea

IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO

ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect

O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, la - LISP alt

lr - LISP site-registrations, ld - LISP dyn-eid, a - Application

I1 2001:2::/64 [115/10]

via FE80::A2E:101, GigabitEthernet0/0.22

 

-----------------------------------------------------------------------------------

теперь RedbAck SE600

 

!

interface IS-IS

ip address 10.46.1.3/24

ipv6 link-local fe80::a2e:103

!

 

!

router isis SSE600_2

net 49.0001.0000.0000.2003.00

address-family ipv4 unicast

redistribute static

address-family ipv6 unicast

redistribute static

!

interface IS-IS

! bind to link-group dot1q-1q pvc 100

address-family ipv4 unicast

address-family ipv6 unicast

 

 

---------------------------------------------

проверка

 

Cisco_1#ping 10.46.1.3

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.46.1.3, timeout is 2 seconds:

!!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms

 

Cisco_2#ping fe80::a2e:103

Output Interface: FastEthernet0/0.22

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to FE80::A2E:103, timeout is 2 seconds:

Packet sent with a source address of FE80::A2E:101

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/8 ms

 

sse600

 

RSSE2#show isis database

 

IS-IS level 1 link-state database for tag SSE600_2:

LSPID Sequence Checksum Holdtime AT/OL Len

RSSE2.00-00* 0xf 0x3834 1134 1/0 87

 

Total IS-IS LSP(s) for tag SSE600_2 in Level-1: 1

 

IS-IS level 2 link-state database for tag SSE600_2:

LSPID Sequence Checksum Holdtime AT/OL Len

RSSE2.00-00* 0xd 0x3721 1134 0/0 212

 

Total IS-IS LSP(s) for tag SSE600_2 in Level-2: 1

 

Логи с эриксона

 

May 29 09:00:28: %SHMM-6-INFO: ndd: Attaching to existing shared memory instance for key 77834 in sds-ipcc(0x1001fe000)

May 29 09:05:12: %SHMM-6-INFO: isisd: Attaching to existing shared memory instance for key 77834 in sds-ipcc(0x1003e5000)

 

и ничего не работает

кто знает в чем причина ?

Edited by alexpn

Share this post


Link to post
Share on other sites

Вроде как ISIS на эрике только для межконтекстной маршрутизации.

Share this post


Link to post
Share on other sites

интерфейсы все добавлены? Соседство покажите

Share this post


Link to post
Share on other sites

интерфейсы все добавлены? Соседство покажите

 

дак во соседства с эрриксоном то и нет

странно както в доке все есть

да и в доке есть функция multi-topology

у меня её нет !!! прикол какойто

 

IOS

show version

 

Redback Networks SmartEdge OS Version SEOS-12.1.1.9-Release

Built by sysbuild@eussjlx7016.sj.us.am.ericsson.se Mon Jan 26 23:09:19 PST 2015

Copyright © 1998-2015, Redback Networks Inc. All rights reserved.

System Bootstrap version is Mips,rev2.0.2.68

Installed minikernel version is 11.7

Router Up Time - 102 days, 12 hours 37 minutes 3 secs

Edited by alexpn

Share this post


Link to post
Share on other sites

Вроде как ISIS на эрике только для межконтекстной маршрутизации.

ну в доке то все ок !!!

Share this post


Link to post
Share on other sites

Вроде как ISIS на эрике только для межконтекстной маршрутизации.

это как рекомендация, т.к. ISIS самый легкий в настройке. Вы можете для межконтекстной использовать и другие протоколы.

 

странным кажется команда

passive-interface default

напишите

no passive на нужный интерфейс

Share this post


Link to post
Share on other sites

Вроде как ISIS на эрике только для межконтекстной маршрутизации.

это как рекомендация, т.к. ISIS самый легкий в настройке. Вы можете для межконтекстной использовать и другие протоколы.

 

странным кажется команда

passive-interface default

напишите

no passive на нужный интерфейс

 

Проблема была банальна

 

в circuit mtu

установил значение чуть меньше чем на циске и все заработало

show ip route isis

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

a - application route

+ - replicated route, % - next hop override

 

Gateway of last resort is 10.46.1.3 to network 0.0.0.0

 

i*L1 0.0.0.0/0 [115/10] via 10.46.1.3, 00:02:10, GigabitEthernet0/0.22

10.0.0.0/8 is variably subnetted, 11 subnets, 3 masks

i L2 10.0.14.0/24 [115/10] via 10.46.1.3, 00:02:08, GigabitEthernet0/0.22

i L2 10.1.0.0/24 [115/10] via 10.46.1.3, 00:02:08, GigabitEthernet0/0.22

i L2 10.1.2.0/24 [115/10] via 10.46.1.3, 00:02:08, GigabitEthernet0/0.22

i L2 10.1.3.0/24 [115/10] via 10.46.1.3, 00:02:08, GigabitEthernet0/0.22

i L2 10.1.11.0/24 [115/10] via 10.46.1.3, 00:02:08, GigabitEthernet0/0.22

i L2 10.10.255.0/30

[115/10] via 10.46.1.3, 00:02:08, GigabitEthernet0/0.22

i L2 10.46.0.0/24 [115/10] via 10.46.1.3, 00:02:08, GigabitEthernet0/0.22

i L2 10.50.1.0/30 [115/10] via 10.46.1.3, 00:02:08, GigabitEthernet0/0.22

i L2 10.50.1.4/30 [115/10] via 10.46.1.3, 00:02:10, GigabitEthernet0/0.22

Share this post


Link to post
Share on other sites

вообщем помогите кто знает

заводится IS-IS только с MTU 1500

мне нужно чтоб на интерфейсе MTU был 9198

пробовал следующее

cisco

clns mtu 1500 не помогает

no isis hello padding не помогает

 

на эриксоне

circuit mtu 1500

по другому не заводится

кто знает куда копать ???

на интерфейсе с виланом MTU задать отдельно не могу

clns mtu 1500 не воспринимается

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this