Jump to content

Carbon billing 4 + Cisco 7301 +PPPoE Помошь во внедрении.

Добрый день.

Стала задача разделить Carbon billing Softrouter на отдельные составляющие(billing и Cisco 7301)

Знаний в данном вопросе маловато но стараюсь все перевести.

Все в биллинге делалось по инструкции http://sladocs.carbonsoft.ru:8084/pages/viewpage.action?pageId=29032767

Но не передаются с биллинга радиус атребуты? Лог в папке радиус не заполняется...

В скрипте генерирует данные для передачи но не отправляет их?

В какую сторону копать?

 

Cisco конфиг делал по нескольким инструкциям:

!

! NVRAM config last updated at 10:35:03 Russia Wed May 27 2015

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname nas1

!

boot-start-marker

boot bootldr disk0:

boot-end-marker

!

!

aaa new-model

!

!

aaa authentication ppp default group radius

aaa authorization network default group radius

aaa accounting delay-start

aaa accounting update periodic 5

aaa accounting network default start-stop group radius

!

aaa session-id common

clock timezone Russia 3

ip subnet-zero

no ip source-route

ip cef

!

!

ip flow-cache timeout inactive 10

ip flow-cache timeout active 1

no ip bootp server

ip domain name nas1

ip name-server XXX.XXX.XXX.XXX

ip name-server XXX.XXX.XXX.XXX

!

!

virtual-template 1 pre-clone 500

!

!

policy-map policy_out512

class class-default

shape average 528000 5000 5000

policy-map policy_out1024

class class-default

shape average 1096000 10000 10000

policy-map policy_in1024

class class-default

police cir 1096000

conform-action transmit

exceed-action drop

policy-map policy_in512

class class-default

police cir 528000 bc 96000 be 192000

conform-action transmit

exceed-action drop

!

!

bba-group pppoe global

virtual-template 1

sessions max limit 8000

ac name nas1

sessions per-mac limit 1

sessions per-vlan limit 500

!

!

interface GigabitEthernet0/0

ip address XXX.XXX.XXX.XXX 255.255.255.248

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

media-type gbic

no negotiation auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

media-type rj45

no negotiation auto

!

interface GigabitEthernet0/2

ip address 192.168.XXX.1 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

media-type rj45

no negotiation auto

!

interface Virtual-Template1

mtu 1492

ip unnumbered GigabitEthernet0/1

ip route-cache flow

autodetect encapsulation ppp

peer default ip address pool PPPoE

ppp max-bad-auth 3

ppp authentication chap radius

ppp authorization radius

ppp accounting radius

ppp timeout retry 3

ppp timeout authentication 45

ppp timeout idle 3600

!

ip classless

ip route 0.0.0.0 0.0.0.0 XXX.XXX.XXX.XXX

no ip http server

no ip http secure-server

!

ip flow-export source GigabitEthernet0/2

ip flow-export version 5

ip flow-export destination 192.168.XXX.2 9996

!

ip nat inside source list nat interface GigabitEthernet0/0 overload

!

ip access-list extended nat

permit ip host 192.168.XXX.3 any

permit ip host 192.168.XXX.4 any

permit ip host 192.168.XXX.5 any

!

logging alarm informational

!

!

radius-server attribute 8 include-in-access-req

radius-server host 192.168.XXX.2 auth-port 1812 acct-port 1813

radius-server retransmit 5

radius-server timeout 30

radius-server deadtime 1

radius-server key secret_pass

radius-server vsa send accounting

radius-server vsa send authentication

!

control-plane

!

!

gatekeeper

shutdown

!

!

line con 0

stopbits 1

line aux 0

stopbits 1

line vty 0 4

!

ntp clock-period 17180152

ntp update-calendar

ntp server 91.226.136.136

!

end

 

Данные выхода со скрипта Event.sh

05/27/15 10:19:06 [1123] INF SYSTEM.EVENTSH login id=78 login=Andrey ip=10.129.0.1 mac= server=0 snat_ip=192.168.XXX.2 finance_user=1 enabled=1 deleted=0 end_user=1 logged=1 auth_type=6 tariff_id=14 contract_number=-1 always_logged=0 nas_ip=192.168.XXX.1 router_ip=0.0.0.0 router_vlan=-1 ROUTER_PORT=-1 router_port=-1 opt82=0 OPT82=0 over_limit=0 limit=-1 balance=0 unlimited=0 limit_ip=0.0.0.0 sms= ps_do_block=0 nas_type=9 radius_secret=secret_pass coa_psw= nas_name=7301 script_name=event_inc.sh disabled_date= acl=0 policy_overlimit=1 own_disabled_end=-1 rate_in=512 rate_out=512 ceil_in=512 ceil_out=512 double_login=0 acct_session_id= radius_logged=0 tray_logged=0 real_host_ip=-1 radius_host_ip=-1 stb_ip=0.0.0.0

radclient: no response from server for ID 201

Sending CoA-Request of id 201 to 192.168.XXX.1 port 1700

User-Name = "Andrey"

Cisco-Account-Info = "S10.129.0.1"

Cisco-AVPair += "ip:sub-qos-policy-in=policy_in512"

Cisco-AVPair += "ip:sub-qos-policy-out=policy_out512"

Re-sending CoA-Request of id 201 to 192.168.XXX.1 port 1700

Edited by ros-maksim

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.