Jump to content
Калькуляторы

PPTP из интернета не соединяет а из лана работает

бьюсь неделю уже, есть 2 провайдера, настроены по дистанции 1,2 и пинг чеку (т.е работает только ISP1 а ISP2 ждет как запасной)

правила фаервола - открыто всё, нат стандартный, маскаражинг Out интерфейсов isp1 и isp2.

PPTP тоже настроено стандартно, и работает из LAN сети, а когда конекчусь извне - даже логи молчат, никакой реакции, видно только в Torch'e что коннект приходит на пару сек на pptp порт, и пропадает...

где может быть проблема ?

 

уже грешу на то что вырублена эта опция в quick set, но врубить обратно чревато, она конфиг весь меняет и офис упадёт :)

post-127766-023189400 1432630562_thumb.png

 

 

export compact# may/21/2015 11:48:36 by RouterOS 6.27/interface bridgeadd name=LANWAN/interface ethernetset [ find default-name=ether1 ] comment=ISP1set [ find default-name=ether2 ] comment=ISP2set [ find default-name=ether3 ] comment=LANset [ find default-name=ether4 ] comment=WAN/ip neighbor discoveryset ether1 comment=ISP1set ether2 comment=ISP2set ether3 comment=LANset ether4 comment=WAN/ip pooladd name=dhcp ranges=192.168.30.50-192.168.30.250/ip dhcp-serveradd address-pool=dhcp disabled=no interface=LANWAN lease-time=1d name=DHCP/portset 0 name=serial0set 1 name=serial1/ppp profileadd local-address=192.168.30.1 name=pptp remote-address=192.168.30.40/snmp communityadd addresses=0.0.0.0/0 name=nemo/interface bridge portadd bridge=LANWAN interface=ether3add bridge=LANWAN interface=ether4/interface l2tp-server serverset ipsec-secret=xxxxxxxxxxxxxx use-ipsec=yes/interface pptp-server serverset default-profile=pptp enabled=yes/ip addressadd address=xxxxxxxxxxxxxx/29 interface=ether1 network=xxxxxxxxxxxxxxadd address=xxxxxxxxxxxxxx/30 interface=ether2 network=xxxxxxxxxxxxxxadd address=192.168.30.1/23 interface=LANWAN network=192.168.30.0/ip cloudset ddns-enabled=yes/ip dhcp-server networkadd address=192.168.30.0/23 dns-server=xxxxxxxxxxxxxx gateway=192.168.30.1/ip dnsset allow-remote-requests=yes servers=xxxxxxxxxxxxxx/ip firewall address-listadd address=192.168.4.0/22 list=LocalNetadd address=192.168.30.0/23 list=LocalNetadd address=172.30.10.0/24 list=LocalNetadd address=192.168.0.0/23 list=LocalNetadd address=172.30.200.0/24 list=LocalNet/ip firewall filteradd chain=input comment="Allow gre" protocol=greadd chain=input comment="Allow port 1723" dst-port=1723 protocol=tcpadd chain=forward comment="Allow all subnets" dst-address-list=LocalNet \   src-address-list=LocalNetadd chain=input comment="Allow ping" protocol=icmpadd chain=forward protocol=icmpadd chain=input comment="Allow estabilished" connection-state=establishedadd chain=forward connection-state=establishedadd chain=input comment="Allow related" connection-state=relatedadd chain=forward connection-state=relatedadd chain=input comment="Allow UDP" protocol=udpadd chain=forward protocol=udpadd action=drop chain=input comment="Drop invalid" connection-state=invalidadd action=drop chain=forward connection-state=invalid/ip firewall natadd action=masquerade chain=srcnat comment=\   "Masquerade out traffic ISP1" out-interface=ether1add action=masquerade chain=srcnat comment="ISP2" \   out-interface=ether2add action=netmap chain=dstnat comment=\   "NAT to web server at Web PC" in-interface=all-ethernet \   protocol=tcp to-addresses=192.168.30.121 to-ports=80/ip firewall service-portset ftp disabled=yesset tftp disabled=yesset irc disabled=yesset h323 disabled=yes/ip routeadd check-gateway=ping comment="ISP1 Gateway" distance=1 gateway=\   xxxxxxxxxxxxxxadd check-gateway=ping comment="ISP2 Gateway" distance=2 gateway=\   xxxxxxxxxxxxxxadd comment="AMS1" distance=1 dst-address=172.30.10.0/23 gateway=\   192.168.30.31add comment="AMS2" distance=1 dst-address=172.30.200.0/24 gateway=\   192.168.30.31add comment="OFFICE1" distance=1 dst-address=192.168.0.0/23 gateway=\   192.168.30.31add comment="OFFICE2" distance=1 dst-address=192.168.4.0/22 gateway=\   192.168.30.31/ip serviceset telnet disabled=yesset ftp disabled=yesset ssh disabled=yesset www-ssl disabled=no/ip upnpset enabled=yes/ip upnp interfacesadd interface=LANWAN type=internaladd interface=ether1 type=externaladd interface=ether2 type=external/ppp profileset 2 local-address=1.89.168.192 remote-address=*3/ppp secretadd local-address=192.168.30.1 name=vpnadm password=xxxxxxxxxxxxxx profile=pptp \   remote-address=192.168.30.42 service=pptp

 

post-127766-023189400 1432630562_thumb.png

Edited by gradash

Share this post


Link to post
Share on other sites

А чёйта у вас не видно маршрута по умолчанию помоему? Когда вы удалённо соединяетесь откуда ему знать через какого провайдера отвечать? У Вас вообще Интернет то работает в локалках?

Снял вопрос увидал (експорт не пишет 0.0.0.0/0)

 

А точно на isp один соединяетесь?

Попробуйте второго провайдера поставить по умолчанию с первой метрикой и на него соединиться.

Провайдер может вам интернет давать через свой маршрутизатор и через нат?

Edited by Соколов

Share this post


Link to post
Share on other sites

А чёйта у вас не видно маршрута по умолчанию помоему? Когда вы удалённо соединяетесь откуда ему знать через какого провайдера отвечать? У Вас вообще Интернет то работает в локалках?

Снял вопрос увидал (експорт не пишет 0.0.0.0/0)

 

 

Нули не пишет, а маршрута нет, есть только два с маркировкой, нужно создать еще один маршрут, или прописать IP адреса удаленных клиентов в маршрутах с большей метрикой и все заработает.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this