Jump to content
Калькуляторы

Как убрать нативный VLAN с транкового порта

Здрасьте всем!

 

Проблема в том, что в (switchport trunk allowed vlan 1,840,931,1002-1005) VLAN 1 и 1002-1005 появляются автоматом и не позволяют себя удалить.

 

WS-C3524-PWR-RusDvor#sh ver

Cisco Internetwork Operating System Software
IOS (tm) C3500XL Software (C3500XL-C3H2S-M), Version 12.0(5)WC17, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2007 by cisco Systems, Inc.
Compiled Tue 13-Feb-07 15:04 by antonino
Image text-base: 0x00003000, data-base: 0x00352924

ROM: Bootstrap program is C3500XL boot loader

WS-C3524-PWR-RusDvor uptime is 1 week, 5 days, 9 hours, 11 minutes
System returned to ROM by power-on
System image file is "flash:c3500xl-c3h2s-mz.120-5.WC17.bin"


cisco WS-C3524-PWR-XL (PowerPC403) processor (revision 0x01) with 8192K/1024K bytes of memory.
Processor board ID CHK0623W1PK, with hardware revision 0x00
Last reset from power-on

Processor is running Enterprise Edition Software
Cluster command switch capable
Cluster member switch capable
24 FastEthernet/IEEE 802.3 interface(s)
2 Gigabit Ethernet/IEEE 802.3 interface(s)

32K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 00:09:E8:1B:F9:40
Motherboard assembly number: 73-4033-08
Power supply part number: 34-0968-02
Motherboard serial number: CAT062304RM
Power supply serial number: LIT062101WG
Model revision number: F0
Motherboard revision number: A0
Model number: WS-C3524-PWR-XL-EN
Daughterboard serial number: CAT0623023C
System serial number: CHK0623W1PK
Configuration register is 0xF

 

WS-C3524-PWR-RusDvor#sh run
Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname WS-C3524-PWR-RusDvor
!
enable secret 5 $1$yj4Z$C4H1VZ/TR179UciDebARf0
!
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
description Trunk IKS  ! Это аплинк на провайдера 2 и здесь пойдет VLAN 840 и VLAN 931 но VLAN 1 нужно убрать.
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,840,931,1002-1005
switchport mode trunk
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
description Uplink Enter   ! Это аплинк на провайдера 1
switchport access vlan 198
power inline never
no cdp enable
!
interface GigabitEthernet0/1
description Trunk Office ! А это транк в офис
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,198,199,1002-1005
switchport mode trunk
!
interface GigabitEthernet0/2
description Grigorich Home
!
interface VLAN1
ip address 192.168.199.212 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
ip default-gateway 192.168.199.199
snmp-server engineID local 0000000902000009E81BF940
snmp-server community private RW
snmp-server community public RO
!
line con 0
transport input none
stopbits 1
line vty 0 4
password password
login
line vty 5 15
password password
login
!
end

 

Свитч стоит на площадке провайдера.

Edited by sunrise333

Share this post


Link to post
Share on other sites

switchport trunk allowed vlan remove 1 ?

Команду то я знал, только она не проходила в старых свитчах.

И всё равно спасибо.

Share this post


Link to post
Share on other sites

switchport trunk allowed vlan remove 1 ?

Команду то я знал, только она не проходила в старых свитчах.

И всё равно спасибо.

я просто не знаком с данной моделью. Есть коммутаторы, на которых нельзя убрать первый влан с порта.

Share this post


Link to post
Share on other sites

а что нить типа

switchport trunk native ?
 vlan  Set native VLAN when interface is in trunking mode

есть? Может этим поиграться?

или

switchport trunk ?
..
pruning        Set pruning VLAN characteristics when interface is in trunking mode
..

Edited by ShumBor

Share this post


Link to post
Share on other sites

ShumBor

pruning будет срабатывать при настроенном vtp

Share this post


Link to post
Share on other sites

Можно полностью уйти с ВЛАН1 на этом динозавре, например на ВЛАН2. А ВЛАН1 в транке на офис сечь нижестоящим оборудованием.

Также на порте прова можно указать другую native и выключить этот ВЛАН. Это если надо оградиться от нетегированных кадров.

Идея: не использовать ВЛАНы которые нельзы удалить из конфига, и блочить untag кадры от прова.

Share this post


Link to post
Share on other sites

Универсальный метод - назначить трэш влан(который никуда не уходит)

Share this post


Link to post
Share on other sites

Ага а вот и динозавр нашелся.

Собственно совет то нужен в том, что бы управляющий VLAN не летел в сторону провайдера.

 

 

Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch_IKS
!
enable secret 5 $password
!
!
!
!
!
!
no spanning-tree vlan 1
ip subnet-zero
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,800,898,1002-1005
switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
switchport access vlan 898
!
interface FastEthernet0/5
!
interface FastEthernet0/6
switchport access vlan 800
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
ip address 192.168.189.202 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
!
line con 0
transport input none
stopbits 1
line vty 0 4
password password
login
line vty 5 15
login
!
end

 

Switch_IKS#sh ver
Cisco Internetwork Operating System Software
IOS (tm) C3500XL Software (C3500XL-C3H2S-M), Version 12.0(5)WC17, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2007 by cisco Systems, Inc.
Compiled Tue 13-Feb-07 15:04 by antonino
Image text-base: 0x00003000, data-base: 0x00352924

ROM: Bootstrap program is C3500XL boot loader

Switch_IKS uptime is 5 weeks, 19 hours, 30 minutes
System returned to ROM by power-on
System image file is "flash:c3500xl-c3h2s-mz.120-5.WC17.bin"


cisco WS-C3524-PWR-XL (PowerPC403) processor (revision 0x01) with 8192K/1024K bytes of memory.
Processor board ID CHK0621V1C8, with hardware revision 0x00
Last reset from power-on

Processor is running Enterprise Edition Software
Cluster command switch capable
Cluster member switch capable
24 FastEthernet/IEEE 802.3 interface(s)
2 Gigabit Ethernet/IEEE 802.3 interface(s)

32K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 00:09:B7:D4:E0:C0
Motherboard assembly number: 73-4033-08
Power supply part number: 34-0968-02
Motherboard serial number: CAT062003ZF
Power supply serial number: DAB06210GGF
Model revision number: F0
Motherboard revision number: A0
Model number: WS-C3524-PWR-XL-EN
Daughterboard serial number: CAT062006XB
System serial number: CHK0621V1C8
Configuration register is 0xF

Share this post


Link to post
Share on other sites

Если встроенной функции удаления PVID нет, создаёте гарантированно не существующий нигде на вашей сети vlan, вписываете его PVID'ом. Всё. Тов. Лобанов об этом уже писал.

Share this post


Link to post
Share on other sites

Ага а вот и динозавр нашелся.

Собственно совет то нужен в том, что бы управляющий VLAN не летел в сторону провайдера.

У Вас управляющий VLAN 1 ? Поздравляю! Впрочем если из других зарезервированных/специальных - тоже не сахар.

Меняйте VLAN иначе вечно будут всякие сюрпризы.

 

VLAN 1 часто у разных вендоров ведет себя особым образом. И совершенно разным. Вплоть до того что он глобально общий без возможности его запретить или же с возможностью, но где-то в глобальных настройках...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this