Jump to content
Калькуляторы

Alcatel OmniStack LS 6224 Multicast IPTV Кто имел опыт по конфигу этих железок помогите.

Не могу настроить мультикаст что бы работал нормально. после него стоит D-link DES-3200-26 на нем все работает отлично. Что интересно если на длинке смотрел канал один то и на алкателе он тоже работает а другия не работают. Думаю что может где нить в конфиге ошибся.

 

Кусок конфига

 

interface range ethernet e(1-24)

port storm-control broadcast enable

port storm-control include-multicast

exit

no spanning-tree

interface range ethernet g(1-4)

switchport mode general

exit

vlan database

vlan 50

exit

interface range ethernet g(1-4)

switchport general allowed vlan add 50

exit

interface vlan 50

name iptv

exit

interface range ethernet e(1-24)

switchport access multicast-tv vlan 50

exit

ip igmp snooping

interface vlan 50

ip igmp snooping

exit

interface vlan 50

ip igmp snooping querier disable

exit

interface range ethernet e(1-24)

loopback-detection enable

exit

loopback-detection enable

ip access-list securityACL

deny-udp any 67 any any

deny-tcp any any any 42

deny-tcp any any any 135

deny-tcp any any any 139

deny-tcp any any any 369

deny-tcp any any any 445

deny-tcp any any any 593

deny-tcp any any any 2869

deny-tcp any any any 5000

deny-udp any any any 42

deny-udp any any any 137

deny-udp any any any 138

deny-udp any any any 445

deny-udp any any any 1025

permit udp any any

permit igmp any any

permit icmp any any

permit gre any any

permit tcp any any

exit

interface range ethernet e(1-24)

service-acl input securityACL

exit

 

еще приутсвуют управляющий влан и абонента. Но мультикаст не идет. если конечно после него на длинке кто нить не включил канал тогда поток идет и в алкатель

Кто имел опыт помогите в настройке

Share this post


Link to post
Share on other sites

А почему general, а не access на абонентских портах?

Share this post


Link to post
Share on other sites

А почему general, а не access на абонентских портах?

 

interface range ethernet e(1-24)

switchport access multicast-tv vlan 50

exit

 

Access вроде

Share this post


Link to post
Share on other sites

Прошу прощения, неправильно прочитал конфиг. У меня конфиг похожий, только свич AT-8000/16. Вроде бы всё работает.

Share this post


Link to post
Share on other sites

Прошу прощения, неправильно прочитал конфиг. У меня конфиг похожий, только свич AT-8000/16. Вроде бы всё работает.

 

Думал что может как Edge-core пока пул адресов мультикаста не добавишь работать не начинает. а вот за ним длинки и ёжики работают четко. а вот алкаш не хочет отдавать приставке поток. Вот грешу что то не включил.

Share this post


Link to post
Share on other sites

Попробуй наоборот снупинг выключить

Share this post


Link to post
Share on other sites

Попробуй наоборот снупинг выключить

 

Пробовал не помогло. Конечно можно грешить который перед ним стоит. Но длинки и ёжики работают без проблем.

Share this post


Link to post
Share on other sites

Если не забуду вечером кину конфиг с рабочим igmp snooping для 6224

Share this post


Link to post
Share on other sites

Если не забуду вечером кину конфиг с рабочим igmp snooping для 6224

 

Буду очень благодарен)

Share this post


Link to post
Share on other sites

Команды, относящиеся к мультикасту выдам, мультикаст влан - 803 , а 303 влан - влан доступа

 

interface range ethernet e(1-24)

port storm-control broadcast enable

port storm-control broadcast rate 500

port storm-control include-multicast

exit

vlan database

vlan 803

exit

interface range ethernet e(1-24)

swi acc multicast-tv vlan 803

exit

interface range ethernet g(1-2)

swi trunk allowed vlan add 303,803

exit

interface vlan 803

name Ring1-Multicast

ip igmp snooping

exit

interface vlan 303

ip igmp snooping

exit

ip igmp snooping

ip igmp snooping multicast-tv vlan 803 add 230.1.1.0 count 256

 

interface range ethernet g(1-2)

no port storm-control include-multicast

exit

Share this post


Link to post
Share on other sites

ip igmp snooping

ip igmp snooping multicast-tv vlan 803 add 230.1.1.0 count 256

 

Вот этого я не делал раньше. Попробывал не заработало. Но толкьо если на выше стоящем DGS-3627 в IGMP Snooping Router Port Settings в влане мультикаста выставить порт который уходит на него и приходящие начинает работать. Но это же получается что на него все запросы идут. В цепочке он будет стоять после DES-3600-26 на нем все прекрастно работает. Задача балин.

Share this post


Link to post
Share on other sites

задай 3627 как querier, посмотри на нижестоящих по show igmp_snooping vlan xx, видит ли querier'a

Share this post


Link to post
Share on other sites

задай 3627 как querier, посмотри на нижестоящих по show igmp_snooping vlan xx, видит ли querier'a

 

Задал. Он потом же сразу изменил статус что не querier. Еще заметил что если после алкаша воткнул DES-3200-26 то все работает. Алкаш через себя пускает поток к длинку. и если шнур приставки переставить с длинка на алкаш то начинает показывать все по на длинке не кончится Expire Time потока. На алкаше тоже перестает вещаться этот поток. Есть подозрение что запросы алкаш режет где то.

 

DES-3200-26:5#show igmp_snooping vlan iptv

Command: show igmp_snooping vlan iptv

 

IGMP Snooping Global State : Enabled

Multicast Router Only : Disabled

Data Driven Learning Max Entries : 256

 

VLAN Name : iptv

Query Interval : 125

Max Response Time : 10

Robustness Value : 2

Last Member Query Interval : 1

Querier State : Disabled

Querier Role : Non-Querier

Querier IP : 10.255.255.25

Querier Expiry Time : 1 secs

State : Enabled

Fast Leave : Enabled

Report Suppression : Disabled

Version : 2

Data Driven Learning Aged Out : Disabled

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this