Jump to content
Калькуляторы

Из одного роутера два!) Что ниб из простого.

Помогите решит тему которую пытаюсь уже пару недель решить сам и все без успеха) Роутер RB750. Подключен к двум провайдерам, у одного авторизация ipoe у второго рррое. Хочу что бы мой микротик выполнял функцию двух роутеров, 1eth wan1 порт для ipoe, 2eth wan2 порт для pppoe,3eth dhcp 10.0.0.1 смотрит на wan2, 4eth dhcp 192.168.1.1 смотрит на wan1. У меня получилось что dhcp смотрят куда надо и интернет идет, ну только когда включен add default route 1 на wan любом, а у кого 2 то нету интернета. меняю местами появляется у кого 1 стоит, если отключить на обеих wan add default route, то интернет вообще пропадает. Если поставить одинаковую цифру, то интернет будет работать тот который второй подключился по счету. Помогите с простой настройкой плиз. Темы про маркировки манджл и пакетов уже читал. реально темный лес, я думаю есть проще варианты так как уже близок к этому и почти работает, хотя может и ошибаюсь)))

Share this post


Link to post
Share on other sites

Saab95, знаю ты уважаешь микротик. Помоги плиз, только не предлагай купить второй)))

Edited by dronis3

Share this post


Link to post
Share on other sites

У меня через маркировку настроено. Вот неплохая статья:

 

ТУТ

Share this post


Link to post
Share on other sites

Saab95, знаю ты уважаешь микротик. Помоги плиз, только не предлагай купить второй)))

 

Лучше всего еще 2 микротика купить, но есть вот такой простой конфиг, вам в нем надо удалить одного DHCP клиента, т.к. вместо него будет PPPoE, в роутах в самом низу указываете шлюз выданный по PPPoE, и по DHCP от операторов, в настройках PPPoE и DHCP снимаете галочки получения дефолтного рута и все у вас заработает. Половина абонентов пойдет через один канал, половина через второй.

 

/interface bridge
add name=bridge1
/ip pool
add name=dhcp_pool1 ranges=192.168.0.2-192.168.0.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=bridge1 name=dhcp1
/interface bridge port
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=ether6
add bridge=bridge1 interface=ether7
add bridge=bridge1 interface=ether8
add bridge=bridge1 interface=ether9
add bridge=bridge1 interface=ether10
/ip address
add address=192.168.0.1/24 interface=bridge1 network=192.168.0.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether1
add dhcp-options=hostname,clientid disabled=no interface=ether2
/ip dhcp-server network
add address=192.168.0.0/24 dns-server=192.168.0.1 gateway=192.168.0.1
/ip dns
set allow-remote-requests=yes
/ip firewall mangle
add action=add-src-to-address-list address-list=ISP1 chain=prerouting per-connection-classifier=src-address:2/1 src-address=192.168.0.0/24
add action=add-src-to-address-list address-list=ISP2 chain=prerouting per-connection-classifier=src-address:2/0 src-address=192.168.0.0/24
add action=mark-routing chain=prerouting dst-address=!192.168.0.0/16 new-routing-mark=to_ISP1 passthrough=no src-address-list=ISP1
add action=mark-routing chain=prerouting dst-address=!192.168.0.0/16 new-routing-mark=to_ISP2 passthrough=no src-address-list=ISP2
/ip firewall nat
add action=masquerade chain=srcnat src-address=192.168.0.0/24
/ip route
add check-gateway=ping distance=10 gateway=192.168.86.1 routing-mark=to_ISP1
add distance=100 gateway=192.168.85.1 routing-mark=to_ISP1
add check-gateway=ping distance=10 gateway=192.168.85.1 routing-mark=to_ISP2
add distance=100 gateway=192.168.86.1 routing-mark=to_ISP2

Share this post


Link to post
Share on other sites

Помогите решит тему которую пытаюсь уже пару недель решить сам и все без успеха) Роутер RB750. Подключен к двум провайдерам, у одного авторизация ipoe у второго рррое. Хочу что бы мой микротик выполнял функцию двух роутеров, 1eth wan1 порт для ipoe, 2eth wan2 порт для pppoe,3eth dhcp 10.0.0.1 смотрит на wan2, 4eth dhcp 192.168.1.1 смотрит на wan1. У меня получилось что dhcp смотрят куда надо и интернет идет, ну только когда включен add default route 1 на wan любом, а у кого 2 то нету интернета. меняю местами появляется у кого 1 стоит, если отключить на обеих wan add default route, то интернет вообще пропадает. Если поставить одинаковую цифру, то интернет будет работать тот который второй подключился по счету. Помогите с простой настройкой плиз. Темы про маркировки манджл и пакетов уже читал. реально темный лес, я думаю есть проще варианты так как уже близок к этому и почти работает, хотя может и ошибаюсь)))

1. маркируешь роутинг в канале прероутинг из LAN1 (mark routing name=route_operator1 chain=prerouting) затем в Ip/routes делаешь статический маршрут 0.0.0.0 на WAN1 и с указанием того самого промаркированного трафика mark_route name=route_operator1.

2. маркируешь роутинг в канале прероутинг из LAN2 (mark routing name=route_operator2 chain=prerouting) затем в Ip/routes делаешь статический маршрут 0.0.0.0 на WAN2 и с указанием второго промаркированного трафика route_operator2.

Всё.

PS Без понимания работы "мангала" (manlge) такие вещи самому настроить почти нереально. Только если угадать.

Для этого штурмовать эту страницу до полного понимания:

http://wiki.mikrotik.com/wiki/Manual:Packet_Flow

Edited by shader

Share this post


Link to post
Share on other sites

/ip firewall mangle add action=add-src-to-address-list address-list=first address-list-timeout=1d chain="mark new unseen" disabled=no nth=4,1

/ip firewall mangle add action=add-src-to-address-list address-list=second address-list-timeout=1d chain="mark new unseen" disabled=no nth=4,2

/ip firewall mangle add action=add-src-to-address-list address-list=third address-list-timeout=1d chain="mark new unseen" disabled=no nth=4,3

/ip firewall mangle add action=add-src-to-address-list address-list=fourth address-list-timeout=1d chain="mark new unseen" disabled=no nth=4,4

/ip firewall mangle add action=add-src-to-address-list address-list=seen address-list-timeout=1d chain="mark new unseen" disabled=no

/ip firewall mangle add action=jump chain="mark new unseen" disabled=no jump-target="mark connection"

 

 

/ip firewall mangle add action=mark-connection chain="mark connection" disabled=no new-connection-mark=first_conn passthrough=yes src-address-list=first

/ip firewall mangle add action=mark-connection chain="mark connection" disabled=no new-connection-mark=second_conn passthrough=yes src-address-list=second

/ip firewall mangle add action=mark-connection chain="mark connection" disabled=no new-connection-mark=third_conn passthrough=yes src-address-list=third

/ip firewall mangle add action=mark-connection chain="mark connection" disabled=no new-connection-mark=fourth_conn passthrough=yes src-address-list=fourth

 

/ip firewall mangle add action=mark-routing chain="mark connection" connection-mark=first_conn disabled=no new-routing-mark=first passthrough=no

/ip firewall mangle add action=mark-routing chain="mark connection" connection-mark=second_conn disabled=no new-routing-mark=second passthrough=no

/ip firewall mangle add action=mark-routing chain="mark connection" connection-mark=third_conn disabled=no new-routing-mark=third passthrough=no

/ip firewall mangle add action=mark-routing chain="mark connection" connection-mark=fourth_conn disabled=no new-routing-mark=fourth passthrough=no

 

 

/ip firewall mangle add action=mark-routing chain=prerouting connection-mark=first_conn disabled=no new-routing-mark=first passthrough=no src-address-list=first

/ip firewall mangle add action=mark-routing chain=prerouting connection-mark=second_conn disabled=no new-routing-mark=second passthrough=no src-address-list=second

/ip firewall mangle add action=mark-routing chain=prerouting connection-mark=third_conn disabled=no new-routing-mark=third passthrough=no src-address-list=third

/ip firewall mangle add action=mark-routing chain=prerouting connection-mark=fourth_conn disabled=no new-routing-mark=fourth passthrough=no src-address-list=fourth

 

/ip firewall mangle add action=jump chain=prerouting connection-state=new disabled=no jump-target="mark connection" src-address-list=local

/ip firewall mangle add action=jump chain=prerouting connection-state=new disabled=no jump-target="mark new unseen" src-address-list=local

 

 

осмысливайте )))

 

это у мя работало пару - тройку лет назад,

 

З.Ы. нюанс, обслуживает только адреса со списка local

Share this post


Link to post
Share on other sites

Вот почти без mangle, на ip rule: http://nixman.info/?p=133

это статическое закрепление за внешним интерфейсом, а у мя чуть чуть фантазии и довольно качественное динамическое распределение

Share this post


Link to post
Share on other sites

у мя чуть чуть фантазии и довольно качественное динамическое распределение

 

Тогда вам нужно использовать OSPF и три физических роутера, тогда вообще настройка сводится к паре кликов мышки.

Share this post


Link to post
Share on other sites

и три физических роутера,

а почему не 10?

 

До 10 еще дорасти надо=)

Share this post


Link to post
Share on other sites

Тогда вам нужно использовать OSPF и три физических роутера, тогда вообще настройка сводится к паре кликов мышки.

Больше микротиков богу микротиков!

 

это статическое закрепление за внешним интерфейсом, а у мя чуть чуть фантазии и довольно качественное динамическое распределение

Так а я ж не говорю, что мой вариант лучше. Он проще ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this