Jump to content
Калькуляторы

Разделение сети в одном комутаторе VLAN или Traffic Segmentation

Суть такова: имеем DGS-1210-28

1) Нужно с 1 по 4 включительно порты отделить от основного комутатора (1 порт кабель ISP1, 3-4 порты сервера)

2) Порты с 5 по 8 включительно также отделить от основного и от первой группы (5 порт кабель ISP2, 6-8 порты сервера)

Остальные порты локалка. Т.е. в идеале как бы внутри коммутатора должно получиться 3 независимых сети.

Пробовал делать 3 разных VLAN. Не получилось, в VLAN локалки все нормально, а вот в остальных двух бардак. А именно порт 1 кабель ISP1 - 2 порт сервер с белым IP. Пробую пингануть шлюз - не работает. Втыкаю кабель ISP1 напрямую в сервер - работает.

C Traffic Segmentation ситуация аналогичная.

Подскажите как поделить порты в этом чудо устройстве.?

Чуть не забыл. В VLAN все порты нетегерированные.

Edited by Niferman

Share this post


Link to post
Share on other sites

Вы наверное включили режим "private vlan" Отключите его и пробуйте снова VLAN

Share this post


Link to post
Share on other sites

Э... что то не найду такого пункта. Это в каком разделе не подскажете?

Share this post


Link to post
Share on other sites

config vlan default delete 1,5

config vlan vlan3333 tag 3333

config vlan vlan3333 add tag 2-4

config vlan vlan3333 add un 1

 

config vlan vlan2222 tag 2222

config vlan vlan2222 add tag 6-8

config vlan vlan2222 add un 5

Вы же в курсе, что коммутатор не сможет самостоятельно разрулить каналы провайдеров? Для этого надо как минимум маршрутизатор или свитч L3.

Схему вижу так: микротик-свитч-сервера

На микротике принимаем каналы провайдеров, разруливаем их по vlanам и vlanы распределяем свитчем по серверам

Share this post


Link to post
Share on other sites

Вы же в курсе, что коммутатор не сможет самостоятельно разрулить каналы провайдеров? Для этого надо как минимум маршрутизатор или свитч L3.

Схему вижу так: микротик-свитч-сервера

На микротике принимаем каналы провайдеров, разруливаем их по vlanам и vlanы распределяем свитчем по серверам

Тут вот можно подробнее?.... Т.е. простой хаб 5-ти портовый может разруливать канал прова, а железяка 2 уровня не в силах?

Т.е. мне банально от нее надо сделать что бы она выступала в роли 3-х независимых хабов.

По поводу схемы соединения у меня примерно так и будет. Только вот VLAN на Mikrotik поднимать не хотелось бы (есть на то свои причины)

Только что ради чистоты эксперимента проверил:

Вставляю кабель ISP1 в VLAN1 (тот что локалка) прописываю на компе внешний IP и вуаля. На компе есть инет.

Вот тут только вопрос, почему с VLAN2 такой фокус не проходит...

Edited by Niferman

Share this post


Link to post
Share on other sites

А что сложного?

Создаёте столько вланов сколько нужно групп портов.

Потом порты делате чтобы антагом были только в одном влане, для остальных вланов ставите нот мембер и всё.

У самого таких пара штук.

Share this post


Link to post
Share on other sites

Т.е. простой хаб 5-ти портовый может разруливать канал прова

Поменьше фантазий.

Ничего простой хаб разрулить не может.

Share this post


Link to post
Share on other sites

Вот в том то и проблема.

По дефолту в VLAN1 входят все порты нетагерированные. VLAN Name - default, VID - 1

Создал еще 2 VLAN

port untagged 5-8, VLAN Name - MTS, VID - 6

port untagged 1-4, VLAN Name - UgLink, VID - 5

 

Так вот в VLAN1 - втыкаю кабель ISP и комп (на компе внешний IP). Все работает.

В VLAN2 и 3 не работает.

Может в прошивке беда?

 

Ничего простой хаб разрулить не может.

Мне разруливать и не надо. Нужно разделить сети и все.

 

у меня счас так

post-124086-084373100 1430988434_thumb.jpg

Edited by Niferman

Share this post


Link to post
Share on other sites

1 - ISP MTS

2-4 - сервера с внешними IP

5 - ISP UgLink

6-8 - сервера с внешними IP

9-28 - локальная сеть

Share this post


Link to post
Share on other sites

короче человеку нужно:

vlan iD 5

port 1-4

ISP MTS + сервера (группа 1) с IP

 

vlan iD 6

port 5-8

ISP UgLink + сервера (группа 2) с IP

 

vlan1 остальная локалка.

 

нужно смотреть остальные конфиги порта (железки) и логи, по скрину все правильно настроено

если все ок. смотреть в сторону прошивки (может есть свежая)

Share this post


Link to post
Share on other sites

наверняка кривые PVID на портах, которые в смартах надо ручками изменять.

Share this post


Link to post
Share on other sites

Мануал бы челу прочитать, там вроде с картинками, страницы 2-5, не больше.

Share this post


Link to post
Share on other sites

Да человек с default vlan 1 по граблям ходит...

Share this post


Link to post
Share on other sites

про PVID в курсе. менял ручками. там получилось так порты 1-4(PVID 5), порты 5-8(PVID 6), порты 9-28(PVID 1)

Да человек с default vlan 1 по граблям ходит

не совсем понял... в чем у них грабли?

Edited by Niferman

Share this post


Link to post
Share on other sites

Не знаю что за трабл был, выключил по питанию железку на пару минут и включил. Все завелось...

Всем спасибо.

Share this post


Link to post
Share on other sites

про PVID в курсе. менял ручками. там получилось так порты 1-4(PVID 5), порты 5-8(PVID 6), порты 9-28(PVID 1)

Да человек с default vlan 1 по граблям ходит

не совсем понял... в чем у них грабли?

Поведение default vlan 1 у длинка непредсказуемо. Равно как и native vlan и private vlan. В моей голове не уместилось, поэтому рулю vlan-ами по цисковски, и никогда не оставляю vlan 1 в конфигах.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this