Jump to content
Калькуляторы

микротик + вланы в бридже на одном порту

схема:

тик, на ether1 создано 2 влана с разными id (989 и 1989), засунуты в bridge1, на бридж повешен адрес 192.168.0.1/24

влан 989 вытащен на другой железке и повешен адрес 192.168.0.2/24, влан 1989 вытащен на третьей железке и повешен адрес 192.168.0.3/24

 

результат: с тика 192.168.0.1 пинг есть и на 0.2 и на 0.3

задача сделать транзит с 0.2 на 0.3 через тик чтобы зашейпить канал, но пакеты не ходят (unreacheble)

 

пробовал создал модель "на столе" из тиков, аналогично

 

wtf?

Share this post


Link to post
Share on other sites

что значит вланы засунуты в бридж? вы сбриджевали два влана?

Что кроме вланов находится в бридже?

Share this post


Link to post
Share on other sites

что значит вланы засунуты в бридж? вы сбриджевали два влана?

Что кроме вланов находится в бридже?

да, оба влана в бридже

в бридже только они

Share this post


Link to post
Share on other sites

Галочка в настройках бриджа Use IP Firewall стоит? Попробуйте убрать ее.

 

схема:

тик, на ether1 создано 2 влана с разными id (989 и 1989), засунуты в bridge1, на бридж повешен адрес 192.168.0.1/24

влан 989 вытащен на другой железке и повешен адрес 192.168.0.2/24, влан 1989 вытащен на третьей железке и повешен адрес 192.168.0.3/24

 

результат: с тика 192.168.0.1 пинг есть и на 0.2 и на 0.3

задача сделать транзит с 0.2 на 0.3 через тик чтобы зашейпить канал, но пакеты не ходят (unreacheble)

 

Другой вариант решения задачи:

1. Уберите бридж.

2. На влан 989 повесьте адрес=192.168.0.1 нетворк=192.168.0.2

3. На влан 1989 повесьте адрес=192.168.0.1 нетворк=192.168.0.3

4. На обоих вланах включите proxy-arp.

Share this post


Link to post
Share on other sites

схема:

тик, на ether1 создано 2 влана с разными id (989 и 1989), засунуты в bridge1, на бридж повешен адрес 192.168.0.1/24

влан 989 вытащен на другой железке и повешен адрес 192.168.0.2/24, влан 1989 вытащен на третьей железке и повешен адрес 192.168.0.3/24

 

результат: с тика 192.168.0.1 пинг есть и на 0.2 и на 0.3

задача сделать транзит с 0.2 на 0.3 через тик чтобы зашейпить канал, но пакеты не ходят (unreacheble)

 

пробовал создал модель "на столе" из тиков, аналогично

 

wtf?

 

Дай экспорт компакт.

У меня такая схема нормально работает.

 

# 
/interface bridge
add mtu=1500 name=bridge2214_2207 protocol-mode=none
/interface ethernet
set [ find default-name=ether1 ] comment=TRUNK_MEGAFON
/interface vlan
add comment=TO_GREMYACHI interface=ether1 l2mtu=1584 name=vlan2207 vlan-id=2207
add comment=TO_PRIVPO interface=ether1 l2mtu=1584 name=vlan2214 vlan-id=2214
/interface bridge port
add bridge=bridge2214_2207 interface=vlan2207
add bridge=bridge2214_2207 interface=vlan2214
/ip address
add address=10.18.4.4/29 interface=vlan2214 network=10.18.4.0
/ip route
add distance=1 gateway=10.18.4.1

 

IP только у меня на VLANе, а не на бридже.

Share this post


Link to post
Share on other sites

схема:

тик, на ether1 создано 2 влана с разными id ...

тик, случайно, не в виртуальной машине?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this