Jump to content
Калькуляторы

Загрузка процессора Mikrotik CCR1036-8G-2S+ 80%-100% Загрузка процессора Mikrotik CCR1036-8G-2S+

Столкнулся со следующей бедой mikrotik постоянно загружен на 80%-100% и за шейпера.

Шейпер сделан по прицепу маркировки соединений и пакетов, на данном микротике работает примерно 1000 абонентов, тарифы у них 5, 8, 10, 20, 25, 30, 50, 80, 100 мегабит.

Входящий канал сейчас более 1 гигабита - загрузка процессора подскакивает до 100% как при 600 мегабит так и при 900 мегабитах.

Делал такой эксперимент, если загрузка держится 100% или около того, я отключаю маркировку пакетов для 50 мегабитного тарифа и загрузка падает до 20-30%.

В mangle пробовал различные схемы менял Forward, postrouting, prerouting – результат нулевой загрузка держится.

Также изначально маркировал только пакеты, сейчас добавил, что маркируются с начало соединения, а потом пакеты, тоже не помогло.

Помогите разобраться, почему такая большая загрузка процессора, или может быть микротик на большее не способен, и надо ставить что-то другое, но вроде 36 ядре каждое 1,2 гигагерца.

 

В конфиге ниже могут быть небольшие не соответствия, такие как Forward, postrouting, prerouting поменяны местами это я уже пробовал метод научного тыка, и он не сработал

 

Забыл, прошивка 6.27 и вышла уже 6.28 еще не пробовал, но дмаю не поможет.

 

Возможно надо все переписать моя задача просто резать скорость абонам и все.

 

 

 

Конфиги микротика:

 

/ip firewall mangle
add action=mark-routing chain=prerouting new-routing-mark=w_ip passthrough=no src-address-list=w_ip
add action=mark-connection chain=postrouting comment=5M-connection-up connection-state=new new-connection-mark=5M-connection-up src-address-list=5M
add action=mark-packet chain=forward comment=5M_down connection-mark=5M-connection-down new-packet-mark=mark_5M_down passthrough=no
add action=mark-connection chain=forward comment=5M-connection-down connection-state=new dst-address-list=5M new-connection-mark=5M-connection-down
add action=mark-packet chain=postrouting comment=5M_up connection-mark=5M-connection-up new-packet-mark=mark_5M_up passthrough=no
add action=mark-connection chain=forward comment=8M-connection-up connection-state=new new-connection-mark=8M-connection-up src-address-list=8M
add action=mark-packet chain=forward comment=8M_up connection-mark=8M-connection-up new-packet-mark=mark_8M_up passthrough=no
add action=mark-connection chain=forward comment=8M-connection-down connection-state=new dst-address-list=8M new-connection-mark=8M-connection-down
add action=mark-packet chain=forward comment=15M_down connection-mark=15M-connection-down new-packet-mark=mark_15M_down passthrough=no
add action=mark-packet chain=forward comment=8M_down connection-mark=8M-connection-down new-packet-mark=mark_8M_down passthrough=no
add action=mark-connection chain=forward comment=10M-connection-up connection-state=new new-connection-mark=10M-connection-up src-address-list=10M
add action=mark-packet chain=forward comment=10M_up connection-mark=10M-connection-up new-packet-mark=mark_10M_up passthrough=no
add action=mark-connection chain=forward comment=10M-connection-down connection-state=new dst-address-list=10M new-connection-mark=10M-connection-down
add action=mark-packet chain=forward comment=10M_down connection-mark=10M-connection-down new-packet-mark=mark_10M_down passthrough=no
add action=mark-connection chain=forward comment=15M-connection-up connection-state=new new-connection-mark=15M-connection-up src-address-list=15M
add action=mark-packet chain=forward comment=15M_up connection-mark=15M-connection-up new-packet-mark=mark_15M_up passthrough=no
add action=mark-connection chain=forward comment=15M-connection-down connection-state=new dst-address-list=15M new-connection-mark=15M-connection-down
add action=mark-connection chain=prerouting comment=20M-connection-up connection-state=new new-connection-mark=20M-connection-up src-address-list=20M
add action=mark-packet chain=prerouting comment=20M_up connection-mark=20M-connection-up new-packet-mark=mark_20M_up passthrough=no
add action=mark-connection chain=prerouting comment=20M-connection-down connection-state=new dst-address-list=20M new-connection-mark=20M-connection-down
add action=mark-packet chain=prerouting comment=20M_down connection-mark=20M-connection-down new-packet-mark=mark_20M_down passthrough=no
add action=mark-connection chain=prerouting comment=25M-connection-up connection-state=new new-connection-mark=25M-connection-up passthrough=no    src-address-list=25M
add action=mark-packet chain=prerouting comment=25M_up connection-mark=25M-connection-up new-packet-mark=mark_25M_up passthrough=no
add action=mark-connection chain=prerouting comment=25M-connection-down connection-state=new dst-address-list=25M new-connection-mark=25M-connection-down    passthrough=no
add action=mark-packet chain=prerouting comment=25M_down connection-mark=25M-connection-down new-packet-mark=mark_25M_down passthrough=no
add action=mark-connection chain=prerouting comment=30M-connection-up connection-state=new new-connection-mark=30M-connection-up passthrough=no    src-address-list=30M
add action=mark-packet chain=prerouting comment=30M_up connection-mark=30M-connection-up new-packet-mark=mark_30M_up passthrough=no
add action=mark-connection chain=prerouting comment=30M-connection-down connection-state=new dst-address-list=30M new-connection-mark=30M-connection-down   passthrough=no
add action=mark-packet chain=prerouting comment=30M_down connection-mark=30M-connection-down new-packet-mark=mark_30M_down passthrough=no
add action=mark-connection chain=prerouting comment=50M-connection-up new-connection-mark=50M-connection-up src-address-list=50M
add action=mark-packet chain=prerouting comment=50M_up connection-mark=50M-connection-up new-packet-mark=mark_50M_up passthrough=no
add action=mark-connection chain=prerouting comment=50M-connection-down dst-address-list=50M new-connection-mark=50M-connection-down
add action=mark-packet chain=prerouting comment=50M_down connection-mark=50M-connection-down new-packet-mark=mark_50M_down passthrough=no
add action=mark-connection chain=forward comment=80M-connection-up connection-state=new new-connection-mark=80M-connection-up src-address-list=80M
add action=mark-packet chain=forward comment=80M_up connection-mark=80M-connection-up new-packet-mark=mark_80M_up passthrough=no
add action=mark-connection chain=forward comment=80M-connection-down connection-state=new dst-address-list=80M new-connection-mark=80M-connection-down
add action=mark-packet chain=forward comment=80M_down connection-mark=80M-connection-down new-packet-mark=mark_80M_down passthrough=no
add action=mark-connection chain=forward comment=100M-connection-up connection-state=new new-connection-mark=100M-connection-up src-address-list=100M
add action=mark-packet chain=forward comment=100M_up connection-mark=100M-connection-up new-packet-mark=mark_100M_up passthrough=no
add action=mark-connection chain=forward comment=100M-connection-down connection-state=new dst-address-list=100M new-connection-mark=100M-connection-down
add action=mark-packet chain=forward comment=100M_down connection-mark=100M-connection-down new-packet-mark=mark_100M_down passthrough=no

 

/queue type
set 0 kind=pcq
add kind=pcq name=pcq_5M_down pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=5M pcq-src-address6-mask=64 pcq-total-limit=900k
add kind=pcq name=pcq_5M_up pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=5M pcq-src-address6-mask=64 pcq-total-limit=900k
add kind=pcq name=pcq_10M_down pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-limit=10k pcq-rate=10M pcq-src-address6-mask=64 pcq-total-limit=900k
add kind=pcq name=pcq_10M_up pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-limit=10k pcq-rate=10M pcq-src-address6-mask=64 pcq-total-limit=900k
add kind=pcq name=pcq_15M_down pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-limit=10k pcq-rate=15M pcq-src-address6-mask=64 pcq-total-limit=900k
add kind=pcq name=pcq_15M_up pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-limit=10k pcq-rate=15M pcq-src-address6-mask=64 pcq-total-limit=900k
add kind=pcq name=pcq_30M_down pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-limit=10k pcq-rate=30M pcq-src-address6-mask=64 pcq-total-limit=900k
add kind=pcq name=pcq_30M_up pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-limit=10k pcq-rate=30M pcq-src-address6-mask=64 pcq-total-limit=900k
add kind=pcq name=pcq_20M_down pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=20M pcq-src-address6-mask=64 pcq-total-limit=90k
add kind=pcq name=pcq_20M_up pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=20M pcq-src-address6-mask=64 pcq-total-limit=90k
add kind=pcq name=pcq_50M_down pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-limit=5k pcq-rate=50M pcq-src-address6-mask=64 pcq-total-limit=900k
add kind=pcq name=pcq_50M_up pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-limit=5k pcq-rate=50M pcq-src-address6-mask=64 pcq-total-limit=900k
add kind=pcq name=pcq_80M_down pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-limit=5k pcq-rate=80M pcq-src-address6-mask=64 pcq-total-limit=100k
add kind=pcq name=pcq_80M_up pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-limit=5k pcq-rate=80M pcq-src-address6-mask=64 pcq-total-limit=100k
add kind=pcq name=pcq_100M_down pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-limit=5k pcq-rate=100M pcq-src-address6-mask=64 pcq-total-limit=300k
add kind=pcq name=pcq_100M_up pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-limit=5k pcq-rate=80M pcq-src-address6-mask=64 pcq-total-limit=512k
add kind=pcq name=pcq_40M_down pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-limit=10k pcq-rate=40M pcq-src-address6-mask=64 pcq-total-limit=900k
add kind=pcq name=pcq_40M_up pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-limit=10k pcq-rate=40M pcq-src-address6-mask=64 pcq-total-limit=900k
add kind=pcq name=pcq_8M_up pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-limit=10k pcq-rate=8M pcq-src-address6-mask=64 pcq-total-limit=900k
add kind=pcq name=pcq_8M_down pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-limit=10k pcq-rate=8M pcq-src-address6-mask=64 pcq-total-limit=900k
add kind=pcq name=pcq_25M_down pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=25M pcq-src-address6-mask=64 pcq-total-limit=64k
add kind=pcq name=pcq_25M_up pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-limit=10k pcq-rate=25M pcq-src-address6-mask=64 pcq-total-limit=900k

 

/queue tree
add name=Total_download parent=global priority=1 queue=pcq-download-default
add name=Total_upload parent=global priority=1 queue=pcq-upload-default
add name=queue_5M_down packet-mark=mark_5M_down parent=Total_download priority=2 queue=pcq_5M_down
add name=queue_5M_up packet-mark=mark_5M_up parent=Total_upload priority=2 queue=pcq_5M_up
add name=queue_10M_down packet-mark=mark_10M_down parent=Total_download priority=3 queue=pcq_10M_down
add name=queue_15M_down packet-mark=mark_15M_down parent=Total_download priority=4 queue=pcq_15M_down
add name=queue_30M_down packet-mark=mark_30M_down parent=Total_download priority=6 queue=pcq_30M_down
add name=queue_10M_up packet-mark=mark_10M_up parent=Total_upload priority=3 queue=pcq_10M_up
add name=queue_15M_up packet-mark=mark_15M_up parent=Total_upload priority=4 queue=pcq_15M_up
add name=queue_30M_up packet-mark=mark_30M_up parent=Total_upload priority=6 queue=pcq_30M_up
add name=queue_20M_down packet-mark=mark_20M_down parent=Total_download priority=5 queue=pcq_20M_down
add name=queue_20M_up packet-mark=mark_20M_up parent=Total_upload priority=5 queue=pcq_20M_up
add name=queue_50M_down packet-mark=mark_50M_down parent=Total_download priority=7 queue=pcq_50M_down
add name=queue_80M_down packet-mark=mark_80M_down parent=Total_download queue=pcq_80M_down
add name=queue_100M_down packet-mark=mark_100M_down parent=Total_download queue=pcq_100M_down
add name=queue_50M_up packet-mark=mark_50M_up parent=Total_upload priority=7 queue=pcq_50M_up
add name=queue_80M_up packet-mark=mark_80M_up parent=Total_upload queue=pcq_80M_up
add name=queue_100M_up packet-mark=mark_100M_up parent=Total_upload queue=pcq_100M_up
add name=queue_25M_down packet-mark=mark_25M_down parent=Total_download priority=5 queue=pcq_25M_down
add name=queue_8M_down packet-mark=mark_8M_down parent=Total_download priority=2 queue=pcq_25M_down
add name=queue_8M_up packet-mark=mark_8M_up parent=Total_upload priority=2 queue=pcq_8M_up
add name=queue_25M_up packet-mark=mark_25M_up parent=Total_upload priority=2 queue=pcq_25M_up

Edited by mr.pegas2010

Share this post


Link to post
Share on other sites

пробуйте simple queue

а ещё лучше на что-то мигрировать....

Edited by GrandPr1de

Share this post


Link to post
Share on other sites

от simple queue отказался когда перевалило за 100 абонентов, оно читает по порядку все и начинаются проблемы свыше 100 правил

Share this post


Link to post
Share on other sites

Тут дело не совсем в процессоре, а в том, что нужно ветвление для шейпера. Имхо оно не рассчитано шейпить тучу пользователей.

Хотя фаны микротика могут переубедить. Возможно появится такой индивидуум как Saab95 и предложит вас поставить десяток CCR :)

Я бы мог посоветовать accel-ppp + Linux, но т.к. есть микротик - лучше подождать, что гуру форума скажут.

Share this post


Link to post
Share on other sites

ну кхм, что-то типо такого работает нормально

 0   ;;; 2m
    chain=forward action=mark-connection new-connection-mark=2m-conn 
    passthrough=yes src-address-list=2m-down_1m-up 

1   chain=forward action=mark-packet new-packet-mark=2m-traff passthrough=no 
    connection-mark=2m-conn 

 

Share this post


Link to post
Share on other sites

от simple queue отказался когда перевалило за 100 абонентов, оно читает по порядку все и начинаются проблемы свыше 100 правил

 

Там, вроде, хэш впилили с какой то версии - попробуйте еще разок.

Share this post


Link to post
Share on other sites

Резюмируем, когда тут спрашивают "чего ставить" - местные религиозные апологеты Микротика и продавцы костьми лягут, и посоветуют Микротик, типа дешево и делает чудеса.

А когда пользующемуся этот микротик долбанет со всего размаху граблями, причем проблема-то простейшая, максимум, на что апологеты способны - сделать скриншоты, и сказать, что у них - всё ОК :-P

Сравните с админами FreeBSD, Linux - где советами просто закидывают в первый же день, тем более на такие банальные вопросы. Делайте выводы.

Share this post


Link to post
Share on other sites

если использовать только маркировку пакетов и не использовать нат то можно попробовать отключить connection tracking + посмотреть через /tool profile что именно жрёт проц

Edited by Alexspils

Share this post


Link to post
Share on other sites

от simple queue отказался когда перевалило за 100 абонентов, оно читает по порядку все и начинаются проблемы свыше 100 правил

 

Может в 5 версии так и было, 6 лишена этого недостатка. Сейчас у вас нагрузка высокая из-за кучи маркировок, каких-то не нужных деревьев и т.п. Перейдите снова на простые очереди и все проблемы уйдут.

Share this post


Link to post
Share on other sites

Перешел на simple queue, нагрузка упала,

добавил на микротик еще 400 абонентов, сейчас на нем более 1400 абонентов, прокачивает трафика больше 900 мегабита, при этом загрузка всего 24% в час пик.

 

Большое все спасибо за помощь, рекомендую всем у кого схожая проблема, убирать деревья и переходить на simple queue.

Share this post


Link to post
Share on other sites

Перешел на simple queue, нагрузка упала,

добавил на микротик еще 400 абонентов, сейчас на нем более 1400 абонентов, прокачивает трафика больше 900 мегабита, при этом загрузка всего 24% в час пик.

 

Большое все спасибо за помощь, рекомендую всем у кого схожая проблема, убирать деревья и переходить на simple queue.

 

 

 

у меня схожая проблема, но на x86 и микротике 5.26

 

Видимо придётся CCR брать

Share this post


Link to post
Share on other sites

у меня схожая проблема, но на x86 и микротике 5.26

 

Видимо придётся CCR брать

CCR загнется гораздо раньше х86.

Share this post


Link to post
Share on other sites

CCR загнется гораздо раньше х86.

 

ну х86 уже загнулась. А на CCR говорят 1+ гбит с шейпером молотит

Share this post


Link to post
Share on other sites

Вы не путайте, загнулась ворованная недоОС, а не железо. С таки обичным линуксом, даже без тюнинга, простой тазик гиг промолачивает.

Share this post


Link to post
Share on other sites

Вы не путайте, загнулась ворованная недоОС, а не железо. С таки обичным линуксом, даже без тюнинга, простой тазик гиг промолачивает.

 

без шейпера оно пропускает сейчас гиг. С шейпером косяки какие-то, максимум 650-700. И в этот момент ядра 35-47%

Share this post


Link to post
Share on other sites

Вы не путайте, загнулась ворованная недоОС, а не железо. С таки обичным линуксом, даже без тюнинга, простой тазик гиг промолачивает.

 

без шейпера оно пропускает сейчас гиг. С шейпером косяки какие-то, максимум 650-700. И в этот момент ядра 35-47%

Шейпер на хэшах или фильтры линейные? Или речь о RouterOS?

Share this post


Link to post
Share on other sites

Шейпер на хэшах или фильтры линейные? Или речь о RouterOS?

 

RouterOS x86 5.26

 

шейпер PCQ деревом. Нарезка входа и выхода без приоритетов.

Share this post


Link to post
Share on other sites

А на CCR говорят 1+ гбит с шейпером молотит

Молотить-то молотит. Только лучше бы не молотил. 1200 пользователей, шейпер, трафику в пике 800-900 мегабит. Потери пакетов, низкая скорость, высокие пинги, вот это вот всё.

Share this post


Link to post
Share on other sites

Реально бесит слушать всякий калл о микротике от косоруких дегенератов, купи попользуйся потом гони всякую хрень, настрой нормально и не гундось,а то только и читаю то не работает это не работает и гонят всякую хрень, купил второй микротик у меня все работает!!!

post-116027-092140200 1430162818_thumb.jpg

Edited by Silence

Share this post


Link to post
Share on other sites

Нужно обязательно ставить шестую ветку ROS на 5.26 ловить нечего уже очень давно. Думаю при 1000 абонентов можно ж позволить 1600рублей. Simple queue в 6 ветке прошейпит 1500 клиентов.

Share this post


Link to post
Share on other sites

Silence, чего сказать-то хотели этим сообщением?

post-124527-009698400 1430196370_thumb.png

Edited by hpswgprk

Share this post


Link to post
Share on other sites

купи попользуйся потом гони всякую хрень

Купил, пользуюсь, можно хрень нести ?

Silence что хотели скрином с 284 pppoe сесиями сказать ?

Share this post


Link to post
Share on other sites

купи попользуйся потом гони всякую хрень

Купил, пользуюсь, можно хрень нести ?

Silence что хотели скрином с 284 pppoe сесиями сказать ?

все работает ничего не глючит проблем нету

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this