Jump to content
Калькуляторы

Port-channel не распределяет тарффик (c3560e) load-balance менял, не помогает

Доброго дня!

Пытаемся зеркалировать трафик в port-channel (На cisco 6500 все отлично работало).

Но на cisco-3560e трафик валит только в первый порт! Такая же ситуация на обычном LACP Port-channel и на тысячной абонентской сети и на стенде. Всю голову сломал. Пробовал все алгоритмы балансировки.

Отключаю один из портов, трафик идет через следующий в группе порт.

Софт менял, такая же ситуация и на 12 и 15 ветках. Был бы признателен за любую помощь.

Конфигурация такая:

 

vlan 801
remote-span
!
port-channel load-balance src-dst-ip
!
interface GigabitEthernet0/21-24
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 801
switchport mode trunk
switchport nonegotiate
channel-group 10 mode on
end
!
interface Port-channel10
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 801
switchport mode trunk
switchport nonegotiate
end
!
monitor session 10 source interface Te0/2
monitor session 10 destination remote vlan 801 
!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
3560#show etherchannel summary 
Flags:  D - down        P - bundled in port-channel
       I - stand-alone s - suspended
       H - Hot-standby (LACP only)
       R - Layer3      S - Layer2
       U - in use      f - failed to allocate aggregator

       M - not in use, minimum links not met
       u - unsuitable for bundling
       w - waiting to be aggregated
       d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
10     Po10(SU)         -        Gi0/21(P)   Gi0/22(P)   Gi0/23(P)   
                                Gi0/24(P) 
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
3560#show monitor session 10
Session 10
----------
Type                   : Remote Source Session
Source Ports           : 
   Both               : Te0/2
Dest RSPAN VLAN        : 801

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
3560#sh vlan id 801

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
801  VLAN0801                         active    Po10

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
801  enet  100801     1500  -      -      -        -    -        0      0   

Remote SPAN VLAN
----------------
Enabled
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

 

sh ver

 

3560#sh ver
Cisco IOS Software, C3560E Software (C3560E-UNIVERSALK9-M), Version 12.2(58)SE2, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2011 by Cisco Systems, Inc.
Compiled Thu 21-Jul-11 01:34 by prod_rel_team

ROM: Bootstrap program is C3560E boot loader
BOOTLDR: C3560E Boot Loader (C3560E-HBOOT-M) Version 12.2(44r)SE3, RELEASE SOFTWARE (fc3)

3560-GUS uptime is 47 minutes
System returned to ROM by power-on
System image file is "flash:c3560e-universalk9-mz.122-58.SE2.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

License Level: ipservices
License Type: Evaluation
Next reload license Level: ipservices

cisco WS-C3560E-24TD (PowerPC405) processor (revision G0) with 131072K bytes of memory.
Processor board ID FDO1332R0FW
Last reset from power-on
198 Virtual Ethernet interfaces
1 FastEthernet interface
28 Gigabit Ethernet interfaces
2 Ten Gigabit Ethernet interfaces
The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address       : 00:26:CB:5A:70:00
Model revision number           : G0
Motherboard revision number     : A0
Model number                    : WS-C3560E-24TD-S
Hardware Board Revision Number  : 0x00


Switch Ports Model              SW Version            SW Image                 
------ ----- -----              ----------            ----------               
*    1 30    WS-C3560E-24TD     12.2(58)SE2           C3560E-UNIVERSALK9-M     


Configuration register is 0xF

 

Edited by xpertiza

Share this post


Link to post
Share on other sites

Обычный браузинг и тп. Трафик был и от ~1000 абонентов, т.е. гарантированно разные src-dst-ip и на стенде трафик хоть и небольшой, но также разные адреса и маки. Вплоть до того, что на трех портах группы буквально rate 0/0, а на одном суммарный трафик.

Edited by xpertiza

Share this post


Link to post
Share on other sites

Покажи конфиг. У меня отлично баланситься на WS-C3560X-24, c3560e-universalk9-mz.150-2.SE2

Share this post


Link to post
Share on other sites

Покажи конфиг.

Весь конфиг по делу в первом посте. Остальное - куча SVI, unnumbered. Ничего особенного. Спасибо, попробую эту версию (пробовал только SE7)

Edited by xpertiza

Share this post


Link to post
Share on other sites

Весь конфиг по делу в первом посте.

 

Сори был невнимателен. У меня так же, только отдельно указан native vlan, но это сути не меняет.

Пробуй ещё на портах channel-group xxx mode active и пересобрать.

 

пробовать Channel-protocol lacp / pagp

 

Что с другой стороны, такой же свитч?

Share this post


Link to post
Share on other sites

Сори был невнимателен. У меня так же, только отдельно указан native vlan, но это сути не меняет.

Пробуй ещё на портах channel-group xxx mode active и пересобрать.

 

Что с другой стороны, такой же свитч?

С другой стороны должен быть СОРМ, но сейчас просто SNR с port-group, mode on, для теста. Пробовал LACP 3560e<-->ASR1002, и там и там active, тоже в один порт льется все. Качаю софт, отпишусь

Share this post


Link to post
Share on other sites

С другой стороны должен быть СОРМ, но сейчас просто SNR

 

Не могу проверить, у меня между цисками и парой циска/брокада работает без проблем, других вендоров не связывал.

Share this post


Link to post
Share on other sites

Не помогла смена софта=( Стоит на агрегации такая же циска 3560e и смотрит в СОРМ (порты gi0/1-4):

 

3560#sh int gi0/1 | i rate
 Queueing strategy: fifo
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 982290000 bits/sec, 111497 packets/sec <--------- Весь трафик здесь
3560#sh int gi0/2 | i rate
 Queueing strategy: fifo
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
3560#sh int gi0/3 | i rate
 Queueing strategy: fifo
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
3560#sh int gi0/4 | i rate
 Queueing strategy: fifo
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec

3560#show etherchannel load-balance 
EtherChannel Load-Balancing Configuration:
       src-dst-ip

EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Source XOR Destination MAC address
 IPv4: Source XOR Destination IP address
 IPv6: Source XOR Destination IP address

 

А там суммарно должно получаться около трех гигов.

Edited by xpertiza

Share this post


Link to post
Share on other sites

Странно.

Попробовать явно задать вручную

 

первый

channel-protocol lacp

channel-group 10 mode active

 

второй

channel-protocol lacp

channel-group 10 mode passive

 

И не забывать пересобирать.

Пробовать различные способы балансировки http://www.edgenetworks.nl/etherchannel.html

 

В крайнем случае (но попробовать стОит) - перевести порты в mode access

Share this post


Link to post
Share on other sites

Пересобрал с нуля с Mode active, на другой стороне сорм и вот по портам (подождал минут 5, не моментально): 930 900 900 900 мбит! выравнивается. Спасибо! Не понимаю почему сразу не сработало, все переделывал не раз, хотя.. channel-protocol не указывал, а сейчас указал. Где-то в доках читал что channel-protocol только убирает конфиг pagp, но на функционал не влияет.

 

Стоп. чет дофига трафа, у меня всего в сумме 3 должно быть. Все порты I - stand-alone, получается один и тот же траф льется в каждый из четырех портов.

Edited by xpertiza

Share this post


Link to post
Share on other sites

Судя по всему, придется вам хоронить идею на 3750.

 

Странно, но между брокадой и C3560X отлично баланситься.

Share this post


Link to post
Share on other sites

А кто балансит то? Брокада или кошак?

Share this post


Link to post
Share on other sites

Обычно попытки SPAN/RSPAN с десяток очень плохо дружат с Port-channel на "младших" платформах.

Share this post


Link to post
Share on other sites

Спасибо за подсказки. Переходим на шасси 6504-e, т.к. эта фича очень нужна.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this