Перейти к содержимому
Калькуляторы

Для чего в MikroTik придумали EoIP EoIP vs GRE

JoeDoe, и чем же таким замечателен адрес "Пернавас, 46"?

Месторасположением. Популярностью района в сводках полиции.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

JoeDoe, и чем же таким замечателен адрес "Пернавас, 46"?

Месторасположением. Популярностью района в сводках полиции.

Думаешь там сидят гопнеки от IT =)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Думаешь там сидят гопнеки от IT =)

Учитывая, сколько опенсорца они слямзили, - настоящие мафиози.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Кто-нибудь ответит, почему Микротик не даёт добавить к мосту GRE или IPIP интерфейс?

Потому что это L3 интерфейсы и MACов там нет - соответственно и бриджевать нечего.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

JoeDoe, и чем же таким замечателен адрес "Пернавас, 46"?

Намекает на стоящих там по вечерам блядей ?

А как же оофис в Румбуле/Дарзини ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Удваивание pps идет только на больших пакетах

Ну т.е. на более чем 50% пакетов в траффике, так? :)

 

Проблем работы за натом тоже нет, т.к. через нат запускается любой туннельный протокол, т.к. указанный EoIP через нат в принципе работать не может, как и любые другие протоколы, требующие указания IP адресов противоположных устройств.

Угу, туннель в туннеле - это так по-микротиковски :) А все потому, что кто-то так и не осилил запилить l2tpv3 в свою поделку.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ну т.е. на более чем 50% пакетов в траффике, так? :)

 

Откуда 50? Обратка обычно маленькими пакетами, они не фрагментируются. Всякие там закачки тоже обычно пакетами в районе 1000, поэтому размер больших пакетов, которые реально будут фрагментироваться, около 10-15 от общего трафика и то на специфических данных.

 

Угу, туннель в туннеле - это так по-микротиковски :) А все потому, что кто-то так и не осилил запилить l2tpv3 в свою поделку.

 

А всеми любимый MPLS это разве не туннель в туннеле?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ни разу за все время использования не наблюдал проблем с eoip. Был единственный случай, когда на CCR просто исчезал один eoip интерфейс, что было вылечено обновлением прошивки.

Использую для пробросов l2 через разношерстные сети (радио, оптика с l3 only, интернет и т.п.), в т.ч. с резервированием на уровне l3.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ну т.е. на более чем 50% пакетов в траффике, так? :)

 

Откуда 50? Обратка обычно маленькими пакетами, они не фрагментируются. Всякие там закачки тоже обычно пакетами в районе 1000, поэтому размер больших пакетов, которые реально будут фрагментироваться, около 10-15 от общего трафика и то на специфических данных.

 

Угу, туннель в туннеле - это так по-микротиковски :) А все потому, что кто-то так и не осилил запилить l2tpv3 в свою поделку.

 

А всеми любимый MPLS это разве не туннель в туннеле?

 

каким р@ком MPLS туннель в туннеле? может вам делом занятся и книжек почитать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

каким р@ком MPLS туннель в туннеле? может вам делом занятся и книжек почитать?

 

А тем, что поверх MPLS ходят разные данные, это не туннели, аналогичные EoIP? VPLS разве не аналог EoIP, только более глючный?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

каким р@ком MPLS туннель в туннеле? может вам делом занятся и книжек почитать?

 

А тем, что поверх MPLS ходят разные данные, это не туннели, аналогичные EoIP? VPLS разве не аналог EoIP, только более глючный?

 

вы дебил?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

каким р@ком MPLS туннель в туннеле? может вам делом занятся и книжек почитать?

 

А тем, что поверх MPLS ходят разные данные, это не туннели, аналогичные EoIP? VPLS разве не аналог EoIP, только более глючный?

 

вы дебил?

А разве это не очевидно? =)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

VPLS разве не аналог EoIP, только более глючный?

буду знать

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Всякие там закачки тоже обычно пакетами в районе 1000

Бред. tcp/udp сессия обычно шпарит пакетами с размером равным MTU.

 

 

А всеми любимый MPLS это разве не туннель в туннеле?

Нет.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

На форуме встречал, что EoIP не защищён.

Связали две точки и настроили между ними IPSec. Довольны.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

На форуме встречал, что EoIP не защищён.

Естественно не защищен. Это просто инкапсуляция.

А тем, что поверх MPLS ходят разные данные, это не туннели, аналогичные EoIP? VPLS разве не аналог EoIP, только более глючный?

Рукалицо

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

каким р@ком MPLS туннель в туннеле? может вам делом занятся и книжек почитать?

 

А тем, что поверх MPLS ходят разные данные, это не туннели, аналогичные EoIP? VPLS разве не аналог EoIP, только более глючный?

 

вы дебил?

он дебил, но мплс действительно можно сравнивать с туннелями, суть та же, дополнительный заголовок поверх исходных данных, каждая следующая метка повышает глубину упаковки. детали реализации только отличаются

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вообще микротик сделал то что не захотили видимо в силу защиты более сложных технологий Cisco. Затащить в GRE возможность передачи point-to-point ethernet фрэйма было бы очень логично и весьма удобно. И Cisco уже теперь когда деваться некуда все таки запилила Ethernet over GRE. Так что никакого ноу-хау тут нет. такие дела

 

! Configure the topology
mobile-node1(config-if)# interface GigabitEthernet0/1
mobile-node1(config-if)# ip address 10.21.1.1 255.255.255.0
mobile-node1(config-if)# no shut
mobile-node1(config-if)# exit
mobile-node1(config)# ip route 10.0.0.1 255.255.255.255 10.21.1.2 

! Configuring the interface used as the source of the tunnel
mobile-node1(config)# interface Loopback0
mobile-node1(config-if)# ip address 10.40.0.1 255.255.255.0 
mobile-node1(config-if)# ipv6 address 2001:db8:2:40::1/64
mobile-node1(config-if)# no shutdown

! Configuring the Ethernet over GRE IPv4 Tunnel
mobile-node1(config-if)# interface Tunnel1
mobile-node1(config-if)# mac-address 0000.0000.0001
mobile-node1(config-if)# ip dhcp client client-id ascii MN1@cisco.com 
mobile-node1(config-if)# ip address dhcp
mobile-node1(config-if)# no ip redirects 
mobile-node1(config-if)# no ip route-cache
mobile-node1(config-if)# tunnel source Loopback0
mobile-node1(config-if)# tunnel mode ethernet gre ipv4 
mobile-node1(config-if)# tunnel key 1 
mobile-node1(config-if)# tunnel vlan 1
mobile-node1(config-if)# no shutdown

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Бред. tcp/udp сессия обычно шпарит пакетами с размером равным MTU.

 

Вы лукавите.

 

Нет.

 

А как же тогда там разные услуги предоставляются? Транспорт L2, транспорт L3 и т.п.?

 

На форуме встречал, что EoIP не защищён.

Связали две точки и настроили между ними IPSec. Довольны.

 

Вы по нему передаете важные данные? Все важные данные и так шифруются приложениями.

 

мплс действительно можно сравнивать с туннелями, суть та же, дополнительный заголовок поверх исходных данных, каждая следующая метка повышает глубину упаковки. детали реализации только отличаются

 

Да, только у EoIP нет никаких проблем с MTU, а у MPLS есть.

 

Вообще микротик сделал то что не захотили видимо в силу защиты более сложных технологий Cisco. Затащить в GRE возможность передачи point-to-point ethernet фрэйма было бы очень логично и весьма удобно. И Cisco уже теперь когда деваться некуда все таки запилила Ethernet over GRE. Так что никакого ноу-хау тут нет. такие дела

 

Вот и я про что, циска утащила эту технологию с микротика.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 

Да, только у EoIP нет никаких проблем с MTU, а у MPLS есть.

o rly?

O_RLY.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Вообще микротик сделал то что не захотили видимо в силу защиты более сложных технологий Cisco. Затащить в GRE возможность передачи point-to-point ethernet фрэйма было бы очень логично и весьма удобно.

Этому сто лет уже, на фре без проблем можно давно туннелировать л2 поверх юдп с помощью нетграфа, в линухах наверное тоже было что то такое ещё раньше, чем тик появился.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Вообще микротик сделал то что не захотили видимо в силу защиты более сложных технологий Cisco. Затащить в GRE возможность передачи point-to-point ethernet фрэйма было бы очень логично и весьма удобно.

Этому сто лет уже, на фре без проблем можно давно туннелировать л2 поверх юдп с помощью нетграфа, в линухах наверное тоже было что то такое ещё раньше, чем тик появился.

эмм.. Да я вроде не о инкапсуляции нижнего протокола в верхний, а о реализации Ethernet over GRE у Cisco.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вы лукавите.

Посмотрите тспдамп что ли любой закачки...

 

А как же тогда там разные услуги предоставляются? Транспорт L2, транспорт L3 и т.п.?

Что, для этого нужно мплс заворачивать в еще один туннель? :)

 

Да, только у EoIP нет никаких проблем с MTU, а у MPLS есть.

Нет у мплс никаких проблем с мту.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Что, для этого нужно мплс заворачивать в еще один туннель? :)

 

МПЛС это и есть туннель.

 

Нет у мплс никаких проблем с мту.

 

Что же основное требование для связи интерфейсов это прохождение пакетов более 1500 байт?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас