Jump to content

Mikrotik 951G 2HnD + Мегафон M100-3 (ZTE MF823) не работает.

Добрый день!

 

Пытаюсь соединить эти два устройства, на вики указано, что данный модем работает с прошивкой 6.8, у меня стоит 6.15, я так понимаю, тоже должен работать. Сначала пытался сделать по данному мануалу: http://smalladmin.dima.com.ru/%D0%BD%D0%B0%D1%81%D1%82%D1%80%D0%BE%D0%B9%D0%BA%D0%B0-4g-lte-%D0%BC%D0%BE%D0%B4%D0%B5%D0%BC%D0%B0-%D0%BC%D0%B5%D0%B3%D0%B0%D1%84%D0%BE%D0%BD-%D0%BC100-3-%D0%B4%D0%BB%D1%8F-%D1%80%D0%B0%D0%B1%D0%BE/

 

Но как то не срослось. Все чего удалось добиться:

 

Если не проводить никаких доп настроек с модемом, в роутере появляется интерфейс LTE, который вроде как активен, но по факту интернета нет. Модем горит ровным зеленым цветом, что означает, что сигнал есть, а коннекта нету.

 

Если "разблокировать" модем, и отключить на нем автозагрузку для программы мегафона на ПК, то на микротике появляется интерфейс ppp-out1, который отмечен серым цветом, и даже если сделать этот интерфейс Enabled, то в логе бесконечно висит "Connecting..." при этом модем мигает зеленым цветом, что означает, что он подключен к интернету, однако интерфейс все равно окрашен серым, и интернет не раздается. Пробовал также заполнять "APN" - internet, а логин и пароль PPP - "gdata", но также никаких изменений не произошло.

 

Настройки микротика дефолтные, из коробки.

 

Также пытался делать по этому мануалу: http://www.lanmart.ru/blogs/mikrotik-3g-4g-lte-modem/

 

Тут у меня уже на первом шаге, совсем все не так, как у автора. При попытке открыть "Info" - у меня выдает ошибку, никаких данных в этом разделе нет. В общем и целом, модем работает, если включаю его напрямую в ПК - интернет есть. Гуглил, находил кучу мануалов по разблокировке модема, но по соединению с микротиком информации очень мало.

 

Вот экспорт, хотя тут все почти по дефолту:

/interface bridge

add admin-mac=4C:5E:0C:34:EC:75 auto-mac=no l2mtu=1598 name=bridge-local

/interface wireless

set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-ht-above \

disabled=no distance=indoors l2mtu=2290 mode=ap-bridge ssid=MikroTik-34EC79

/interface ethernet

set [ find default-name=ether1 ] name=ether1-gateway

set [ find default-name=ether2 ] name=ether2-master-local

set [ find default-name=ether3 ] master-port=ether2-master-local name=\

ether3-slave-local

set [ find default-name=ether4 ] master-port=ether2-master-local name=\

ether4-slave-local

set [ find default-name=ether5 ] master-port=ether2-master-local name=\

ether5-slave-local

/ip neighbor discovery

set ether1-gateway discover=no

/ip hotspot user profile

set [ find default=yes ] idle-timeout=none keepalive-timeout=2m \

mac-cookie-timeout=3d

/ip pool

add name=default-dhcp ranges=192.168.88.10-192.168.88.254

/ip dhcp-server

add address-pool=default-dhcp disabled=no interface=bridge-local lease-time=10m \

name=default

/port

set 0 name=usb1

/interface ppp-client

add add-default-route=yes allow=pap,chap,mschap1,mschap2 data-channel=0 \

default-route-distance=1 dial-command=ATDT dial-on-demand=yes disabled=no \

info-channel=0 keepalive-timeout=10 max-mru=1500 max-mtu=1500 modem-init="" \

mrru=disabled name=ppp-out1 null-modem=no password="" phone="" pin="" port=\

usb1 profile=default use-peer-dns=yes user=""

/interface bridge port

add bridge=bridge-local interface=ether2-master-local

add bridge=bridge-local interface=wlan1

/ip address

add address=192.168.88.1/24 comment="default configuration" interface=\

bridge-local network=192.168.88.0

/ip dhcp-client

add comment="default configuration" dhcp-options=hostname,clientid interface=\

ether1-gateway

add default-route-distance=0 dhcp-options=hostname,clientid disabled=no

/ip dhcp-server network

add address=192.168.88.0/24 comment="default configuration" dns-server=\

192.168.88.1 gateway=192.168.88.1

/ip dns

set allow-remote-requests=yes

/ip dns static

add address=192.168.88.1 name=router

/ip firewall filter

add chain=input comment="default configuration" disabled=yes protocol=icmp

add chain=input comment="default configuration" connection-state=established \

disabled=yes

add chain=input comment="default configuration" connection-state=related \

disabled=yes

add action=drop chain=input comment="default configuration" disabled=yes \

in-interface=ether1-gateway

add chain=forward comment="default configuration" connection-state=established \

disabled=yes

add chain=forward comment="default configuration" connection-state=related \

disabled=yes

add action=drop chain=forward comment="default configuration" connection-state=\

invalid disabled=yes

/ip firewall nat

add action=masquerade chain=srcnat comment="default configuration" \

out-interface=ppp-out1

/ip upnp

set allow-disable-external-interface=no

/system leds

set 0 interface=wlan1

/tool mac-server

set [ find default=yes ] disabled=yes

add interface=ether2-master-local

add interface=ether3-slave-local

add interface=ether4-slave-local

add interface=ether5-slave-local

add interface=wlan1

add interface=bridge-local

/tool mac-server mac-winbox

set [ find default=yes ] disabled=yes

add interface=ether2-master-local

add interface=ether3-slave-local

add interface=ether4-slave-local

add interface=ether5-slave-local

add interface=wlan1

add interface=bridge-local

 

Вот как это выглядит изнутри.

 

7H4RxbE.png

Edited by mafteg

Share this post


Link to post
Share on other sites

Прошей модем в режим HiLink и он сам определится и присвоит IP, необходимо только включить DHCP Client на интерфейс lte1.

и забыть про эти ppp-out1, APN.

Share this post


Link to post
Share on other sites

Прошей модем в режим HiLink и он сам определится и присвоит IP, необходимо только включить DHCP Client на интерфейс lte1.

и забыть про эти ppp-out1, APN.

 

Большое спасибо! Все включилось, сначала так и сделал в целом, но забыл NAT настроить.

Share this post


Link to post
Share on other sites

Всё, конечно, здорово. Предварительно модем переводишь в режим автодозвона (см. тут), а на микротике включаешь NAT - всё работает.

НО. Получаем двойной NAT (модем уже является роутером). В некоторых случаях это может вызвать определённые неудобства.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.