Jump to content

Настройка туннеля ipip между freebsd и mikrotik

Всем здравствуйте!

Никак не могу разобраться, по этому прошу помощи. С микротиком только начинаю знакомство :)

Имеется 2 железки:

Дом - RB2011, RouterOS: 6.26

Офис- FreeBSD 8.2 x64

Хочу заставить работать ipip туннель между микротиком и FreeBSD, но столкнулся с непонятными для меня вещами.

Сам туннель вроде настроил:

FreeBSD:
gif1: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> metric 0 mtu 1460
tunnel inet OFFICE WAN --> HOME WAN
inet 172.16.10.2 --> 172.16.10.1 netmask 0xffffff00 
options=1<ACCEPT_REV_ETHIP_VER>
Mikrotik:
/interface ipip
add !keepalive local-address=HOME WAN mtu=1460 name=ipip-Office \
   remote-address=OFFICE WAN

Маршруты тоже прописаны:

FreeBSD:
172.16.10.1        link#11            UH          0       36   gif1
172.16.10.2        link#11            UHS         0        3    lo0
192.168.2.0        172.16.10.1        UGS         0     1052   gif1

Mikrotik:
172.16.10.0/24     172.16.10.1     ipip-Office            255
192.168.18.0/24                    172.16.10.2               1

 

И в общем-то туннель работает, но только тогда, когда со стороны FreeBSD есть связь. Т.е. если запустить пинг из офиса к дому, то связь есть, доступ к ресурсам внутри домашней сети из офиса тоже, а обратно никак. Пинг от микротика до бсд только в течении нескольких секунд, после того, как со стороны bsd была связь, иначе тунель падает и поднимается, только если пустить пинги от bsd, иначе request timeout. Доступа к ресурсам офиса из дома тоже нет. В чем может быть причина? Фаервол в микротике пустой:

/ip firewall filter
add chain=input comment="Beeline IPTV" in-interface=WAN1 protocol=igmp
add action=drop chain=input comment="Drop invalid connections" \
   connection-state=invalid
add chain=input comment="Allow Established connections" connection-state=\
   established
/ip firewall mangle
add action=change-mss chain=forward in-interface=Beeline new-mss=1420 \
   protocol=tcp tcp-flags=syn tcp-mss=1421-65535
add action=change-mss chain=forward new-mss=1420 out-interface=Beeline \
   protocol=tcp tcp-flags=syn tcp-mss=1421-65535
/ip firewall nat
add action=masquerade chain=srcnat out-interface=WAN1
add action=masquerade chain=srcnat out-interface=Beeline
add action=dst-nat chain=dstnat comment="WEB server" dst-address=HOME WAN \
   dst-port=80 protocol=tcp to-addresses=192.168.2.2 to-ports=80
add action=src-nat chain=srcnat protocol=tcp src-address=192.168.2.0/24 \
   to-addresses=HOME WAN
/ip firewall service-port
set ftp disabled=yes
set irc disabled=yes
set h323 disabled=yes

На бсд сейчас тоже самое. Нат для офиса и allow ip from any to any

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.