Jump to content
Калькуляторы

vlan-mapping + interfcae vlan Huawei NE40 vlan-mapping влана, в котором есть interface vlan

Добрый день.

 

Где-то ошибаюсь даже в теоретеской базе, не могу понять где.

 

 

Есть схема со свичами, в которой управление ими расположено в 8-м влане. Появлися необходимость пробросить через другого оператора управление в сторону новой точки. Естественно, 8-й влан у оператора занят. Свободен 2307. Решил сделать vlan mapping.

 

Свич59 --- vlan2307, tag --- NE40 ---- vlan8, tag -- Свич2

 

Проблема - собственный vlan interface 8 на NE40 не видит новый, 59-й свич. В таблице мак-адресов мак есть. А arp - нет.

В то же время другое оборудование в 8-м влане прекрасно видит 59-й свич.

 

И у 59-й достукивается ко всем железкам в 8-м влане, кроме NE40. (своего шлюза по умолчанию)

 

Самое важное из конфиги:

 

На свиче59:

interface vlan 2307

ip addr 192.168.10.59 255.255.255.0

 

 

На свиче2:

interface vlan 8

ip addr 192.168.10.2 255.255.255.0

 

На NE40:

 

vlan 8

 

interface vlan 8

ip addrr 192.168.10.1 255.255.255.0

 

int gi 1/1/0 <-- в сторону Свича59

undo shutdown

portswitch

port link-type trunk

port vlan-mapping outside-vlan 2307 map-vlan 8

 

 

int gi 1/1/2 <-- в сторону Свича2

undo shutdown

portswitch

port link-type trunk

port trunk allow-pass vlan 8

 

что имеем:

 

1. Свич59 может пинговать Свич2. Но _не_может_ пинговать NE40 :(

2. Свич 2. Может пинговать как Свич59 так и NE40.

3. NE40 может пинговать _только_ Свич2.

 

Как заставить NE40 пинговать Свич59?

 

 

 

 

[NE40]disp mac-address dynamic vlan 8

MAC address table of slot 1:

-------------------------------------------------------------------------------

MAC Address VLAN/ PEVLAN CEVLAN Port Type LSP/LSR-ID

VSI/SI MAC-Tunnel

-------------------------------------------------------------------------------

00e0-fc12-33b1 8 - - GE1/1/2 dynamic 1/-

00e0-fc12-33a9 8 - 2307 GE1/1/0 dynamic 1/-

 

-------------------------------------------------------------------------------

Total matching items on slot 1 displayed = 2

 

 

[NE40]display vlan 8

VLAN ID Type Status MAC Learning Broadcast/Multicast/Unicast Property

--------------------------------------------------------------------------------

8 common enable enable forward forward forward default

----------------

Tagged Port: GigabitEthernet1/1/2

----------------

QinQ-map Port: GigabitEthernet1/1/0

----------------

Interface Physical

GigabitEthernet1/1/0 UP

GigabitEthernet1/1/2 UP

 

 

[NE40]disp arp int vl 8

IP ADDRESS MAC ADDRESS EXPIRE(M) TYPE INTERFACE VPN-INSTANCE

VLAN/CEVLAN PVC

------------------------------------------------------------------------------

192.168.10.1 0025-9e16-3286 I - Vlanif8 test1

192.168.10.2 00e0-fc12-33b1 13 DF1 GE1/1/2 test1

8/-

------------------------------------------------------------------------------

Total:2 Dynamic:1 Static:0 Interface:1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this