Jump to content
Калькуляторы

Вопрос по VirtualBox

Есть сервер с FreeBSD 8.2 x64 с VirtualBox.

После обновления перестала запускаться виртуальная машина.

В логах следующее:

25/02/2015 15:10:24 Listening for VNC connections on TCP port 65101
25/02/2015 15:10:24 listenerRun: error in select: Bad file descriptor
Oracle VM VirtualBox Headless Interface 4.3.22_OSE
(C) 2008-2015 Oracle Corporation
All rights reserved.

VRDE server is listening on port 65101.
Error: failed to start machine. Error message: Failed to open/create the internal network 'HostInterfaceNetworking-em0' (VERR_SUPDRV_COMPONENT_NOT_FOUND).
Failed to attach the network LUN (VERR_SUPDRV_COMPONENT_NOT_FOUND)

Не пойму, что тут не так.

Интерфейс em0 существует и работает.

Сеть в виртуальной машине определена так:

     <Network>
       <Adapter slot="0" enabled="true" MACAddress="0800273BCADC" cable="true" speed="0" type="82540EM">
         <DisabledModes>
           <NAT>
             <DNS pass-domain="true" use-proxy="false" use-host-resolver="false"/>
             <Alias logging="false" proxy-only="false" use-same-ports="false"/>
           </NAT>
           <InternalNetwork name="intnet"/>
           <NATNetwork name="NatNetwork"/>
         </DisabledModes>
         <BridgedInterface name="em0"/>
       </Adapter>
       <Adapter slot="1" enabled="false" MACAddress="080027A50583" cable="true" speed="0" type="82540EM">
         <DisabledModes>
           <NAT>
             <DNS pass-domain="true" use-proxy="false" use-host-resolver="false"/>
             <Alias logging="false" proxy-only="false" use-same-ports="false"/>
           </NAT>
         </DisabledModes>
       </Adapter>
       <Adapter slot="2" enabled="false" MACAddress="080027D03A76" cable="true" speed="0" type="82540EM">
         <DisabledModes>
           <NAT>
             <DNS pass-domain="true" use-proxy="false" use-host-resolver="false"/>
             <Alias logging="false" proxy-only="false" use-same-ports="false"/>
           </NAT>
         </DisabledModes>
       </Adapter>
       <Adapter slot="3" enabled="false" MACAddress="08002770608B" cable="true" speed="0" type="82540EM">
         <DisabledModes>
           <NAT>
             <DNS pass-domain="true" use-proxy="false" use-host-resolver="false"/>
             <Alias logging="false" proxy-only="false" use-same-ports="false"/>
           </NAT>
         </DisabledModes>
       </Adapter>
       <Adapter slot="4" enabled="false" MACAddress="0800278408BA" cable="true" speed="0" type="82540EM">
         <DisabledModes>
           <NAT>
             <DNS pass-domain="true" use-proxy="false" use-host-resolver="false"/>
             <Alias logging="false" proxy-only="false" use-same-ports="false"/>
           </NAT>
         </DisabledModes>
       </Adapter>
       <Adapter slot="5" enabled="false" MACAddress="0800273CBB2D" cable="true" speed="0" type="82540EM">
         <DisabledModes>
           <NAT>
             <DNS pass-domain="true" use-proxy="false" use-host-resolver="false"/>
             <Alias logging="false" proxy-only="false" use-same-ports="false"/>
           </NAT>
         </DisabledModes>
       </Adapter>
       <Adapter slot="6" enabled="false" MACAddress="080027EDB577" cable="true" speed="0" type="82540EM">
         <DisabledModes>
           <NAT>
             <DNS pass-domain="true" use-proxy="false" use-host-resolver="false"/>
             <Alias logging="false" proxy-only="false" use-same-ports="false"/>
           </NAT>
         </DisabledModes>
       </Adapter>
       <Adapter slot="7" enabled="false" MACAddress="08002789FFE3" cable="true" speed="0" type="82540EM">
         <DisabledModes>
           <NAT>
             <DNS pass-domain="true" use-proxy="false" use-host-resolver="false"/>
             <Alias logging="false" proxy-only="false" use-same-ports="false"/>
           </NAT>
         </DisabledModes>
       </Adapter>
     </Network>

Share this post


Link to post
Share on other sites

lsmod ? или как там на фре глянуть загруженные модуля ядра.

Share this post


Link to post
Share on other sites

# kldstat
Id Refs Address            Size     Name
1   31 0xffffffff80200000 15f0430  kernel
2    3 0xffffffff817f1000 6b508    vboxdrv.ko
3    1 0xffffffff81a12000 34d8     ums.ko
4    1 0xffffffff81a16000 265f     pflog.ko
5    1 0xffffffff81a19000 2f17f    pf.ko
6    1 0xffffffff81a49000 9bf6     linprocfs.ko
7    1 0xffffffff81a53000 432d4    linux.ko
8    1 0xffffffff81a97000 37c7     ng_socket.ko
9    3 0xffffffff81a9b000 affe     netgraph.ko
10    2 0xffffffff81aa6000 28c0     vboxnetflt.ko
11    1 0xffffffff81aa9000 4041     ng_ether.ko
12    1 0xffffffff81aae000 3ec0     vboxnetadp.ko

Вроде бы все загружено.

Раньше VirtualBox работал, перестал работать после обновления.

Share this post


Link to post
Share on other sites

Видимо да.

Сейчас с помощью kldload заново загрузил модули vbox, теперь виртуальная машина стартовала нормально.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this