Jump to content
Калькуляторы

Проблема с Wi-Fi в Микротике Высокие и рваные пинги до самого микротика

Приветствую! Я уже неоднократно сталкивался с проблемой Wi-Fi в микротике, когда пинги до самого роутера начинают рваться и подскакивать аж до 4000мс. При этом если от клиента забрать микротик и привезти его в офис, то все работает нормально. Думал, может проблема в одинаковых частотах, на которых вещают другие рядом стоящие роутеры. Однако, какую бы частоту я не выбирал проблема не исчезает. Повторюсь, в офисе (который находится в здании, где очень много других компаний, использующих wi-fi-роутеры), где wi-fi сетей еще больше, чем в здании клиента все работает нормально.

 

Последним пиком негодования стал микротик у клиента, который проживает в частном доме. Там мы ловим только одну "левую" есть. Стоит микротик RB2011UAS-2HnD, прошитый до routeros-mipsbe v6.6. Вот настройки Wi-Fi сети на нем:

 

/interface wireless security-profiles
set [ find default=yes ] group-ciphers=tkip
add authentication-types=wpa-psk,wpa2-psk eap-methods="" group-ciphers=tkip,aes-c
   unicast-ciphers=tkip,aes-ccm wpa-pre-shared-key=bit1002418 wpa2-pre-shared-ke
/interface wireless
set [ find default-name=wlan1 ] allow-sharedkey=yes antenna-gain=15 band=2ghz-b/g
   2452 frequency-mode=superchannel ht-rxchains=0,1 ht-txchains=0,1 l2mtu=2290 m
   security-profile=wifi ssid=bit_wi-fi tx-power=20 tx-power-mode=all-rates-fixe
/interface wireless nstreme
set wlan1 enable-polling=no

 

К нему подключены 4 ноута, на которых практически ничего не запущено (только различные мелкие проги). Пингуем с каждого из них микротик и видим, что пинги начинают рваться (через каждые 2-4 отклика 3-4 потери), а время отклика составляет порой 300-1000мс. Если на каком-либо из них запустить закачку файла из инета пинг просаживается аж до 2000-4000мс. Отключаем три ноута, оставляем один, выбранный наобум. Вуа-ля, все работает идеально. Пинги до микротика 1-2 мс и больше не рвутся, скорость инета соответствует тарифному плану (в данном случае 12 Мбит/с). И только стоит подключить хотя бы один из буков к сети wi-fi. Все опять начинает работать через жопу.

 

Рядом с микротиком поставили DIR-615. Отключаем Wi-Fi на тике и подключаем все ноуты к ДИРу. Сеть работает идеально, хоть пинги и прыгают до 50-70мс до него иногда, но по крайней мере не рвутся. Сошлемся на то, что мощность передатчика у ДИРа все же слабее, чем у тика. Отключаем ДИР и подключаем ноуты к тику - начинается та же жопа.

 

Перелопатил все настройки на микротике, ничего не помогло. Я уже выдохся и потерял всякую надежду на то, что у клиента Wi-Fi-сеть начнет нормально работать через микротик. Народ, если кто сталкивался с аналогичной проблемой или кто хоть что-то может подсказать помогите!!! Я никак понять не могу, из-за чего он себя так ведет.

 

Заранее благодарен!

Share this post


Link to post
Share on other sites

/interface wireless print detail покажите.

 

Ну и сразу, не глядя:

/interface wireless set interface=wlan1 tx-power=10 antenna-gain=3

Share this post


Link to post
Share on other sites

Flags: X - disabled, R - running

0 X name="wlan1" mtu=1500 mac-address=D4:CA:6D:56:FF:7F arp=enabled interface-type=Atheros AR9300 mode=ap-bridge ssid="bit_wi-fi" frequency=2452 band=2ghz-b/g/n

channel-width=20/40mhz-ht-above scan-list=default wireless-protocol=any wds-mode=disabled wds-default-bridge=none wds-ignore-ssid=no bridge-mode=enabled

default-authentication=yes default-forwarding=yes default-ap-tx-limit=0 default-client-tx-limit=0 hide-ssid=no security-profile=wifi compression=no

 

В данный момент сеть отключена, т.к. Wi-Fi работает через DIR-615.

 

interface wireless set 0 tx-power=10 antenna-gain=3 - Выставил, но с этими параметрами я тоже игрался.

Share this post


Link to post
Share on other sites

Ширина канала не влияет в моем случае на качество сигнала. Пробовал уже менять.

А что нам даст параметр ht-basic-mcs=mcs7 ?

Share this post


Link to post
Share on other sites

Ага подобная проблема есть. Немного лучше стало при включении nstreme.

Share this post


Link to post
Share on other sites

Ширина канала не влияет в моем случае на качество сигнала. Пробовал уже менять.

А что нам даст параметр ht-basic-mcs=mcs7

Ширину канала выше 20 в любом случае нет смысла ставить.

И добавьте ht-supported-mcs=mcs7

Эти два параметра ограничат модуляцию, если ситуация улучшится, то дальше методом перебора будем искать лучшую

Share this post


Link to post
Share on other sites

Действительно, возможно помогло включение параметра ht-basic-mcs=mcs7

 

По крайней мере клиент активно пользовался Wi-Fi с нескольких машин в течении трех часов и все было в норме. Он еще протестирует до завтра, как будет работать сеть. Если все будет в норме, то это просто супер.

 

P.S. что это за надстройка и что она делает?

Share this post


Link to post
Share on other sites

Эта настройка меняет тип модуляции и схему кодирования сигнала.

Нет смысла загонять в антенну сложно модулированный сигнал, если клиенту нужно несколько Мбит\с

Разобрать такой сигнал сложнее. Особенно если нет избыточности от этого можно поиметь проблем при большой интерференции. Проще говоря чем больше эта цыфарка, тем больше у вас должен быть запас по сигнал\шуму.

Вот тут подробнее

http://www.digitalairwireless.com.au/wireless-blog/recent/understanding-mcs-values.html

 

Более подробно об этом можно узнать...

в универитетах этой страны. (:

Edited by Fancar

Share this post


Link to post
Share on other sites

Действительно, возможно помогло включение параметра ht-basic-mcs=mcs7

 

По крайней мере клиент активно пользовался Wi-Fi с нескольких машин в течении трех часов и все было в норме. Он еще протестирует до завтра, как будет работать сеть. Если все будет в норме, то это просто супер.

 

P.S. что это за надстройка и что она делает?

Если попроще, то она снижает плотность информации, передаваемой в канале. Эта настройка помогает работать в зашумленном эфире ценой снижения пропускной способности канала.

Share this post


Link to post
Share on other sites

Эта настройка меняет тип модуляции и схему кодирования сигнала.

Нет смысла загонять в антенну сложно модулированный сигнал, если клиенту нужно несколько Мбит\с

Разобрать такой сигнал сложнее. Особенно если нет избыточности от этого можно поиметь проблем при большой интерференции. Проще говоря чем больше эта цыфарка, тем больше у вас должен быть запас по сигнал\шуму.

Вот тут подробнее

http://www.digitalairwireless.com.au/wireless-blog/recent/understanding-mcs-values.html

 

Более подробно об этом можно узнать...

в универитетах этой страны. (:

 

Большое спасибо за ответ.

Не бывали мы в университетах =) Жизнь так повернулась, что... эх... короче не об этом нынче разговор ))

Буду дальше штудировать материалы по этому вопросу =)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this