Jump to content
Калькуляторы

SXT-lite и untagged eth port Что-то пошло не так

Доброго дня.

 

Имеется задача, настроить vlan c\на порт ethernet у SXT-lite без тега.

 

Следующая схема иногда(!) работает до перезагрузки устройства wlan1 <-> bridge1 vlan2(int Bridge1), Bridge2:port:eth, Bridge2:port:vlan2. ip-адрес управления на vlan1, vlan1 смотрит в wlan1 интерфейс.

При этом почему-то если физические интерфейсы не объеденены в один бридж портами (меню бридж, вкладка ports), устройство переключается в режим роутер(!) и просит воткнуть ip на wlan. Но коммутация при этом работает, повторюсь, до перезагрузки абонентского комплекта.

 

При этом на SXT-СhPnD нормально работает схема с untagged vlan на eth без бриджа на wlan, vlan управления и vlan абонента смотрят прямо в wlan1 интерфейс, бридж объединяет vlan абонента (порты бриджа - влан аб-та и eth-интерфейс) Такая схема почему-то не работает на SXT-lite (точнее иногда работает до перезагрузки, и устройство думает, что оно в mode:router)

 

есть у кого-нибудь рабочая конфигурация в загашнике? Такая тривиальная, казалось бы, задача выливается на микротике в мозговой штурм. ужас.

Edited by Fancar

Share this post


Link to post
Share on other sites

У вас влан прилетает с wlan интерфейса? Wlan и lan в бридже?

Share this post


Link to post
Share on other sites

тэгированные фреймы идут с радио-интерфейса, lan, vlan (клиента) в одном бридже (портами).

Сами vlan's (клиентский и mng)и бридж смотрят на wlan. Такой конфиг работает на PnD. Но отказывается работать на Lite.

Edited by Fancar

Share this post


Link to post
Share on other sites

Тлен. forum.mikrotik.com/viewtopic.php?t=59591

На форуме микротика

пишут, что можно попробовать wds-station на клиентах.

Это что настолько поделка-поделка, что даже такой банальной вещи делать не умеет, как снять тег. И нужен wds?

Edited by Fancar

Share this post


Link to post
Share on other sites

Прочитал все сообщения и, честно говоря, вообще не понял задачу.

Лучше всего нарисовать схему работы - желаемую.

Совсем не понятно, какое устройство выступает в качестве базы, а какое в качестве клиента. Не понятно в каком режиме b,g,n,nv2 работает радио.

Микротик нормально работает с тегированным трафиком (SXT в частности)

По поводу wds - не могу понять моды пихать его куда попало.

Нарисуйте схему на которой показано, что именно вы хотите получить в итоге.

Share this post


Link to post
Share on other sites

Если все правильно понял, то вам нужно на Wlan интерфейсе поднять два влана. К примеру 1 nms и 2 data. На влане 1 вешаете адрес управления и более с ним нечего делать не нужно.

Далее создаете бридж, в который засовываете vlan 2 и eth, получится что трафик пойдет антегом в лан интерфейс.

Вроде так

Edited by pandel

Share this post


Link to post
Share on other sites

Saiko, думаю можно обойтись без схемы. нужно на eth интерфейсе отдать vlan без тега, на wlan соответственно принять два vlan, один для управления SMкой, второй абонентский. По wds согласен. Тоже не понимаю почему во всех доках указано, что его нужно включить.

 

pandel, так и делаю. На один влан вешаю ip-адрес, и цепляю этот vlan на интерфейс wlan.

Далее если создать бридж, в который засунуть vlan и eth портами, то трафик должен пойти антагом (так работает на hPnD и роутерах). При этом SXT-lite не работает так. Возможно коммутации не происходит, потому, что точка переключается в режим "роутер", если интерфейсы eth и wlan не объеденены в один бридж портами.

Share this post


Link to post
Share on other sites

pandel правильно говорит как надо сделать.

Только не зря спрашивал по поводу протокола на радио интерфейсе, от этого зависит: будет ваша схема работать или нет (и включение wds тоже)

Share this post


Link to post
Share on other sites

В общем победил я эти SXT-lite, накатил последнюю версию прошивки (была 5.24) и оно стало работать ;). Коммутация заработала. Видимо был баг.

Единственное что осталось: в "quiсk set" при такой конфигурации mode: bridge по прежнему не поставить. Она сразу создает bridge1 и сует туда оба физических интерфейса портами. Отключаем порт wlan1 от бриджа и вуаля, модуль снова в режиме роутер и просит ip на wan интерфейс ))) Лучше ничего на этой старнице быстрых настроек не менять, да и не даст оно, т.к. ругается на пустой wan-ip. Но если его не задавать, то коммутация работает. не дышать ))

 

Тогда как на полной версии устройства если создал бридж только для нетегированного eth и влан (вкладка ports), а тегированный (радио) туда не добавил, модуль спокнойно висит в mode: bridge

 

Словом ужос. Буду по возможности обходить эти штуки стороной.

Edited by Fancar

Share this post


Link to post
Share on other sites

Кстати, никто не расскажет нахрена все врубают wds? теги итак все ходят, причем между SMками тоже, если на радиоинтерфейсе выбран station bridge/

wds, это же для репитеров костыль, дублирование кадра. Или в терминологии mikrotik это что-то другое?

Edited by Fancar

Share this post


Link to post
Share on other sites

Тоже нефига не понимаю почему все твердят делать в WDS. Для прозрачного L2 ведь есть бридж режим.

 

Кстати у вас случайно лан и влан интерфейсы не в бридже были? Сейчас собирал тестовую схему, выяснилось что маршрут не работает корректно, если ip адрес прописан на влане, а не на бридже

Share this post


Link to post
Share on other sites

вы имеете ввиду wlan или vlan?

Если есть bridge, в который смотрит интерфейс с которого идут тегированные фреймы (vlan смотрит в бридж, а не в интерфейс непосредственно), то да, нужно, чтобы ip-адрес был не на vlan, а на бридже.

У меня маршрутизации нет, на SM адреса только для менеджмента самой SM. Поэтому vlan управления я прицепил прямо на wlan1.

Edited by Fancar

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this