Jump to content
Калькуляторы

vlan mapping WS-X45-SUP7L-E

Коллеги, нид хэлп :)

Есть: Cat4500 с WS-X45-SUP7L-E и плата WS-X4648-RJ45-E

 

interface GigabitEthernet5/2
description P2P: ISP
switchport trunk allowed vlan 657,662,768,930,931
switchport mode trunk
switchport vlan mapping 931 768
end

 

Задача приходящий vlan 931 транслировать в свой 768 (который пойдет уже дальше по нашей сети), остальные vlan оставить как есть.

Для остальных vlan надо делать mapping 1 в 1?, т.е.

switchport vlan mapping 657 657

switchport vlan mapping 930 930

и т.д.

 

Попробовал сделать без mapping 1 в 1 - отвалились все vlan в этом порту. Экспериментировать нет возможности, порт рабочий и важный.

Share this post


Link to post
Share on other sites

Не знаю как на 45-ом, но на ME-3750 один в один мапить не надо, прописываешь только те vlan которые необходимо поменять.

И первым прописывается локальный vlan (существует в vlan database), вторым тот на который поменять надо, то есть в вашем случае

 

switchport vlan mapping 768 931

 

768 - ваш локальный vlan

931 - vlan например другого оператора, локально прописывать не надо!!!

Share this post


Link to post
Share on other sites

А.. ну да..

switchport vlan mapping ?

WORD original VLAN ID(s) on wire

 

Первым надо указать приходящий ко мне VLAN :)

 

Попробую завтра утром. Но все равно непонятно, даже если я перепутал маппинг - почему пропали мак адреса в других вланах...

 

Хотя все равно моя конфигурация правильная должна быть:

http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst4500/12-2/54sg/configuration/guide/config/tunnel.html#wp1048614

 

 

switch(config-if)# switchport vlan mapping vlan-id translated-id

 

vlan-id—the customer VLAN ID (C-VLAN) entering the switch from the customer network. The range is from 1 to 4094.

translated-id—the assigned service-provider VLAN ID (S-VLAN). The range is from 1 to 4094.

 

Note Packets with unconfigured vlan_ids are dropped.

c-valan 931, s-vlan 768

 

Note: забавное уточнение. Попробую завтра сделать с мапингом 1 в 1 все таки.

Edited by DejaVu

Share this post


Link to post
Share on other sites

Ура, все получилось. Вот правильная и работающая конфигурация для моего железа:

 

interface GigabitEthernet5/2
description P2P: 
switchport trunk allowed vlan 657,662,768,930,931
switchport mode trunk
switchport vlan mapping 657 657
switchport vlan mapping 662 662
switchport vlan mapping 930 930
switchport vlan mapping 931 768
end

 

sh vlan mapping gigabitEthernet 5/2
Interface Gi5/2:
VLANs on wire                    Translated VLAN     Operation
------------------------------   ---------------     --------------
657                                   657            1-to-1
662                                   662            1-to-1
930                                   930            1-to-1
931                                   768            1-to-1

 

931 - приходит ко мне от оператора, 768 - по моей сети. в vlan database создан только 768.

Edited by DejaVu

Share this post


Link to post
Share on other sites

Cisco nexus 3048

Приходит 1881 на порт, нужно его протранслировать в 1133.

version 9.2(3) Bios:version 5.0.0

interface Ethernet1/1
  description uplink
  switchport mode trunk
  switchport vlan mapping enable
  switchport vlan mapping 1133 1881
  switchport trunk allowed vlan 821,1009,1133-1134,1148,1881,3158

Reedlan-10G.Core# show int eth 1/1 vlan mapp
Interface Eth1/1:
Original VLAN                      Translated VLAN
---------------                    -----------------
1133                                      1881

но мас в влане 1881 не виден

что не правильно ?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this