Jump to content
Калькуляторы

Обновление RouterOS через The Dude

Добрый день!

Пытаюсь обновить прошивку на устройствах Mikrotik RouterBOARD 751G-2HnD и 951G-2HnD через программу The Dude 4.0beta3 используя оснастку Devices - RouterOS - Device - Upgrade - 6.26

Но обновление на устройстве не запускается, в поле Upgrade Status появляется сообщение "неизвестные пакеты".

 

Проблема стала наблюдаться с версии 6.25. Каждое отдельное устройство успешно обновляется через интерфейс WinBox: Quick Set - Check For Updates - Download & Upgrade

 

Подскажите как решить эту проблему или альтернативный способ обновить разом пару десятков устройств.

Share this post


Link to post
Share on other sites

Добрый день. Столкнулся с той же проблемой, такое ощущение что The Dude 4.0beta3 не знает новые версии или новые версии по другому стали передавать список пакетов.

Share this post


Link to post
Share on other sites

Подскажите как решить эту проблему или альтернативный способ обновить разом пару десятков устройств.

 

Залейте прошивку на оборудование через FTP, а после по SSH отправьте команду на перезагрузку.

Share this post


Link to post
Share on other sites

Подскажите как решить эту проблему или альтернативный способ обновить разом пару десятков устройств.

 

Залейте прошивку на оборудование через FTP, а после по SSH отправьте команду на перезагрузку.

На кучу устройств по фтп, ручками?

Share this post


Link to post
Share on other sites

пользую скрипт (в шедулере раз в сутки)

 

/system package update

check-for-updates

:delay 1s;

:if ( [get current-version] != [get latest-version]) do={ upgrade }

 

взято из ви-ки оф. сайта МТ

Share this post


Link to post
Share on other sites

На кучу устройств по фтп, ручками?

 

Не ручками а через специализированное по.

Share this post


Link to post
Share on other sites

На кучу устройств по фтп, ручками?

 

Не ручками а через специализированное по.

Это какое? Как видим специализированное ПО вида Дуде обновлять не хочет.

Share this post


Link to post
Share on other sites

Скорее всего обновления The Dude ждать не стоит... Вот моя переписка с представителями MikroTik

Советуют либо через шедулер либо через API... **************

Hello,

Unfortunately my colleague misinformed you a bit. This problem cannot be solved
without the Dude upgrade, but the project is at the moment been put on hold as we
have more important things to work on in regards of RouterOS development. At the
moment best option would be to create upgrade/maintenance system using API system.

Wiki article on api:
wiki.mikrotik.com/wiki/Manual:API

Regards,
Krisjanis P.

03/03/2015 03:00 - Игорь Гречко wrote:

> Hi!
> I administer a small wireless network (600 units).
> With the release of RouterOS 6.25+ I was faced with the problem of
> automatic update devices.
> Dude packages unknown and can not update the device.
> How to solve this problem?
> Surely no one more experienced with it?
> Why bury Dude? Why is not there any solutions?
>
------------------------------------------------------------------------------------------------------------------------------------------------
> sergejs answered me:
>
> We are aware of the particular problem, and fix for the issue will be
> present soon.
>
> Meanwhile for automatic upgrade, I recommend to use simple script.
>
> /system scheduler
> add name=upgrade on-event="/system package update check-for-updates;\r\
> \n/system package update download;\r\
> \n:delay 60s;\r\
> \n/system reboot;"
> policy=reboot,read,write,policy,test,password,sniff,sensitive start-date=\
> feb/28/2015 start-time=13:55:00
>
> it is enough for uprade, you can adjust way how it is loaded and how time
> is specified, but idea is simple.
>
------------------------------------------------------------------------------------------------------------------------------------------------
> Ок!!!!
>
> Yes, but this method is suitable for the equipment on which there is access
> to the Internet. And what about the equipment and the local transport
> network? Only update manually ... And if hundreds of such equipment? When
> will the decision about?
>
> *P.S. My company bought more than 1000 units of your product and you can
> not even fix the problem with the automatic update via ROS The Dude ... I'm
> very disappointed in Mikrotik : (((*

Edited by CoUL

Share this post


Link to post
Share on other sites

На Dude 3.6 успешно перепрошил 3 десятка лайтов. ROS 6.27

Share this post


Link to post
Share on other sites

divxl

С какой версии?

С 6.23 и ниже обновляется без проблем. Попробуй обновить 6.24+...

Share this post


Link to post
Share on other sites

ХЗ ниже 6.27 не пробовал и какой смысл пробовать, прошивки не актуальны. 6.27 обновил без проблем.

Share this post


Link to post
Share on other sites

divxl Я имел ввиду что 6.27 ты уже не сможешь обновить на следующую версию...

The Dude скажет что не знает пакеты...

То-есть обновить можно только версии до 6.24 на любую версию какая есть сейчас, а дальше нельзя...

Edited by CoUL

Share this post


Link to post
Share on other sites

to CoUL

 

Не обновляется :( ФАК, только решил настроить dude Для обновлений групповых, большинство клиентов было на 5.26.

 

Печально все это.

Share this post


Link to post
Share on other sites

divxl Вот-вот... У меня тоже +600 устройств все уже было настрое погрупированно и т.д. А тут облом...

А MikroTik говорит используйте планировщик, API, да вот как будто исправить мелочь с определением пакетов в The Dude сложнее **** чем мне с нуля изучить язык программирования...

Я в шоке... Проект The Dude заморожен и неизвестно когда будет возобновлен, мол есть другие более важные задачи...

Сделали б уже The Dude платным и нормально развивали его...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this