Jump to content
Калькуляторы

Cisco QoS Настройка QoS для организации видеоконференций

Народ ВСЕХ С НОВЫМ ГОДОМ !

Очень нужна помощь с настройкой QoS.

Руководством приобрело новый видеосервер и хотят организовывать HD конференции с филиалами. Без настроек QoS все работает плохо, картинка сыпится. Хотя на оборудовании все магистральные порты загружены максимум на 40 %.

 

Помогите с конфигурацией QoS.

 

 

Сам как бы пытался.

Делал следующие настройки на свичах

 

mls qos map dscp-cos 16 to 1

mls qos map dscp-cos 24 to 2

mls qos map dscp-cos 32 to 3

mls qos map dscp-cos 40 to 4

mls qos map cos-dscp 0 10 18 26 34 46 48 56

 

!

class-map match-all RTP

match access-group name RTP

!

policy-map QoS

class RTP

set dscp ef

!

ip access-list extended RTP

permit udp 10.28.80.0 0.0.0.255 range 4900 49999 10.28.0.0 0.0.255.255 range 4900 49999

!

 

Вешал эту политику на порты видеосервера.

post-63897-012968800 1421242100_thumb.jpg

Edited by Omax

Share this post


Link to post
Share on other sites

эта полиси не полисит, а только красит. полисить надо на выходных портах, в сторону радиоканала.

Share this post


Link to post
Share on other sites

А разве по меткам dscp, при включении mls qos на коммутаторе, не включается автоматически механизм приоритезации пакетов в очередях ?

Edited by Omax

Share this post


Link to post
Share on other sites

Нед. Ибо приоретизация бывает разной.

 

Первый сценарий: Жесткий приоритет. В этом случае пакеты от видеоконференции СТРОГО пойдут вперёд всех. И если у сервера видеоконференций сорвёт башню и о начнёт флудить от души то весь остальной трафик подохнет.

Второй сценарий: Взвешенный приоритет. Тому или иному типу трафика назначается %% от полосы канала. В одном варианте трафик может преодолевать выделенный ему %% если канал простаивает, в другом - нет.

И ешё тысячи их.

 

Вам нужно указать тип дисциплины очередеи на том порту, где у вас "узость".

Share this post


Link to post
Share on other sites

Первый сценарий: Жесткий приоритет. В этом случае пакеты от видеоконференции СТРОГО пойдут вперёд всех. И если у сервера видеоконференций сорвёт башню и о начнёт флудить от души то весь остальной трафик подохнет.

Не могли бы вы привести пример такой настройки.

Второй сценарий: Взвешенный приоритет. Тому или иному типу трафика назначается %% от полосы канала. В одном варианте трафик может преодолевать выделенный ему %% если канал простаивает, в другом - нет.

Это что то типа

policy-map RTP

class RTP

priority percent 50

Share this post


Link to post
Share on other sites

как-то так, но это на роутере. На свичах некоторые фичи в части полисинга /шейпинга могут не поддерживаться.

 

class-map match-any REALTIME

match ip dscp ef

match ip dscp cs5

class-map match-any CRITICAL-DATA

match ip dscp cs6

match ip dscp af31

match ip dscp cs3

class-map match-any VIDEO

match ip dscp af21

match ip dscp cs2

 

policy-map Policy-CBWFQ-to-CE

class REALTIME

priority percent 20

class CRITICAL-DATA

bandwidth percent 10

class VIDEO

bandwidth percent 30

class class-default

fair-queue

 

policy-map Shaper-10M-to-CE

class class-default

shape average 10000000 80000 80000

service-policy Policy-CBWFQ-to-CE

 

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

MSK-c3945-PE1#sh policy-map int gi0/1.174 output

GigabitEthernet0/1.174

 

Service-policy output: Shaper-10M-to-CE

 

Class-map: class-default (match-any)

44331784 packets, 8887326551 bytes

5 minute offered rate 212000 bps, drop rate 0000 bps

Match: any

Queueing

queue limit 64 packets

(queue depth/total drops/no-buffer drops) 0/32996/0

(pkts output/bytes output) 44298787/8843339333

shape (average) cir 10000000, bc 80000, be 80000

target shape rate 10000000

 

Service-policy : Policy-CBWFQ-to-CE

 

queue stats for all priority classes:

Queueing

queue limit 64 packets

(queue depth/total drops/no-buffer drops) 0/0/0

(pkts output/bytes output) 4416218/902883751

 

Class-map: REALTIME (match-any)

4416218 packets, 902883751 bytes

5 minute offered rate 70000 bps, drop rate 0000 bps

Match: ip dscp ef (46)

2082 packets, 453054 bytes

5 minute rate 0 bps

Match: ip dscp cs5 (40)

4414136 packets, 902430697 bytes

5 minute rate 70000 bps

Priority: 20% (2000 kbps), burst bytes 50000, b/w exceed drops: 0

 

 

Class-map: CRITICAL-DATA (match-any)

4674 packets, 934930 bytes

5 minute offered rate 0000 bps, drop rate 0000 bps

Match: ip dscp cs6 (48)

1303 packets, 96410 bytes

5 minute rate 0 bps

Match: ip dscp af31 (26)

2250 packets, 558010 bytes

5 minute rate 0 bps

Match: ip dscp cs3 (24)

1121 packets, 280510 bytes

5 minute rate 0 bps

Queueing

queue limit 64 packets

(queue depth/total drops/no-buffer drops) 0/0/0

(pkts output/bytes output) 4674/934930

bandwidth 10% (1000 kbps)

 

Class-map: VIDEO (match-any)

5635 packets, 803772 bytes

5 minute offered rate 0000 bps, drop rate 0000 bps

Match: ip dscp af21 (18)

0 packets, 0 bytes

5 minute rate 0 bps

Match: ip dscp cs2 (16)

5635 packets, 803772 bytes

5 minute rate 0 bps

Queueing

queue limit 64 packets

(queue depth/total drops/no-buffer drops) 0/0/0

(pkts output/bytes output) 5635/803772

bandwidth 30% (3000 kbps)

 

Class-map: class-default (match-any)

39905257 packets, 7982704098 bytes

5 minute offered rate 147000 bps, drop rate 0000 bps

Match: any

Queueing

queue limit 64 packets

(queue depth/total drops/no-buffer drops/flowdrops) 0/32996/0/32996

(pkts output/bytes output) 39872260/7938716880

Fair-queue: per-flow queue limit 16 packets

Share this post


Link to post
Share on other sites

Мой 3750 не понимает команды bandwidth percent, я сделал так.

 

class-map match-all VIDEO

match ip dscp ef

match ip dscp cs5

!

!

policy-map Video_Sh

class VIDEO

police 5000000 8000 exceed-action drop

!

 

Никак не получается повесить эту политику на 11 интерфейс. Вот его настройки:

interface GigabitEthernet1/0/11

description !!!Of1-zelax!!!

no switchport

ip address 10.28.20.6 255.255.255.252

mls qos trust dscp

no mdix auto

no cdp enable

!

Вот что происходит при применении

 

(config-if)#service-policy input Video_Sh

QoS: class(VIDEO) match ip can be used only with match protocol in a match-all class [GigabitEthernet1/0/11]

Edited by Omax

Share this post


Link to post
Share on other sites

Попробую задать вопрос по другому. С маркировкой пакетов вроде разобрался. Как на 11 порту свича 3750 мне организовать преоритизацию, что бы пакеты маркированные под видео уходили первыми и,желательно, гарантировать им полосу пропускания в 4Мбита ?

 

ЗЫ Есть Вот ссылка. Тут как бы вроде все объясняется, но я как то не могу понять.

Edited by Omax

Share this post


Link to post
Share on other sites
...Приоритетная очередь обслуживается до тех пор, пока все пакеты не буду успешно переданы, после чего обслуживаются все другие очереди. Включение приоритетной очереди выполняется при помощи команды настройки интерфейса priority-queue out

полисить по полосе на свичах вроде 3750 на выходе можно только через

srr-queue bandwidth

подробнее смотрите раздел

 

Команды управления качеством (QoS) для исходящей очереди.

 

в общих чертах - на входе красите и режете лишнее если надо, на выходе в соотвествии с dscp раскладываете по очередям, процентное отношениие полосы по очередям можно задать. Если канал тонкий, указыаете его пропускную способность через

srr-queue bandwidth limit , емнип, процент этот ситается от скорости физики, т.е. если задать speed 10 и srr-queue bandwidth limit 10 - то это будет 1 мбит/с.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this