Jump to content
Калькуляторы

Помогите с настройкой интерфейса SNR-S3750G-48S-E

Здравствуйте!

Имеем небольшую сеть на полторы тыс абонов.

Сеть самая простая, группы абонов разбиты по подсетям.

 

Решили ее модернизировать, в ядро установили SNR-S3750G-48S-E.

Разбили все по виланам, работают.

Подскажите плз, как правильно настроить интерфейс, который смотрит в сторону роутера ( в нашем случае это: Ethernet1/0/1).

Дать ему айпи, сконфигурить и чтобы траф из всех виланов шел через этот интерфейс на роутер.

 

Спасибо!

Share this post


Link to post
Share on other sites

вы же уже разбили на вланы? как оно сейчас работает?

 

Да разобрал. Каждому вилану назначил айипи на свиче S3750G, с других свичей пробросил данные виланы до этого свича.

С портов свичей доступа, которые относятся к определенным виланам, компы пингуют свои маршруты по-умолчанию на S3750G.

 

Включил роутинг на S3750G. Но теперь надо назначить исходящему Ethernet1/0/1 айпишник и указать чтобы весть траф, уходил через этот интерфейс наружу.

 

Руководствовался этой статьей.

 

Вот цитата с нее:

Перевод интерфейса в режим 3го уровня

 

Интерфейс fa0/10 соединен с маршрутизатором. Этот интерфейс можно перевести в режим 3 уровня.

 

Перевод fa0/10 в режим интерфейса 3 уровня и задание IP-адреса:

 

sw3(config)#interface FastEthernet 0/10

sw3(config-if)# no switchport

sw3(config-if)# ip address 192.168.1.2 255.255.255.0

sw3(config-if)# no shutdown

 

Но этот свич команду "no switchport" не воспринимает в таком виде (нужно добавлять параметры)

и "ip address 192.168.1.2 255.255.255.0" не задается.

 

Извиняюсь за нубские вопросы. Читал мануал по этому свичу, но не смог разобраться с настройкой наружного интерфейса.

 

Спасибо за помощь!

Share this post


Link to post
Share on other sites

maverick5

не делайте no switchport. делайте interface vlan XXX, в нём поднимайте ip address, а потому на порт просто вешайте vlan XXX аксессом

Share this post


Link to post
Share on other sites

не делайте no switchport. делайте interface vlan XXX, в нём поднимайте ip address, а потому на порт просто вешайте vlan XXX аксессом

 

Как указать чтобы траф из всех виланов (если он не адресован в какой-нить из этих виланов) уходил через этот влан наружу?

Share this post


Link to post
Share on other sites

int vlan 666

ip address 192.168.1.2 255.255.255.0

no shut <-- скорее всего, не нужно, но бывает и нужно на некоторых свитчах с cisco-like CLI

exit

 

int fa0/10

switchport mode access

switchport access vlan 666

exit

 

ip route 0.0.0.0 0.0.0.0 192.168.1.1

Share this post


Link to post
Share on other sites

int vlan 666

ip address 192.168.1.2 255.255.255.0

no shut

exit

 

int fa0/10

switchport mode access

switchport access vlan 666

exit

 

ip route 0.0.0.0 0.0.0.0 192.168.1.1

 

Спасиб! Попробую ))

Share this post


Link to post
Share on other sites

возможно, ещё нужно явно создать vlan 666

 

да, надо создавать явно.

Спасибо еще раз

Share this post


Link to post
Share on other sites

int vlan 666

ip address 192.168.1.2 255.255.255.0

no shut <-- скорее всего, не нужно, но бывает и нужно на некоторых свитчах с cisco-like CLI

exit

 

int fa0/10

switchport mode access

switchport access vlan 666

exit

 

ip route 0.0.0.0 0.0.0.0 192.168.1.1

 

С клиентского компа 192.168.0.2 - пингуется, а 192.168.0.1 нет....

с самого свича 192.168.0.1 - пингуется.

 

Что-то не включил?

 

SNR-S3750G-48S-E(config)#show ip route
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
      O - OSPF, IA - OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2
      i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
      * - candidate default

Gateway of last resort is 192.168.0.1 to network 0.0.0.0

S*      0.0.0.0/0 [1/0] via 192.168.0.1, Vlan100  tag:0
C       10.0.0.0/9 is directly connected, Vlan1  tag:0
C       127.0.0.0/8 is directly connected, Loopback  tag:0
C       172.16.1.0/24 is directly connected, Vlan2  tag:0
C       172.16.2.0/24 is directly connected, Vlan101  tag:0
C       172.16.3.0/24 is directly connected, Vlan102  tag:0
C       192.168.0.0/24 is directly connected, Vlan100  tag:0
Total routes are : 7 item(s)

 

Комп, с которого пингую находится в 172.16.3.0

P.S. Чтобы не запутать никого. В примере (в статье) наружняя сеть 192.168.1.0, а у меня 192.168.0.0

на вилане, который наружу 192.168.0.2 айпи, а шлюз 192.168.0.1

Edited by maverick5

Share this post


Link to post
Share on other sites

всё это странно, вы пишите про 192.168.1.0/24, а в выводе 192.168.0.0/24

Пояснил выше )) Сорри.

Share this post


Link to post
Share on other sites

а, ну понятно, ваш роутер ничего не знает о клиенстких подсетях из сети 172.16/16. ищите как на нём добавить статический маршрут типа "172.16/16 via 192.168.0.2". если это что-то типа dlink dir300, то быстрее будет найти самому, чем спрашивать на форумах

Share this post


Link to post
Share on other sites

а, ну понятно, ваш роутер ничего не знает о клиенстких подсетях из сети 172.16/16. ищите как на нём добавить статический маршрут типа "172.16/16 via 192.168.0.2". если это что-то типа dlink dir300, то быстрее будет найти самому, чем спрашивать на форумах

не длинк. Прописал статику на нем, все ок.

Спасибо большое!

Share this post


Link to post
Share on other sites

Еще вопросик...

 

вот разделили сетку на виланы, например,

 

vlan 111 - 172.16.1.0/24

vlan 112 - 172.16.2.0/24

vlan 113 - 172.16.3.0/24

vlan 114 - 172.16.4.0/24

и т.д.

есть vlan 100 - 192.168.1.2 - на порту, который идет на шлюз

прописали ip route 0.0.0.0 0.0.0.0 192.168.1.1

 

Юзера ходят в нет из эих виланов без проблем.

есть еще vlan 115, в котором находятся сервера с сервисами (фильмы, музыка, etc..)

 

Как можно настроить маршрутизацию, чтобы компы из пользовательский виланов, видели сервера из вилана 115? Но при этом чтобы между пользовательскими виланами маршрутизации не было.

 

Спасибо!

Share this post


Link to post
Share on other sites

если ваш l3-свитч не умеет vrf и импорт-экспорт между ними, то делайте чтобы всё маршрутизировалось (полную l3-связность между хостами) и режьте ненужное ACL-ми

Share this post


Link to post
Share on other sites

если ваш l3-свитч не умеет vrf и импорт-экспорт между ними, то делайте чтобы всё маршрутизировалось (полную l3-связность между хостами) и режьте ненужное ACL-ми

 

Судя по описанию - умеет. Надо разобраться как это делается....

Edited by maverick5

Share this post


Link to post
Share on other sites

как это делается ищите на сайте Cisco. У SNR/DCN синтаксис оттуда срисован

Share this post


Link to post
Share on other sites

Что-то мне подсказывает, что человеку пока что не следует разбираться с импортом-экспортом в vrf, а стоит сделать как можно проще. А проще ACL ничего не существует.

Share this post


Link to post
Share on other sites

vurd

лично мне проще было бы vrf. потому что в ACL очень легко ошибиться(человеческий фактор), а vrf проще проверить (просто посмотреть таблицу роутинга по каждому vrf)

Share this post


Link to post
Share on other sites

vurd

лично мне проще было бы vrf. потому что в ACL очень легко ошибиться(человеческий фактор), а vrf проще проверить (просто посмотреть таблицу роутинга по каждому vrf)

Нашел кучу инфы относительно VRF, буду вникать..

 

Трудно рабочую плоскую сеть переделать на vlan-ы. Надо было раньше это делать.. Сейчас возникают моменты такого плана:

в порт маршрутизатора воткнут сегмент на тупых свичах и в этом сегменте имеется пара подсетей, типа, 10.100.10.0/24 и 10.100.11.0/24.

в access порт можно навесить только одну. Есть правда вариант объехать абонов и настрить всех в одну подсеть и в access их, стандартным образом. Но на этот момент народ будет без нета сидеть. Короче, работы - завались)

Share this post


Link to post
Share on other sites

 

Трудно рабочую плоскую сеть переделать на vlan-ы. Надо было раньше это делать.. Сейчас возникают моменты такого плана:

в порт маршрутизатора воткнут сегмент на тупых свичах и в этом сегменте имеется пара подсетей, типа, 10.100.10.0/24 и 10.100.11.0/24.

в access порт можно навесить только одну. Есть правда вариант объехать абонов и настрить всех в одну подсеть и в access их, стандартным образом. Но на этот момент народ будет без нета сидеть. Короче, работы - завались)

 

Используйте сеть бОльшего размера, например 10.100.10.0/23

Share this post


Link to post
Share on other sites

в access порт можно навесить только одну

Не в аксесс, на интерфейс vlan. А что, SNR ip address secondary не умеет?

Share this post


Link to post
Share on other sites

Используйте сеть бОльшего размера, например 10.100.10.0/23

 

А как в этом случае с адресами шлюзов быть?

10.100.10.1 и 10.100.11.1 Все равно у части абонентов надо исправлять

Share this post


Link to post
Share on other sites

А еще такой вопрос)))

 

Настроен порт как access на определенный vlan, например vlan 110

 

К этому порту подключена сетка из НЕуправляемых свичей. У всех абонов этой сетки айпишники данного вилана - все работает нормально...

Но вот появляется необходимость дать одному из пользователей в данной сетке белый айпи. Как-то можно его прикрутить???

 

Спасибо!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this