Jump to content
Калькуляторы

mikrotik 2wan-2lan

Здравствуйте,подскажите по настройкам mikrotik rb750.Схема такова-имеем провайдера,который по DHCP дает 2 подключения,хочется 2 порта провайдера воткнуть

в 2 порта микротика(eth1 и eth2) и забрать 2 канала (eth3 и eth4),eth3 и eth4 разные подсети (192.168.11.0/24 и 192.168.12.0/24), т.е. Lan1 получает интернет от Wan1, а Lan2 от Wan2. С портами eth3 и eth4 разобрался, а вот Wan1 и wan2 не получается... Поможите,люди,кто с микротиком на ТЫ...

Share this post


Link to post
Share on other sites

Что именно не получается?

Убираем ethernet1 и ethernet2 из бриджей (если таковые есть), вешаем dhcp client на оба интерфейса.

Далее создаем 2 таблицы маршрутизации - как минимум одна с Routing Mark (например eth2). Одна таблица маршрутизации (можно оставить по умолчанию) - через первый порт, второй - через второй порт.

И под конец в IP->Firewall->Mangle создаем правила для маршрутизации, указывая нужную Routing Mark для каждой сети.

Share this post


Link to post
Share on other sites

Что именно не получается?

Убираем ethernet1 и ethernet2 из бриджей (если таковые есть), вешаем dhcp client на оба интерфейса.

Далее создаем 2 таблицы маршрутизации - как минимум одна с Routing Mark (например eth2). Одна таблица маршрутизации (можно оставить по умолчанию) - через первый порт, второй - через второй порт.

И под конец в IP->Firewall->Mangle создаем правила для маршрутизации, указывая нужную Routing Mark для каждой сети.

Eth1 и eth2 и не были в бридже, dhcp1 client на eth1 и dhcp2 client соответственно на eth2 это понятно, а вот дальше ПОЖАЛУЙСТА по-шагово...

Share this post


Link to post
Share on other sites

niktv3000

такое делается с помощью vrf, даже работает на микротике

Share this post


Link to post
Share on other sites

Что именно не получается?

Убираем ethernet1 и ethernet2 из бриджей (если таковые есть), вешаем dhcp client на оба интерфейса.

Далее создаем 2 таблицы маршрутизации - как минимум одна с Routing Mark (например eth2). Одна таблица маршрутизации (можно оставить по умолчанию) - через первый порт, второй - через второй порт.

И под конец в IP->Firewall->Mangle создаем правила для маршрутизации, указывая нужную Routing Mark для каждой сети.

Eth1 и eth2 и не были в бридже, dhcp1 client на eth1 и dhcp2 client соответственно на eth2 это понятно, а вот дальше ПОЖАЛУЙСТА по-шагово...

Создаем маршрут по умолчанию через второй ethernet с меткой eth2:

/ip route add distance=1 gateway=eth2 routing-mark=eth2 dst-address=0.0.0.0/0

Указываем сеть 192.168.12.0/24 маршрутизировать через маршруты с меткой eth2:

/ip firewall mangle add action=mark-routing chain=prerouting new-routing-mark=eth2 src-address=192.168.12.0/24

 

Как-то так.

Share this post


Link to post
Share on other sites

Создаем маршрут по умолчанию через второй ethernet с меткой eth2:

/ip route add distance=1 gateway=eth2 routing-mark=eth2 dst-address=0.0.0.0/0

Указываем сеть 192.168.12.0/24 маршрутизировать через маршруты с меткой eth2:

/ip firewall mangle add action=mark-routing chain=prerouting new-routing-mark=eth2 src-address=192.168.12.0/24

 

Как-то так.

 

При создании /ip route add distance=1 gateway=eth2 routing-mark=eth2 dst-address=0.0.0.0/0

New Terminal ругается

invalid value for argument gw:

invalid value for argument address

input does not match any value of interface

invalid value for argument add

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this