Jump to content
Калькуляторы

Mikrotik BGP Странные глюки

Началось все в 0-00 1 января, рестартанула бгп сессия с ТТК, все само поднялось, но после этого с моих PI перестали быть доступны одноклассники, вконтакт, киви и еще пару направлений, думал может глюк тика, версия стояла старая 5.7, обновил на 5.26 и перешел на другой сервак, все стало ровно, проработало больше суток и вот опять тоже самое.

 

Как только раздисабливаю

add action=accept chain=AS20485-bgp-out disabled=no invert-match=no prefix=194.79.47.0/24 set-bgp-prepend-path=""

ну или любую строку для своей /24

сразу отваливается vk, ok через оба аплинка

 

traceroute to vk.com (87.240.131.118), 30 hops max, 60 byte packets

1 194.79.47.1 0.518 ms 0.325 ms 0.229 ms

2 83.229.242.221 0.712 ms 1.574 ms 1.454 ms

3 83.229.225.44 25.907 ms 26.194 ms 25.498 ms

4 37.29.2.173 25.887 ms 36.886 ms 37.29.2.175 26.082 ms

5 * * *

6 * * *

 

traceroute vk.com -n

traceroute to vk.com (87.240.131.99), 30 hops max, 60 byte packets

1 194.79.47.1 0.275 ms 0.142 ms 0.441 ms

2 217.150.45.18 5.745 ms 5.605 ms 5.851 ms

3 * * *

4 * * *

 

 

 

/routing filter
add action=accept chain=AS6854-bgp-out disabled=no invert-match=no prefix=194.79.47.0/24 set-bgp-prepend-path=""
add action=accept chain=AS6854-bgp-out disabled=no invert-match=no prefix=194.79.44.0/22 set-bgp-prepend-path=""
add action=discard chain=AS6854-bgp-out disabled=no invert-match=no set-bgp-prepend-path=""

add action=accept chain=AS20485-bgp-out disabled=yes invert-match=no prefix=194.79.44.0/24 set-bgp-prepend-path=""
add action=accept chain=AS20485-bgp-out disabled=yes invert-match=no prefix=194.79.45.0/24 set-bgp-prepend-path=""
add action=accept chain=AS20485-bgp-out disabled=yes invert-match=no prefix=194.79.46.0/24 set-bgp-prepend-path=""
add action=accept chain=AS20485-bgp-out disabled=no invert-match=no prefix=194.79.47.0/24 set-bgp-prepend-path=""
add action=accept chain=AS20485-bgp-out disabled=no invert-match=no prefix=194.79.44.0/22 set-bgp-prepend-path=""
add action=discard chain=AS20485-bgp-out disabled=no invert-match=no set-bgp-prepend-path=""
add action=accept chain=AS20485-bgp-in disabled=no invert-match=no prefix=0.0.0.0 prefix-length=0 set-bgp-prepend-path=""

add action=discard chain=AS20485-bgp-in disabled=no invert-match=no set-bgp-prepend-path=""
add action=accept chain=AS6854-bgp-in comment=inputdefault disabled=no invert-match=no prefix=0.0.0.0 prefix-length=0 set-bgp-prepend-path=""
add action=discard chain=AS6854-bgp-in disabled=no invert-match=no set-bgp-prepend-path=""

 

 

с выключенными фильтрами ок, вк пашут, а киви нет и еще пинг вырастает в два раза на все направления. Хотя если попробовать открывать все эти направления с ip выданных ТТК никаких проблем вообще не наблюдается.

 

PS: заметил, что не вижу анонса своих /24 подсетей , хотя тик их анонсирует

/routing bgp network
add disabled=no network=194.79.44.0/24 synchronize=no
add disabled=no network=194.79.45.0/24 synchronize=no
add disabled=no network=194.79.46.0/24 synchronize=no
add disabled=no network=194.79.47.0/24 synchronize=no
add disabled=no network=194.79.44.0/22 synchronize=no

 

пробую глянуть их извне и не вижу

 

AS58217> sho ip bgp 194.79.47.0/24

% Network not in table

Edited by Tem

Share this post


Link to post
Share on other sites

PS: заметил, что не вижу анонса своих /24 подсетей , хотя тик их анонсирует

пробую глянуть их извне и не вижу

 

AS58217> sho ip bgp 194.79.47.0/24

% Network not in table

 

В анонсах-то есть только /22.

Share this post


Link to post
Share on other sites

Что касается затыка - видно же, что траф от ВК заруливает в коджент и там дохнет. А со стороны ТТК есть прямой пир на ВК, только вас туда не анонсируют.

 

Я бы адресовал вопросы аплинку.

Share this post


Link to post
Share on other sites

Аплинка два, второй эксСинтерра, ныне мегафон

Share this post


Link to post
Share on other sites

При анонсировании море-специфик сети перестает анонсироваться более большая сеть. Это Микротик. У него фильтры на выход через попу работают.

Там еще дефолт балансится средствами PBR Микротика 2:1. Возможно, еще Микротик не всегда корректно детектит упавший линк на одного из аплинков.

Еще был паразитный VoIP траффик с микротика, который так и не выяснили откуда пришел и почему микротик генерил.

 

И еще - переходите на quagga и не мучайтесь. У вас же есть резервный роутер для этого.

Возможно еще придется поставить cacti для рисования графиков и netflow для снятия и анализа траффика.

Edited by vlad11

Share this post


Link to post
Share on other sites

быстро переползти на квагу не получится.

Попробовал добавить префикс /23, через пару минут он уже был в таблице, а с /24 так и не дождался.

Дефолт оставил только через одного аплинка, балланс временно убрал.

странно, что пинг с моих pi в два раза больше пинга с ip предоставленных ттк.

Share this post


Link to post
Share on other sites

Пинайте аплинков, чтоб разобрались со своими фильтрами /24

Вы ж сами понимаете, что раньше 12-го числа дождаться ответа от них не реально.

Share this post


Link to post
Share on other sites

Пинаю, ТТК траблтикет открыл, надеюсь решат раньше 12.

 

Я вот понять не могу, как только включаю фильтр на out /24 Сети через ТТК пинг на майл, гугл сразу становится норма, но отваливается ок и вк, А после выключения пинг до майла 120 мск, яндекс 80, зато соцсети пашут

Share this post


Link to post
Share on other sites

Пинаю, ТТК траблтикет открыл, надеюсь решат раньше 12.

 

Я вот понять не могу, как только включаю фильтр на out /24 Сети через ТТК пинг на майл, гугл сразу становится норма, но отваливается ок и вк, А после выключения пинг до майла 120 мск, яндекс 80, зато соцсети пашут

 

Это где-то фильтры у аплинков.

+ для нормализации пингов (назначения лучшего маршрута) и балансировки по каналам нужны будут комьюнити и пропуск через аплинков. у Микротика комьюнити реализованы еще через большую жопу.

Edited by vlad11

Share this post


Link to post
Share on other sites

Странно эти фильтры работают, сейчас вот опять включил правило

add action=accept chain=AS20485-bgp-out disabled=no invert-match=no prefix=194.79.47.0/24 set-bgp-prepend-path=""

 

и сразу появился маршрут

 

sho ip bgp 194.79.47.0/24
BGP routing table entry for 194.79.47.0/24
Paths: (1 available, best #1, table Default-IP-Routing-Table)
 Not advertised to any peer
 20870 20485 49545
   80.72.237.33 from 80.72.237.33 (10.123.0.211)
     Origin IGP, localpref 100, valid, external, best
     Community: 20485:11723 20870:223
     Last update: Sun Jan  4 18:52:00 2015

 

Но сразу отваливаются соцсети, уже реально мозг кипит.

Share this post


Link to post
Share on other sites

Но сразу отваливаются соцсети, уже реально мозг кипит.

 

Поставьте два микротика, каждый подключите к своему аплинку, тогда легко сможете управлять потоками трафика. В случае проблем с фильтрами сразу будете знать какому провайдеру звонить с жалобой.

Share this post


Link to post
Share on other sites

Но сразу отваливаются соцсети, уже реально мозг кипит.

 

Поставьте два микротика, каждый подключите к своему аплинку, тогда легко сможете управлять потоками трафика. В случае проблем с фильтрами сразу будете знать какому провайдеру звонить с жалобой.

 

Опа! Уже надо ставить второй микротик.

А может, Микротик в следующей версии прошивки сделает дебаг?

А как простите делать балансировку каналов?

А синхронизировать роутинг внутри AS?

Share this post


Link to post
Share on other sites

Но сразу отваливаются соцсети, уже реально мозг кипит.

 

Поставьте два микротика, каждый подключите к своему аплинку, тогда легко сможете управлять потоками трафика. В случае проблем с фильтрами сразу будете знать какому провайдеру звонить с жалобой.

 

Опа! Уже надо ставить второй микротик.

А может, Микротик в следующей версии прошивки сделает дебаг?

А как простите делать балансировку каналов?

А синхронизировать роутинг внутри AS?

А может просто не использовать это гавно с операторстве?

Я вот у себя пытаюсь полнлстью от них избавиться - да курс $ подкачал

Share this post


Link to post
Share on other sites

Я вот у себя пытаюсь полнлстью от них избавиться - да курс $ подкачал

В OpenWRT какой-нить зашейте на пробу - авось постабильнее работать начнет :)

Share this post


Link to post
Share on other sites

Но сразу отваливаются соцсети, уже реально мозг кипит.

 

Поставьте два микротика, каждый подключите к своему аплинку, тогда легко сможете управлять потоками трафика. В случае проблем с фильтрами сразу будете знать какому провайдеру звонить с жалобой.

А если 3 аплинка , то три тика ?

 

Я уже убрал анонс /24 сети, включал фулвью, один фиг затык идет, причем на двух аплинках.

traceroute to ulmart.ru (178.248.236.28), 30 hops max, 60 byte packets
1  194.79.47.1  0.188 ms  0.128 ms  0.273 ms
2  217.150.45.18  4.754 ms  5.281 ms  5.238 ms
3  * * *
4  * * *
5  * * *

 

 

traceroute to ulmart.ru (178.248.236.28), 30 hops max, 60 byte packets
1  194.79.47.1  0.296 ms  0.146 ms  0.381 ms
2  83.229.242.221  0.794 ms  0.684 ms  0.711 ms
3  83.229.225.44  47.875 ms  47.781 ms  47.830 ms
4  37.29.2.175  47.694 ms  47.672 ms 37.29.2.173  48.732 ms
5  217.150.58.134  26.036 ms  26.250 ms *
6  * * *
7  * * *
8  * * *

 

хотя в последнем видно, что до сети ТТК доходит.

 

PS: А почему при получение фулвью префиксы валятся так медленно ? за СУТКИ я получил 83 000 префиксов.

PPS: Какая версия из 6 ветки более мене стабильна, может апгрейднуться ?

Share this post


Link to post
Share on other sites

PS: А почему при получение фулвью префиксы валятся так медленно ? за СУТКИ я получил 83 000 префиксов.

PPS: Какая версия из 6 ветки более мене стабильна, может апгрейднуться ?

Мой позг точно вскипел. На квагге при падении пира и его подьеме весь fv через него вливается ну за минуту примерно. Комп под freebsd при этом довольно тупил. Теперь на brocade cer вообще ничего не замечаю, кроме записи в логах... А вообще-то, fv гораздо больше.

Share this post


Link to post
Share on other sites

Мой позг точно вскипел. На квагге при падении пира и его подьеме весь fv через него вливается ну за минуту примерно. Комп под freebsd при этом довольно тупил. Теперь на brocade cer вообще ничего не замечаю, кроме записи в логах... А вообще-то, fv гораздо больше.

я знаю, что их там овер 400к.

на кваге у меня заливается довольно шустро, но тут реально жесть

Edited by Tem

Share this post


Link to post
Share on other sites

их там овер 400к.

Овер 500к

 

на кваге у меня заливается довольно шустро, но тут реально жесть

Угу. Сколько же фэйловер отрабатываться будет?

Share this post


Link to post
Share on other sites

Блин, хрень какаято, юлмарт и киви запахали, я ничего не делал, заработало само, но пинг на майл, яндекс, вк дикий

вот майл с адресов ттк

HOST: office         Loss%   Snt   Last   Avg  Best  Wrst StDev
 1.|-- 83.234.46.113   0.0%    10    0.3   0.2   0.1   0.7   0.0
 2.|-- 217.150.45.18   0.0%    10    5.0   7.7   4.0  33.4   9.2
 3.|-- 188.43.8.129    0.0%    10   42.4  42.5  42.3  42.9   0.0
 4.|-- 94.100.180.202  0.0%    10   43.1  43.1  42.8  43.8   0.0

 

а вот с моих pi

HOST: pinger         Loss%   Snt   Last   Avg  Best  Wrst StDev
 1.|-- 194.79.47.1     0.0%    10    0.5   0.4   0.4   0.5   0.0
 2.|-- 217.150.45.18   0.0%    10    4.4   5.0   4.3   8.1   0.9
 3.|-- 188.43.8.129    0.0%    10  129.0 129.3 124.4 131.8   2.2
 4.|-- 217.69.139.202 20.0%    10  131.7 131.3 129.9 132.6   0.8

Share this post


Link to post
Share on other sites

Ваш аплинк вас явно не всем своим пирам анонсит. Looking glass-Ы в руки и искать проблему! Это явно не микротик виноват.

Share this post


Link to post
Share on other sites

Ваш аплинк вас явно не всем своим пирам анонсит. Looking glass-Ы в руки и искать проблему! Это явно не микротик виноват.

 

Тут на форуме тема была что микротик вис и глючил, помогла блокировка всего мусора на оборудовании перед ним, скорее всего и тут подобная проблема.

 

А может просто не использовать это гавно с операторстве?

Я вот у себя пытаюсь полнлстью от них избавиться - да курс $ подкачал

 

Нормально оно работает, тем более если вы его используете, то значит оно приносит определенный доход, который и окупает сеть. Если была бы возможность, давно бы циску поставили?

 

на кваге у меня заливается довольно шустро, но тут реально жесть

 

У меня на микротике за пару минут все принимается.

Share this post


Link to post
Share on other sites

Циска у "бюджетников" не в тренде, особенно под бгп. Очень редко попадаются серьезные гробы занедорого под это дело, как правило не у барыг. Остальное или не тянет по производительности, или не имеет нужного функционала, но если не нужен fv, то можно обойтись хоть копеечным 3550-м каталистом. Ну а так - или микротик или тазики, но опять же, в случае последнего, не стоит наваливать в коробку сразу все - и бгп, и нат, и шейперы. Глюки будут стопроцентно.

Share this post


Link to post
Share on other sites

Лучше уж 3550 за 100$ и мозг не парить этой херней

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this