Jump to content
Калькуляторы

Непонятная работа в псевдобридже.

Здравствуйте, есть проблема. Схематически представляю мою сеть. Это последняя на сегодняшний день версия настройки, все устройства в сети отлично работают и пингуются.

Теперь подробнее, из подъезда приходит витая пара, интернет от дом.ру, настроен роутер DIR-320, поднимает соединение PPPoE. Далее Mikrotik соединяется с AP TP-LINK 5210G, на расстоянии около 350 метров. В общем никаких технических и аппаратных проблем нет. Однако, в течении например дня, пропадает Интернет, причём сеть продолжает работать и все устройства отвечают на запросы. Проблема исчезает после перезагрузки Mikrotika, снова Интернет работает, всё «летает». Я имел опыт настройки и монтажа, радиомоста из пары lite 2 на 4.5 км, с идеальным эфиром, но практически перекрытой кронами деревьев, зоной Френеля. Настройка по схеме точка-точка, режим AP bridge-station WDS. Здесь же автоматом включается непонятный pseudobridge. Пожалуйста объясните доходчиво, что это, и как это едят.

PS Заранее спасибо

PSS Прошу сильно не ругать!

post-123867-014115300 1419839765_thumb.png

Share this post


Link to post
Share on other sites

Вам нужно поставить второй микротик на точку заместо тп-линка и все будет работать без проблем. Еще можно и роутер заменить тоже на микротик, что бы уйти от низкой производительность длинка.

Share this post


Link to post
Share on other sites

Спасибо за совет, но на данный момент нет возможности произвести замену оборудования. Да, действительно, попробовав однажды router OS и Mikrotik, нет никакого желания возвращаться на "хомячные" д и тп линки! Но как обычно желания не совпадают с возможностями. Нашёл временный выход из ситуации, настроил sheulder и теперь по расписанию в 7.32 происходит перезагрузка lite 2. Но всё равно инет пропадает рано или поздно.

PS Всех с наступающим,

Edited by adsl

Share this post


Link to post
Share on other sites

Спасибо за совет, но на данный момент нет возможности произвести замену оборудования. Да, действительно, попробовав однажды router OS и Mikrotik, нет никакого желания возвращаться на "хомячные" д и тп линки! Но как обычно желания не совпадают с возможностями. Нашёл временный выход из ситуации, настроил sheulder и теперь по расписанию в 7.32 происходит перезагрузка lite 2. Но всё равно инет пропадает рано или поздно.

PS Всех с наступающим,

Чуть красивее было бы использовать watchdog микротика. Настройте на ip адрес, который считаете более стабильным и пусть перезагружается, когда это необходимо, а не по расписанию.

Хотя, как по мне, лучше разобраться в причине падения канала. Сколько не сталкивался с тп-линками, ничего хорошего, кроме ценника, от них не удалось получить.

Edited by Saiko

Share this post


Link to post
Share on other sites

Настроил пса, теперь пингует Яндекс. Не понимаю, на каком "уровне" происходит падение канала. Локальная сеть продолжает работать т. е. все устройства исправны. Последний вариант был обновление прошивки с 6.22 до 6.24. Ситуация не изменилась. Правда после апдейта, не сделал сброс по дефолту, читал что не обязательно.

Share this post


Link to post
Share on other sites

Настроил пса, теперь пингует Яндекс. Не понимаю, на каком "уровне" происходит падение канала. Локальная сеть продолжает работать т. е. все устройства исправны. Последний вариант был обновление прошивки с 6.22 до 6.24. Ситуация не изменилась. Правда после апдейта, не сделал сброс по дефолту, читал что не обязательно.

 

После обновления не нужно ничего сбрасывать.

Share this post


Link to post
Share on other sites

Попробуйте использовать VLAN. В моем случае (мост из двух SXT-5hPnD, на дальнем конце моста несколько десятков хостов) линк стал намного стабильнее (по сравнению с псевдобриджем).

 

/interface vlan add interface=wlan1 l2mtu=2286 name=vlan1 vlan-id=1516

 

/interface bridge port add bridge=bridge1 interface=ether1 add bridge=bridge1 interface=vlan1

 

В Вашем случае я бы прошил TP-Link в DD-wrt или OpenWRT (если в родной прошивке нет VLAN-настроек).

 

С наступающим!

 

 

PS Еще добавлю, что такой с такой настройкой нет ограничений, связанных с особенностями 802.11 (например dhcp работает без проблем).

Edited by DAF

Share this post


Link to post
Share on other sites

Да, настроек vlan нет в 5210g, шить openwrt пока не хочется, давайс на гарантии. Заметил такую штуку, ip адрес Яндекса псом пингуется, но Интернет пропадает всё равно. Может что то с Dns у Микротикаа не всё впорядке?

Share this post


Link to post
Share on other sites

Pseudobridge - это режим работы МТ со сторонними АР, в принципе аналогичен Station WDS. Вы попробуйте сделать наоборот - пусть микротик станет АР в чистом 802.11, а тплинк - клиентом. Мало ли...

 

кстати, а при отпадании интернетов dir320 в сети тоже видно?

Share this post


Link to post
Share on other sites

Да, видно. И кроме этого, с Микротика пингуется все ip из интернета, через вкладку Tools проверял. Стоит lite 2 Перезагрузить и Интернет появляется. Кстати пес не ребутит мост, т.к. Яндекс пингуется.

Edited by adsl

Share this post


Link to post
Share on other sites

Конфигурацию сети нет возможности изменить, всё настроено, прокинуто, подключено. На Микротике, level 3.

Share this post


Link to post
Share on other sites

level3? Да тяжко жить с этими лицензиями

Тогда - обновляйте прошивку, сносите с микротика текущую конфигурацию и настраивайте заново с нуля. Это выглядит так, как будто в какой-то момент перестает работать bridge между eth и wlan. Покажите конфиг устройства, пожалуйста.

Если не поможет, то костыльно можете настроить ватчдог на пинг несуществующего локального адреса, примерно так:

/system watchdog set watchdog-address=192.168.254.254 no-ping-delay=600m

где

watchdog-address = несуществющий локальный IP

no-ping-delay = время после ребута, когда watchdog ping не будет пинговать этот самый адрес. 600минут для примера, ставьте как нравится.

Share this post


Link to post
Share on other sites

Но после падения Интернета, сеть продолжает работать, устройства до и после Микротика пингуются.

Выкладываю скрины, извиняюсь делал скрины из вэбморды со смартфона.

post-123867-053709300 1420714299_thumb.png

post-123867-014952700 1420714329_thumb.png

post-123867-027310300 1420714346_thumb.png

post-123867-098691800 1420714358_thumb.png

post-123867-021563900 1420714381_thumb.png

post-123867-038156100 1420714390_thumb.png

post-123867-089280500 1420714403_thumb.png

Share this post


Link to post
Share on other sites

В каком смысле падает интернет?

Основной шлюз пингуется? (я так понял tplink)

Следующий шлюз(соновной шлюз тп-линка)?

Внешний интефейс тп-линка?

ресурс в интернете? (8.8.8.8)

Share this post


Link to post
Share on other sites

Вам просто надо сбросить начальную конфигурацию и настроить с нуля по всем правилам.

Share this post


Link to post
Share on other sites

adsl

из скринов видно, что микротик работает на/поверх заводского конфига, а он ипанутый. Перенастрайвате с нуля антенну

Share this post


Link to post
Share on other sites

Т.е. System - Reset Configuration, далее как обычно: объединяю в мост wlan и eth0, настраиваю профиль шифрования, выставляю мощность, защитный интервал, скан лист дефолтный, сканирую эфир и подключаюсь к желаемой ТД. Естественно меняю пас на админку и айпишник настраиваю под свою сеть. Остальное пропишется автоматом?

Share this post


Link to post
Share on other sites

А больше ничего не надо. Разве что бриджу присвоить айпи

 

Upd в reset configuration поставить галку no default config, а дальше мактелнетом или винбоксом настраивать

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this