Jump to content
Калькуляторы

alex116

Пользователи
  • Content Count

    6
  • Joined

  • Last visited

About alex116

  • Rank
    Абитуриент
  1. Спасибо. Поизучаю тему. 623860, не самый последний. Но esx вряд ли косячит, там аптайм больше полугода, да и не одна виртуалка крутится на нем.
  2. Хочу вывести все не бинарные скрипты проверок на отдельную виртуалку через nrpe, не самую критически важную, посмотреть на поведением Load Average.
  3. Сейчас не могу проверить, это нужно опять дождаться такого же зависания. При нормальной работе изредка проскакивает такое: [root@graph /usr/local/libexec/nagios]# ps aux | grep Z USER PID %CPU %MEM VSZ RSS TT STAT STARTED TIME COMMAND nagios 50386 0.0 0.0 0 0 ?? Z 8:28AM 0:00.01 <defunct> nagios 50388 0.0 0.0 0 0 ?? Z 8:28AM 0:00.00 <defunct> root 50393 0.0 0.1 16424 1528 1 S+ 8:28AM 0:00.00 grep Z Только defunct выскакивает где-то один раз из 10 запросов, потом опять сразу же чисто.
  4. Чьи логи? Перечитал всё, что нашел. Ни ерроров, ни варнингов обнаружено не было. Да, читал в мануале к нагиосу, в разделе про производительность. Насколько я понял, пассивные проверки мы можем сделать для серверов, но от них нагрузка и так очень маленькая, ну.. 10-15 сервисов. Я не понимаю как можно сделать пассивную проверку для сетевого железа, чтобы, например, коммутатор отсылал раз в 3 минуты статус определенного порта. Или сама железка раз в n-минут сообщала о себе. Если есть пути, прошу указать, буду изучать. В итоге на какой версии сейчас всё это крутится?
  5. Всем добрый день. Настроен Nagios 3.4.1, FreeBSD 9. Настроено около 1000 сервисов. Всё это крутится на ВМ с esx 5.0. Мониторится в основном сетевое железо, по пингам и по snmp, намного меньше, но тоже есть всякие упсы и сервера. За 3-4 месяца этот нагиос два раза завис. Последний раз вчера ночью. Зайти в систему по ssh я смог, посмотрел топ, в нём около 100 зомби процессов. Поделитесь опытом, как найти на чем стопорится система? Рестартануть сервис нагиоса не получилось, просто виснет и не отрабатывает, отправить в ребут тоже не получилось, пришлось через консоль vsphere по жесткому ребутать виртуалку. Посоветуйте плз, как найти источник проблемы. Есть ещё график Load Average-загрузки, который мне не нравится. После перезагрузки это значение постепенно растет, хотя новые сервисы не добавляются. После включения системы LA-находится в раойне 0.5, через месяц работы среднее значение уходит в район 1.5.. Загрузка процессора при этом не меняется.
  6. Если не сложно, скиньте пожалуйста на ru.sobolev@gmail.com